PDA

View Full Version : Motion Modifier Expressions are somewhat cursed!!!



stealthoperator
11-17-2005, 03:02 PM
Hello.

I've read Jonny Gordens book about rigging and now, I'm messing around with a muscle-bone setup.

I found it very strange that when I assign the stretch-expression to my muscle bone in its motion options, sometimes the expression does someting completely wrong (like offsetting my bone.)
When assign the same expression to the zScale of my bone in the Graph-Editor, everything works fine.

When I look at the example rig which came with the book, the expression is assigned to the bone and is working. But when I open its properties, there is no formula and no channel assigned... strange.

I hope you understood what I mean...

Am I :screwy: or what?

cheers

Dodgy
11-17-2005, 03:58 PM
Do you have the expression in the right channel? Is it visible when you have the x position channel selected, or when you have the scale channel selected? I know It's kind of obvious, but that's what it sounds like....

stealthoperator
11-18-2005, 01:09 AM
Oh...yeah... I see. :bangwall:

I think I missunderstood the concept of the motion modifer-expressions.

Thanks a lot.

ercaxus
11-18-2005, 08:38 PM
have you tried RV_rigtools (http://www.topix.com/reevan/spine/) ? I believe it comes with a muscle bone plugin and it should be very easy to setup.

stealthoperator
11-19-2005, 06:59 AM
thanks ercaxus, that's in fact the reason I'm messing around myself with stretchy bones.
You know, I'm one of these jerky mac users, and RV-Tools are Win only. There are so many nice tools, we can't use!

maybe I'll change sometime. But then, I think I'd buy Messiah or so...

Thanks anyway!