View Full Version : NewTek Releases Eighth Free Texture Collection

11-17-2005, 09:41 AM
Fifty New Images Brings Free Resource for Digital Artists to 400 High Resolution Textures and Reference Images

NewTek, Inc., manufacturer of industry-leading 3D animation and video products, today announced the release of the eighth edition of NewTek's free Texture Collection. As with previous editions, this new set includes fifty high-resolution images useful for textures and reference available for free download at NewTek.com. The total number of free texture and reference images available from NewTek is now at 400. The eighth edition of the texture collection contains images in the categories Concrete, Nature, Landscape, Soil and Wood. The images are suitable for use as is, and most can be easily processed for seamless tiling as well.
Full Press Release... (http://www.newtek.com/news/releases/11-17-05a.html)

12-05-2005, 08:23 AM
I'm unable to access these, I get a log-in prompt, enter my username and password, and get a message that I don't have access to the admin area.

12-20-2005, 11:15 PM

Same problem here. I've used these collections all the time and for some reason it won't let me in now. The prompt for username and password specifically states it needs them for "Admin Area", and it definitely does not except my forum username and password.

Would be great if I could get back in. :)


12-21-2005, 09:01 AM
Hey! Im' having the same problemo here as wello!

Fix it Newtek!!!

I've even tried changing my password, and it doesn't work!

12-21-2005, 09:56 AM
Yep, no access here either, thought I was missing something, but I'm relieved to see others are having the same issue. What gives?

12-21-2005, 10:51 AM
no problems herew

12-21-2005, 10:52 AM
oops sorry hit 1 2 many keys

12-21-2005, 10:58 AM
There was talk some time ago about free presets, setups, models, etc. etc. similar to this, any chance of it really happening? Many ideas seem to just get 'lost in space' at NT.

12-21-2005, 12:04 PM
Okay, tried it again and now it does seem to be working, just used my username & pw from the forums (which is exactly what I tried this morning when it did not work)....