PDA

View Full Version : LW8.5, HyperVoxels, Self Shadows...bug?



StevenDS
11-13-2005, 11:35 AM
Hello to all!

I was playing around with LW8.5, setting up a simple HV particle emitter, and ran across a problem with the HV 'Self Shadows' option.

I did a search in the forums with keywords like: HyperVoxel, self shadows, etc, and didn't find a thread about this problem. I hope this hasn't been discussed before. If it has been I apologize.

I have a very basic scene with one emitter with HV 'Object Type' set to 'Surface'. When I turn on 'Self Shadows', it renders very badly.
:See attached image at bottom:

Now, with 'Self Shadows' off I'll get this:
http://home.comcast.net/~s.severson/HVProblems/SelfShadowOff_f26.jpg

Turn 'Self Shadows' on, I'll get this:
http://home.comcast.net/~s.severson/HVProblems/SelfShadowOn_f26.jpg

With 'Self Shadows' on AND jumping forward a few frames, more and more HVs will render correctly:

Frame 47:
http://home.comcast.net/~s.severson/HVProblems/SelfShadowOn_f47.jpg

Frame 57:
http://home.comcast.net/~s.severson/HVProblems/SelfShadowOn_f57.jpg

Frame 63:
http://home.comcast.net/~s.severson/HVProblems/SelfShadowOn_f63.jpg

I tried this same scene set up with my LW7.5d and with "Self Shadows' on, I'll get, well, no shadows at all.

Have other people seen this problem with LW8.5?
Am I overlooking one simple option or setting?

Even though this is a super simple scene I made just to play with HVs, here is the scene file:
http://home.comcast.net/~s.severson/HVProblems/Scene_01.zip

Any response is very appreciated!
Thanks in advance,
-Steven

marlo.steed
11-13-2005, 10:40 PM
I am sure I have seen this same phenomena before but you know, it was problably one of those things that I just decided not to pursue. Many of the features of Lightwave are like this, here is my standard approach with Lightwave:

Try this cool feature
Play with the preferences,
Find out what works and what doesn't
Ignore those that don't work (try not to play with those again)
Be happy that the limited capabilities work at all
Create some cool image

I don't think I am answering your question well but I have found that ignoring some features are better than banging your head against a brick wall; this maybe one of those.

zareh
11-14-2005, 02:38 AM
try using a spot light rather than a distant light.
make sure you have ray trace shadows turned on
in the render options panel.
:thumbsup:

StevenDS
11-14-2005, 05:20 PM
try using a spot light rather than a distant light.
make sure you have ray trace shadows turned on
in the render options panel.
:thumbsup:

Thanks but, done and done. Same problem.

.................................................. .

EDIT#2:
Would this be something for the 8.5 bugs sticky thread?

zareh
11-15-2005, 01:03 AM
I loaded your scene and you're right, it's a bug.
From what I can see, if you turn on "Self Shadows"
for a "surface" type HyperVoxel you get this
grainy render. I loaded the same scene into
LightWave 7.5c and it rendered fine, without
the grain. So I'd say this is a bug to report to
the sticky thread for 8.5. Make sure you include
your scene so the programmers at NewTek
can reproduce the bug.

Zareh