View Full Version : Removing Multiple Selection Sets

11-05-2005, 11:55 AM
Using LW 8.3 here. I need to BATCH ELIMINATE about 8000 selection sets. Converting objects from IGES to Lightwave, unfortunatly a bi product of doing this are the selection sets that are created from NURB objects coming from the IGES model. There is a way to eliminate these while in polytrans, but for somereason it is not working in Polytrans right now. It causes Polytrans to crash. So, Is there a way to multple remove selection sets in Lightwave8.3 Modeler. When the model is open, and F8 is pressed it gives you all these sets in a list. You would think that you can shift-click on these sets selecting multiple sets. But you can't. Not there. So once last time, is there another way to select or remove mutiple selection sets.

Thanks in advance.

11-05-2005, 08:44 PM
Here's a plug-in that removes all Selection Sets from all Points. I hope it's what you need.

Please be careful using it until you're sure it's doing the right thing. No warranty is given or implied, and I accept no liability for its use.

You should be able to add it with Utilities=>Add Plugin, and it will appear in the Additional menu.

One cosmetic anomaly is that after the plug-in executes, the first Selection Set will be selected in the lower right pull-down menu, even though it has been removed. If you choose "None" from the pulldown, or save the object, it will vanish.


P.S. I forgot to mention that this process may be fairly time-consuming. Selection set data (as all VMaps) are stored per point, so the plug-in must scan each point in the model, then clear each potential selection set from each point (i.e. number of points * number of selection sets). On my test models, it's almost instantaneous, but on the size of data you're talking about, it may take a while. I could probably rig a monitor (progress bar) for it if you find it would be helpful.

11-07-2005, 07:41 PM
Tried it and it seems to have done nothing. But that is hard to tell when there are over 68,000 selection sets. So I took a small part of the model. Something with 289 polys. There are about 100 selection sets for just this geometry. Ran it on this piece. Nothing gets removed. Same number of selection sets after the run as before.

Any further ideas or suggestions?

11-07-2005, 08:08 PM
Solved the problem. I did test your plugin on someting smaller and it works. Still don't know why it doesn't on the big stuff.

This has been solved by exporting the .lwo to an .obj and saying "No" on the "export selection sets as a group". Then reopening the .obj, everything is gone. Since I am starting with a non textured model, it isn't so bad, but if you have all the other stuff, weight, UV's and such, well I am still converting. we will see, but on a smaller version of the same thing, ot got rid of ALL the selection set data.


11-08-2005, 10:48 AM
Sorry it didn't work for you. The plug-in works on my test objects, so without a sample of a model where it doesn't work, it'll be impossible for me to debug.

With that size of data, I'm not really sure I want to even attempt it. Manipulation of VMaps via the plug-in interface is not incredibly well documented, so it isn't clear that I'd ever get it working on an LWO exported by Polytrans.

I think your best resolution is to get the Polytrans functionality working, and eliminate them up front. Otherwise, I'd recommend using your export to OBJ and re-import workaround.