View Full Version : scan directory removes pluggins???

10-28-2005, 11:26 AM
I goto edit pluggins, and then choose scan directory. I choose my root lightwave 8 directory. Says it found like 700+ pluggins. I goto my utilities additional and it only shows 8 pluggins?

Before I hit scan directory, it had like 50 pluggins in it. Where did they all go?
I thought maybe it was just my machine so I uninstalled LW8 and re-installed it, applied teh 8.5 patch. Copied pluggins and then hit scan directory.

My boss is having same issues on his machine as well. Any Ideas?

10-28-2005, 11:43 AM
Hi Joshuaz,

First try to select the Plugins directory inside the LightWave one. THings will go much faster and be more accurate. Secondly, are you sure you only have eight plug-ins and not eight groups of plug-ins? If you change the sort method at the bottom of the window you should see all the plug-ins that were added.


10-28-2005, 11:57 AM
I am not sure where you find the sort pluggins. I am assuming you are reffering to the edit pluggins, then choosing grouping method category or file. in that case, yes i can see the pluggins I seem to have lost, like fprime. I still expect to be able to launch pluggins taht i haven't catagorized in buttons through additional though.

I am pretty sure that they are not 8 groups. I also just tried to scan only the pluggins directory, but it seems to have no effect. Here is a picture of what I see when i select Utilities/Additional


10-28-2005, 01:01 PM
Ok I don't know whats going on now.
I deleted my cfg files and rescaned the directory again, and now they are all there.

Wierd cause I have tried deleting them before and rescanning and it didn't work. I even uninstalled, and reinstalled, scanned again, still problem.

This time I delete cfgs, and now it works. I don't know whats going different this time but it works so i am going to leave it. :)

Hope no one else is having this issue.

11-01-2005, 01:12 PM
having same issue with another computer using a different copy of lightwave... We even deleted the config files again and rescaned the plugins directory again, and still the additional menu is left with very few plugins showing up...

This is anoying because we are not sure how to fix it and it seems to be a consistant problem.

11-01-2005, 03:10 PM
Have you tried setting the menu to default. If default is grayed out, set menu to 7 then set to default.

11-02-2005, 02:54 AM
If the Additional dropdown is a little empty, then the plugins may have been assigned to menus.

If you have fewer in there, it doesn't necessarily mean they are not loaded. Use the menu editor to see where the commands are being assigned.

11-02-2005, 03:23 AM
Just to be sure you can remake your configs following these steps, if you need to:

WARNING! This will kill any customisations you have made, so it's a good idea to use the editors to save menus and shortcuts.

1. Load the Layout portion of LightWave;
2. Hit Alt F11 (or go into the Utilities Tab and click on the Edit Plug-Ins button) and then the Scan Directory button and point it to your LightWave plugins folder. It will scan the plug-ins and give you a message like "xxx Plug-Ins found in xxx files.";
3. Hit Alt F10 (or go to the Edit menu and choose Edit Menu Layout) and change the Presets menu to LightWave 7.5. Return to it and change it back to Default;
4. Hit Alt F9 (or go to the Edit menu and choose Edit Keyboard Shortcuts) and change the Presets menu to LightWave 7.5. Return to it and change it back to Default;
5. Now quit LightWave and start Modeler from your new icon;
6. Repeat steps 3 and 4 but be aware that the Preset Menu will only offer LightWave 7.0;
7. Quit Modeler and quit Hub too.


11-02-2005, 09:59 PM
Maybe that should become a sticky. :hey:
I was wondering do you have that post set up as a word doc or something so you can just paste it? I have been thinking of doing that with some of the repeat replys that I post to.

11-04-2005, 03:53 AM
Indeed. I post it so often that is has been mutated and improved, but yes, it is copied and pasted.