View Full Version : Network rendering

02-15-2003, 07:11 PM
Does anyone know of a good tutorial or know how to set up Screamernet in os 10.2? I have read the lightwave manual but it is pretty vague concerning Mac usage.

02-15-2003, 08:44 PM
Please visit www.catalystproductions.cc/screamernet for information on how to set up network rendering for Mac OS X. In the download for the Screamernet Controller is instructions (that will work with the ScreamerNet Controller or with Lightwave's controller)

-Jon Baker

02-15-2003, 08:49 PM
10.2 introduced a bug that effectively killed screamernet network rendering. As far as I know, Jonathan Baker's 'LWSN/OS10.2 fixer' is the only solution currently available (though I haven't tried plain vanilla screamernet with 10.2.4 yet):


... bottom of the page. You don't need to be using his ScreamerNet Controller for the 'fixer' to work, but I would highly recommend it. It just makes network rendering SO much easier.

02-15-2003, 10:40 PM
Thanks for your help guys, the hard part now should be getting the guys at the station to let me rename all the drives so they are compatable with lwsn. (macintosh_HD instead of macintosh HD)

02-16-2003, 08:58 AM
If you're talking about the remote nodes and the comments about network rendering in version 3.2, you actually don't have to remove the spaces on those computers, just the host computer (the computer with the content directory)

-Jon Baker

02-17-2003, 08:32 AM
NigelH, although I heard about the 10.2 bug with SN, I didn't bother with any network rendering during the lifespan of 10.2-10.2.2. After I had 10.2.3 up and running on two machines, there was a request by the LW development team for specific steps used to produce the error with network rendering. Since I had a functional network under 10.1, and had upgraded to 10.2, I attempted to duplicate the rendering error. End result: my network render was fine. I do not believe that network rendering is "broken" in 10.2.3 or later, whether there was a fix with 10.2.3 or whether it is appropriate post-install maintenance that allowed me to render effectively, I had three nodes (dual 800 and iBook) render a 60 frame test animation from the 7.5 content with all 60 framed distributed correctly and rendered correctly over the three nodes, using the built-in controller, and non of Jon's utilities.

Early releases of 10.2.x had issues with file/folder permissions, which you are able to correct using the Disk Utility - First Aid as of 10.2.3. This may have had some effect on the network rendering in earlier releases. I don't know what the problem was for network rendering, since I've never had my network fail rendering (except when trying to render a scene with Sasquatch or G2, in a cross-platform render farm).

02-17-2003, 10:27 AM
I agree, since I upgraded to 10.2.3 I have not had any problems with the network rendering. I have left the Jaguar fix on my website in case there are people who still experience problems.

02-24-2003, 08:03 AM
Do any of you guys have any idea why my rendered files would render out in different formats across a network?

I.E. My host machine renders the PICT format I specify, but my node 1 machine renders out a (.flx) file with no background.

I'm sure it's something I'm doing, but I can not figure it out.

The nodes obviously see each other or they wouldn't render at all right?

02-24-2003, 09:31 AM
If you have LWSN and the Lightwave Program files installed on each machine (instead of launching them through the mounted drive) there are a couple of problems that could be causing this. Open up Lightwave on the remote computer and go into the Render Options dialog. Check to see if you have the format options there. If you do, double-check your preferences path in your LWSN cmdLine. If you don't, you will probably need to reinstall Lightwave on that computer. If you just copied over the Lightwave directory, it will not work (or at least has not worked in my experience). You need to install it from the CD, which is really not a big deal if you just choose the "programs" only from the customize dialog. (Make sure if you have the 7.0 CD that you also install the update to 7.5).

One cause of this problem for me was updating to 10.2.3, and I had to reinstall Lightwave to get it to work. Someone suggested repairing disk permissions using Disk Utility would fix it, but that didn't work for me; reinstalling the program did.

Hope this helps...