View Full Version : Bridge tool / Create skin (bug?)

10-25-2005, 09:09 AM
Always when working on high desity meshes these tools seem to fail, the polys are all over the place.. http://erikalstad.com/smiley/Notsatisfied.gif

01-22-2006, 05:01 AM
Bump, video example attached.


01-22-2006, 08:06 AM
Hi erikals !

First thing is that I don't understand is why did you post this in feature requist forum if is a bug report :)? Other things i that i don't see clearly is what is the flow of this object/model. Is that smappler part inisde of bigger or in front of it :). Either way something messy is going on there but i have one suggestion.

Can you maybe try to cut/paste those polygons in new layer and then try to use brige ? Maybe it'll work then and if it does it shouldn't be problem to cut/paste it back in main layer and merge points. Not a perfect solution but maybe workaround :).


01-22-2006, 05:55 PM
Hi Lewis

Thank you for helping :)
True, should be posted in LW 8.5 bug thread, my mistake.

For the moment, the object in the video is just a test object, so it looks a bit messy, but the topology/mesh is fine, so no problems there.
I tried to use the trick by copying polys to a different layer but unfortunatly with same result.

I'll post this in the LW8.5-bug-thread instead, see if anyone has the same problem. ( hopefully :) ) http://www.newtek.com/forums/showthread.php?p=331840#post331840


01-23-2006, 09:55 AM
**** :(. BTW is there maybe 2 point polys inside mesh or maybe open edge somewhere (not merged/welded points) ? I know that rounder have issues when you try to do it on open edge but didn't know about this problem with bridge (i don't use it too much and few times i did it worked fine).

01-23-2006, 10:34 AM
Nope, I wish it was the case, but this must be a bug.
Here's a new test object http://www.erikalstad.com/cgtemp/BridgeToolBug_Test-01.lwo and video http://www.erikalstad.com/cgtemp/BridgeToolBug2.avi

On simpler geometry it seems to work fine though (sometimes)

01-23-2006, 10:40 AM
Hmm, wait a second I'm testing this now :). BTW this other video shows problem much more clear :).

01-23-2006, 10:52 AM
OK i tested this now and it is definately a BUG. I suspect it has something to do with angle/curvature and SIZE of object. After certian angle it becomes messy (in this case if you select 5 polys on each ring it'll work but it won't with 6). I tried single sided, double sided surfaces, no change. I tried fliping polys , no help either :(. I also tested with FLAT polygons (same segmented line as ring but straight) and it does work as long as both sides are pretty much same size in lenght (small tolerance is still OK) but untill one of those stripes become much longer than other I get same tha tproblem even with straight lines :(.

Only HALF workaround would be to bridge 5 at once and aonther one separately but you then need to delete 2 polys left inside which is biproduct of that bridging. It can be done easi on simple models but not so easy on comlicated ones :(.

Report this as BUG erikals 'coz it sure is :(

cheers and sorry i didn't help you to find perfect solution.

P.S. I'll test this in LW 8.0, 8.2 and 8.3 when i get home to see is it 8.5 only problem.

01-23-2006, 11:00 AM
Thanks Lewis,
Good to get it verified. I though it was very strange that none has reported this bug, seems to me that complex geometry isn't created too often in LW. Oh well.

Hehe, it seems to work fine when lines are paralell though :)

It's reported now as bug number #090 in the LW8.5 thread, hope they fix it as I'll be using this quite alot. (Edit: oh, btw, tested in LW8.5, same bug there)

Thanks for testing :)

01-23-2006, 11:51 AM
Hehe YES I know it's evident in 8.5 (i tested it in also) I just noted that i'll test in older 8.X versions to see is it 8.5 ONLY (wouldn't be first bug which is introduced in 8.5 :().

01-23-2006, 12:59 PM
Oops, me reading the sentences too fast again.. :foreheads

01-23-2006, 06:38 PM
I just tested in Lw 8.3 and that's messy even more :). I can't even bridge two of them without twisting polys between :). SO i guess 8.5 bridge is actually "advanced" comparing to older one ;).

01-23-2006, 07:33 PM
:) I have the "advanced" version.
Strange no one noticed this though. Very strange. I guess maybe it has to do with that complex models are not that often made..

NT, please fix :)

01-23-2006, 07:42 PM
hehe :)

Thing is that I wouldn't use bridge for operations we now used it to test so maybe that's why noone experienced it till now :). Those kind of things I'd do with smooth shift, multishift, bevels, size, extender and similar stuff. Aslo proton showed us bridge tool in action on some LW 8 videos when he was attaching premade hands to model without hands and it worked there :).