PDA

View Full Version : 64bit hypervoxel limit?



ehallein
10-16-2005, 09:39 PM
Hi,

Does anyone know if lightwave 64 changes the maximum hypervoxel particle number limit of 65535.

You can test this by creating a particle system with more than this many particles and adding hypervoxels to it, and see if it renders.

thanks in advance.
Evan

RedBull
10-17-2005, 01:00 AM
I don't believe that LW has a point limit for HV....
I just tried the 32bit version of LW8.5..

I tried 900,000 point limit, and birth rate of 1.2million points, without problem...(COOL!) Still a lot more room for more Zero's too.....

I believe 8.3 still had a 100,000 point limit for HV, it's now been removed...

ehallein
10-17-2005, 10:00 PM
Did you actually render out the hypervoxels? If I try to render out more that about 65000, it renders nothing.

emilc
10-18-2005, 08:53 AM
Quicktest for me

54700 particles render fine grey dots
107520 its all black

So it seems to me there is a limit..

btw I'm using 8.5

RedBull
10-18-2005, 04:01 PM
Sorry i may of got it wrong......
I didn't try and render them...

I tried again yesterday......

Viper will display 100,000 points now.....
Where as previous versions, would lock, at exactly 50% of the Viper preview.
And i would imagine, if Viper displays them LW should render them...
But maybe not.......

100,000 Crashed FPRIME........
I stupidly tried to use Fprime to see if it would render them quickly,
but i had to crash LW, to get my machine back again.....
When i tried it again, i used Viper once again displayed them, hit F9...
And when i came back, my machine had overheated, and shut itself off....
(Not LW's fault, My PC is on it's last legs)

I'm trying 88,000 now, it's sorting polygons, but not rendering
Viper once again displayed 88,000....
But i have a feeling pushing my CPU at 100% for such a long time,
is not great for my dying PC....

So it seems to of improved, Previously Viper could definately not render 100k.
But still not fixed, sorry....

hunter
10-18-2005, 04:46 PM
Same here. 70000 particles. Sits on sorting polygons. If I make 3 emmitters at 25000 particles each it's fine. If I then set them to the same blending group I'm right back to the sorting poly's hang. :agree:

ehallein
10-18-2005, 06:06 PM
thanks for checking it out, it seems like it is some internal problem of lightwave. Could anyone from Newtek verify this limit for us? I assume it has to do with the integer limit.

thanks

Jarno
10-18-2005, 11:23 PM
Yes, hypervoxels are limited to 65k particles. More than that and it is kabloowy.

---JvdL---

lardbros
10-19-2005, 02:57 PM
Oh my god!! This wasn't ever in the feature list? :)

I asked a question a while back about why my hypervoxels were disappearing after a certain frame in my animation... no-one mentioned this, and i never knew. Now i know... and i'm glad in a way that it wasn't me going mad. Hopefully this has been altered for 64-bit LW otherwise alot of peeps won't be pleased.