View Full Version : 8.5 Particle FX PROBLEMS!

10-11-2005, 11:42 AM
Ok, im going to stay calm, but please Newtek, can you stop screwing up stuff that was fine to begin with?

Someone please tell me if you have the same issues with 8.5?

Ok, to begin with, when loading scenes that are pfx intensive, with multiple emitters and SAVED pfx files, the scene loads up, then locksup into white.
NOW, if you hold down ctrl when the scene is loading, you may or may not get the scn to load right. BUT this shouldnt be happening if the pfx files are saved, LW should NOT try to calculate a freshly loaded scn.
Problem #2!
When youve got a scn of lets say 5 emitters, and 3 are saved pfx files, 2 are not, and you go to test the HVs in VIPER, you must HOLD Ctrl down so VIPER will render. THIS NEVER HAPPENED BEFORE 8.5! It gets worse, NOW you must also hold CTRL to RENDER FINAL FRAMES, PER FRAME!?
Ok so i thought, maybe LW is trying to calc the 2 other emitters. Nope, saved them as pfx files, still HAVE TO HOLD CTRL FOR LW TO DO FINAL RENDER even though VIPER works now?! again, prior versions of LW, you didnt have to worry about this when doing viper or renders.
Now this was from a scene made in 8.3, not sure how a fresh 8.5 scn works, will test....but this incompatiblity from 7-8-8.5 is just wrong and theres many other things different from 7.5 FX...
7.5 FX Browser worked like a charm, you could select multiple emitters, winds, collisions, all open panels and workflow was good...then 8 came around, now you can only have ONE fx panel open, and if you select one emitter, but had a different one selected in layouts dropdown, it goes to ****, and you end up editing the wrong emitter, or it doesnt take the input into FXbrowser!
Then of course in 8 came lockups, lockups that NEVER happened in 7.5.
Now they 'fixed' this in 8.5, where yes, 95% of time its worked fine, i can FINALLY abort FX or select a different window and come back to LW, hit abort and its fine...95%...still occasionally i get a lockup, but im starting to think it has to do with these new PFX and HV issues....

PLEASE someone test this out...

And please, NT! FIX these issues that werent there before!

10-11-2005, 12:12 PM

I can check this out tonite - maybe someone will confirm it earlier.
I'm now in the habit of keeping all prev LW versions available.
You might want to post a real simple "trouble" scene to make it easier.
I notice at the end you mention HV issues. Do HV's have to be involved or is it just particles?

I wouldn't post things like this . . .
:censored:Hi KRoo2,
I just wanted to let you know that HowardM & Mike Pauza are two of the best LW-pfx experts that aren't NewTek employees.

I only wish that Howard and Mike were signed up as part of the LW beta testing team.
That's the only way that future "challenges" ;D like this will be avoided.

10-11-2005, 12:14 PM
Cheers Greg!
Yes, HVs are needed for the VIPER issues...

Ya, I do need to hound Deuce to get me on the beta team, perhaps theyd like to hire me? ;)

10-11-2005, 12:28 PM
Ya, I do need to hound Deuce to get me on the beta team, perhaps theyd like to hire me? ;)
Do the first and maybe #2 will come out of it.

Either way - it would be cool.

10-11-2005, 12:31 PM
We've moved the thread to the support forum, where it belongs. Please post support issues and suspected bugs in the proper support forum.

Howard, we'll look into this as quickly as we can - basically any operational changes should have been documented, and the only operational changes I'm aware of are a change to the loading algorithm that should let scenes with particle dynamics load faster. Can you email content to Deuce?

10-11-2005, 01:50 PM
Ok, narrowing down the problem!
It appears to be an issue with emitters that have not been calculated or saved....LW is trying to calculate the pfx before letting viper render, so if you hit ctrl, it stops LW from calculating ....but again, you must hold CTRL down the entire time for Viper to work.
I am still getting lockups on loading, if you dont hold CTRL down as the scene loads in, and also when quiting a render or closing viper, or just doing something new to the scn, its as if LW is trying to always calculate any uncalculated particles (without an FXStart), and you must quickly hit CTRL before TOTAL WHITE mode happens...and there is no coming back...no matter how many times I hit CTRL...

Ill get a scene out to Deuce.

10-11-2005, 03:06 PM
Here guys, try loading this scene and tell me your troubles...


What happens to me, upon load, it locks up, if you dont hold down CTRL.
Once loaded, open up HV and Viper, select Scene Preview in Viper and make a preview.
Should sit there until you hit CTRL, and it will then start rendering....if you let go, it stops.
Try to render f9...nothing, unless you hit CTRL...
Again, if you remove the emitters that are not calulated and saved yet, it should work normally.
This wasnt an issue before.

Maybe this bug is just in my scene...

Bill Carey
10-11-2005, 05:28 PM
Well, it wasn't consistent for me at all. First time was the white screen of death. Second time it loaded up (slowly) and then locked when I tried to move the frame slider. Third time it loaded quickly with the control key pushed, then locked when I touched the frame slider. It also said I was missing the file in /shotend1, but I don't know if that did it in.


10-11-2005, 05:39 PM
Tried the file. LW seems to lock while loading but if you press ctrl it loads. If I move the slider at all then LW seems to lock up but if you press ctrl it unlocks. To move the slider in the test file I have to hold down the ctrl key or it locks up on me. It must be doing some kind of calculating. I set up a content dir similar to what LW was looking for so it only asks me about the one missing file in shotend1.

I didn't try viper yet.

10-11-2005, 10:08 PM
OK Howard,

In LW 8.2 I get messages that it can't load the pfx files & LW8.2 crashes (bye bye - no white screen).

LW8.3 says the same thing about the pfx files.
Plus I get the message:
No plug-in of type ImageFilterHandler found with name post_Alpha2
Then 8.3 gets stuck on loading until I press the Ctrl key. Same with Play.
Renders require pressing the Ctrl key too.

Tests with LW8.5 gives exactly the same results.

Question #1: How did you make this Scene and with which version?

10-12-2005, 03:44 AM
Post2alpha is just an Alpha filter plugin made by Al Street, not a problem if it doesnt load...

I originally made this scene in 8.3.

10-12-2005, 09:19 AM
Can you still load it into LW8.3? I can't.

10-12-2005, 09:23 AM
Same issues, need to use CTRL to get it to work....

10-12-2005, 02:52 PM
Hmm so if scene doesn't work properly in 8.3 (won't load if you don't hold CTRL) either maybe scene is broken afterall :)?

10-13-2005, 04:52 AM
well, Deuce has the scene now and is working on it so lets see what NT says.

yeah Lewis, this may be just some random combination coming from my scene, and may not be a major issue....

what im hoping is, that it doesnt really matter because LW9 will have a totally new FX engine or at least this one, re-written to be more robust and stable.
hoping.... :)

10-13-2005, 12:20 PM
well i can load the scene just fine

...but if you move the timeline or press play tho it takes a coupla minutes, the particles do appear and the calculation seems to be taking place.

it doesnt seem to be using the pfx files you saved.

also if i go to the properties for any dynamic object it takes ages to read the properties, and if i close the properties tab (cause i get sick of waiting and have a life to live, when the computer lets me)..lightwave quits.

only way to tell for sure would be to rebuild a similar setup with similar particle count, and save out pfx files from 8.5, and see if it works ok with an entirely 8.5 process.

my system specs:

x2 3800 @2220Mhz
2Gb Corsair Twinx
GeForce 6800GT (78.01) :devil: