PDA

View Full Version : Light escaping through object - like Pin Holes



Lude
10-11-2005, 10:51 AM
Hi guys got a wee problem.

Iím creating a pumpkin but my light seams to be coming out through areas it shouldnít like pin holes.

Any ideaís as to how to fix this?

Exception
10-11-2005, 12:04 PM
I am suspecting some tiny errors in the actual model file. Vertices which border polygons and so on. I would try making a sphere inside the pumpkin with a general hole in the area of the face. This ball should have its polygons facing inward. That would effectively stop that from happing.
Also, anti aliasing might minimize the noise.
thirdly, you can try to fix your object. I'm smelling an object import, if so, don't even try...

Lude
10-11-2005, 12:57 PM
Hi guys itís a model Iím making in Lightwave so to give u some idea of what might be going on hereís some screen shotís.

I get no light leaks when the object isnít frozen; Iím frizzing the object to cut the logo into it. But even before cutting the logo as soon as I freeze it the light leaks.

Lude
10-11-2005, 01:09 PM
ok I think it's fixed now - i tripled it, what a pain in the *** - gone is my clean model.

ACLOBO
10-11-2005, 01:22 PM
Yup, I was just about to suggest non-planar polys. These aren't an issue when working with subpatched objects, but as soon as you freeze, you will inevitably have some non-planars as your object is frozen to quads. trippling them makes sure that they are planar and not twisted and therefore, there should be no render errors. Until we get some kind of boolean functions that work with subpatched objects, you have to keep this in mind when working with frozen meshes.

-Adrian

Lude
10-11-2005, 03:16 PM
Hi there ACLOBO, i had had done the non-planar polys but it still did'nt work till i did al the for point polys. Bummer

Scott Gammans
10-11-2005, 04:03 PM
(1) Try making your surfaces double-sided. This will stop the raytraced light(s) from "leaking" through.

(2) Use shadow-mapped spotlights. The bug you are experiencing--and yes, it is a bug that occurs with all raytraced light types--does not occur with shadow-mapped shadows.

icon kid
05-16-2006, 06:21 PM
I'm new to this forum -- I joined because I was looking for an answer to the same bug reported in several threads including this one -- "leaking light rays." I haven't seen an official response to it yet. Before I found this forum, I made some graphic documentation on it. It's more than what one should post directly into a thread, so here is the URL to it -- at least it seems to corroborate some of the other posts.

http://www.jeffs-icons.com/3D/LLL/Lightwave_3D_Light_Leaks.html

icon kid
05-16-2006, 06:23 PM
I'm new to this forum -- I joined because I was looking for an answer to the same bug reported in several threads including this one -- "leaking light rays." I haven't seen an official response to it yet. Before I found this forum, I made some graphic documentation on it. It's more than what one should post directly into a thread, so here is the URL to it -- at least it seems to corroborate some of the other posts.

http://www.jeffs-icons.com/3D/LLL/Lightwave_3D_Light_Leaks.html