PDA

View Full Version : Hard body dynamics... confused



Exception
10-10-2005, 09:51 PM
Hi guys,

Im trying to use hard body dynamics for dropping a whole bunch of boxes into a single large box. So I made the large box, and the small one, set up a partigon emitter, and now... im confused... ->

If I use MD_Controller to set up the two objects, it works fine for just those two, but once I fire FX_Linker (which is a horrible stupid undoable thing in my opinion), and create the 100 or so boxes, once I run the md_controller solution calculation it doesnt work. the boxes no longer fall. This is with trying to input the gravity in both the particle emitter and the environment tab of MD.

If I use the Dynamics tab of each object, and add FX_Hard to both, set the big box to fixed, and then fire FX_Linker, all objects are fine, but once I press the calculate button it will start running but the boxes are all gone. They don't come back either.

What am I doing wrong? this should be easy right? Or do I need to go back to (shrug) Working Model to do this?

Dodgy
10-11-2005, 06:49 AM
Just duplicate your little box, in the same layer, into the positions you want them to drop from. Add hardfx to the boxes object, and set gravity to -9 in the hardfx settings (you don't need a gravity effect for this) Set the collision to nodes or box, and self collision to box(obviously, although if you can use Sphere and get away with it, this is much faster!). Add a Collision dynamic to the big box, setting it's Type to 'object' (or 'object advanced', if you get some interpenetration).

Depending on the size, you may need to lower the calculation resolution (in the file tab of HardFX) to something smaller. Smaller=slower.

Hit the calculate button and it should all fall together..