PDA

View Full Version : Preference Woes



marlo.steed
09-10-2005, 06:10 PM
I am using Lightwave 8.3 and have tried a couple of times to change the preferences - like update the plugins, or change the Content directory. No luck. I have tried trashing the prefs in the Library folder and that always worked in the past but Lightwave doesn't even seem to recreate the prefs. Am I missing something or what?

As it stands I have to rescan the plugins each time I use Layout or Modeler. Very frustrating. Any thoughts?

toby
09-11-2005, 01:28 AM
My only 'thought' (you asked!:D ) is that LW may be looking somewhere else for the preferences. The next time you quit layout or modeler, do a search for files by date, and you may be able to find the preferences it's using.

marlo.steed
09-11-2005, 03:27 PM
That is the problem - the prefs are not getting updated so when I do a search for prefs that are getting changed - nothing shows up.

It is wierd - I don't want to reinstall but perhaps that is the only thing left to try. Any other suggestions?

toby
09-11-2005, 04:30 PM
Could the pref files be write-protected? Sometimes that happens when you do an install.

marlo.steed
09-11-2005, 08:12 PM
I have moved the prefs out of the Prefence folder so I don't think that is the case - the pref files aren't there and they aren't getting recreated. This renders Lightwave basically useless because I have to change so many of the setting each time I use it. I tried using Disk Utilities and repaired permissions - no luck. Frustration growing...

Darth Mole
09-12-2005, 12:58 PM
Does 8.3 quit on closing?

eblu
09-12-2005, 03:04 PM
well, there is a place where you can direct Lightwave to look elsewhere for pref files...

the file "LightWave cmdLine" file found in your Lightwave "Programs" folder can be used to override lightwave's default path.

open it up and see if it has a "-D<pathGoesHere> " anywhere in it. usually its blank, but you may have changed it in the past and forgot about it.

but i don't think thats whats happening. delete your pref files... all of them (good luck finding them all) and then see what happens. it sounds like your prefs are corrupted. this can happen at any time LW crashes, and is the most likely answer to most preference problems.

marlo.steed
09-12-2005, 08:20 PM
eblu, the cmd line files were indeed the problem but for quite different reasons than your theory. The cmd line files contained a path name to an old volume name. I had changed the volume name when I was linking to another computer with the same volume name and hadn't considered that it would send Lightwave for flip. The solution was to set the volume name back to the original. Surely this is a problem with the way Lightwave is setup. I am sure I am not the first nor the last person to change volume names.

Thanks eblu for the hint. Things seem to be good once more.