View Full Version : how I fixed my hub problems

09-06-2005, 04:18 PM
Hi everyone, this is my first post here. I recently encoutered a problem with the hub where I couldn't switch over to layout from modeler and vice versa. Other weird things were happening as well. Basically I would get errors when pressing F12 in modeler in saying that modeler was not tied to the hub...which was weird.

I scoured the forums and found one guy who had a solution, but I decided to just put mine here as well just in case that didn't work for someone.

as funny as it is, all my problems went away when I got another problem with my computer. Basically my college's IT department put my computer on quaranteen because I supposedly had a virus (which I didn't...). During this time I could not connect to the internet. When I tried to load modeler during that time it took a loooong time to start up. Almost to the point where I thought it had frozen. Then it just worked... after that I hit F12 (just for the fun of it) and BAM! layout started! I was surprised. Now, as you can tell I have internet capabilities back and it is still working for me.

So, a possible fix would be to just unplug your ethernet cable and run modeler like that... I don't know if it will work for everyone, I'm just putting it here so that you guys can try it if nothing else has helped. I'm sorry if this fix has been discovered before...I couldn't find it with a search.

09-06-2005, 07:29 PM
As you are realizing, Lightwave uses the internet protocall to communicate between lyaout and modeler. Which is why one of the first thing(s) that get mentioned is how the firewall is setup. Because the firewall can block complete access to the internet as well as individual programs from accessing the internet using the protocall that Lightwave uses.
Not only do you have to tell the firewall that layout, modeler and the hub as complete access to the net, you also have to tell the firewall that the printer spooler has access as well. By not allowing the printer spooler access, lightwave will seam to hang, not totally loading. Disabling the firewall allows lightwave to finish loading. The only reason why I found this out about the printer spooler, is because the firewall would keep asking permission for the printer spooler everytime I accessed lightwave.
Another problem that can occur is the config file for the hub, if you have just upgraded to 8.3, it is possible for the config file to show 2 instances of modeler and/or layout. This is just only one reason why it is so important to delete the config files and start from scratch.

10-21-2005, 06:14 AM
I had the exact same problem, tried the above to no avail. It was only fixed when I updated the rainbow dongle drivers.

I had to shut down, remove dongle, restarted, uninstalled sentinel drivers, downloaded latest from rainbow site, installed those, shut down, put in dongle, restarted, & it all worked again.

It had stopped working after I installed a new firewire card & a new graphics card. not sure which did it, but hey....

10-21-2005, 10:57 AM
Does anyone know if Newtek intends to eliminate IP for communication in the Hub and use some other method of interprocess communication? Shared memory, message queues, mailboxes, pipes, etc. are all really good for purely local communication and don't involve a "vulnerable" component of the OS like the Internet stack.

Or maybe Newtek thinks someone will have Modeler and Layout on separate systems?