PDA

View Full Version : exclude object from shadow maps



mattyb
09-02-2005, 12:47 PM
It is possible to exclude an object from lights using shadow maps.

Turning them off in the object properties window doesn't work.

MonroePoteet
09-02-2005, 05:47 PM
It works for me. I'm running V8.2. I can disable it both from the Objects panel in the Light Properties, or the Lights panel in the Object Properties.

I wasn't sure if you meant just disabling the shadows on the Render Tab. I can disable them altogether, but it doesn't seem to allow only disabling "self shadow" or "cast shadow". In other words, if either of these buttons is set, it does both.

mTp

mattyb
09-02-2005, 06:24 PM
THanks for the help. I'm running 8.3 on a Mac.

I only clicked off the "cast Shadow" button in object properties... and didn't think to also turn off the self shadow. I guess because of the way the shadow maps are calculated you need to turn off both to see a change. In the end I suppose it makes sense.

Fortunately having the self shadow off for the onjects in wuestion shouldn't matter for the scene. I have some tiny ions fading in and out... the shadow maps are either full on or full off, so they don't like the fading objects. The shadows popped on before the ions were fully visible.

I guess this is why I don't use shadow maps much.