PDA

View Full Version : please help problems w/ my mac being sluggish



scottg
09-01-2005, 06:34 PM
Hi,
I'm new here, and new to the 3d world. I'm mostly a 2d artist and use photoshop. But I really love what I have been seeing done using 3d programs.

I looked but couldnt find anything to help me so I hope I'm not posting somthing that has been posted a lot before.

My powerbook g4 is running sluggish, while using lightwave 8.3. The computer has 2 gigs of DDR SDRAM & a 1.67 ghz powerpc g4 processor. The object I'm modeling in lightwave (from a 3dgarage.com tutorial package - the chandelier) is at about 111,000. While that seems large, the computer in the tutorial seems to be running much faster than mine. Is there anything I can do to speed up modeler and layout?

Thanks for any help

scott g
http://homepage.mac.com/scottgipson/PhotoAlbum1.html

unc1e meat
09-01-2005, 08:07 PM
I think it's just because the graphics card in your Powerbook is pretty good but I don't think it can handle rotating or moving objects over 100,000 polygons very smoothly. I don't think any of the Powerbook cards can really handle over 100,000 polygon objects very smoothly.

However, you could try the following:

1. turn the bounding box threshold down
2. turn off opengl textures or just turn down the resolution
3. turn off opengl transparency

scottg
09-01-2005, 09:51 PM
thanks unc1e
edit
**just found out I have the same card**


"Powerbook 17" 1.5ghz, 1gb RAM, ATI 9700 128mb"

how does you power book run with the ATI? better than the Powerbook cards?

And can I get one put in mine? or was that somthing that you had to special order from apple?

and i dont even know if a ati card and a powerbook card are the same thing
are they both graphics cards?

thanks again for your time

scottg
http://homepage.mac.com/scottgipson/PhotoAlbum1.html

scottg
09-01-2005, 11:24 PM
"turn the bounding box threshold down"

where is this?

thanks

scott

pantone
09-02-2005, 07:55 AM
Have you checked the power management setup in your system preferences?

I know powerbooks, by default, are setup for power conservation rather than speed.

Make sure your hard disk is set to never spin down and that the processor performance is set to highest.

wilgory
09-02-2005, 09:14 AM
I've found that LW can be sluggish compared to other applications even on my powermac. It isn't your powerbook its lw's old architecture and crippled opengl performance. I was working on a project in LW that involved huge models with 500 layers and many textures, parts, etc. When the client told me to animate it, I had to switch over to maya 7, which not only allowed me to interact with the entire object in real time while it was fully smooth shaded, couldn't even come close to this in LW on the same machine.
Try maya PL on your powerbook and see if it is your computer or your software.

Good luck.

Greg

unc1e meat
09-02-2005, 11:20 AM
Scott, sorry I forgot to mention where to find bounding box threshold. If you're in Layout, hit the "d" key on your keyboard. This brings up display options. All the settings I had mentioned in my previous post can be changed here.

Now to your next question:
Unfortunately, when you get a Powerbook or most other brand of laptops, you can't change the graphics card. It's a factory option pretty much. But don't worry though because the ATI card in our Powerbooks is pretty darn good.

Wilgory is also correct. LW is just slow in comparison to some other apps that use OpenGL. Hopefully this will change in the near future.

scottg
09-02-2005, 12:21 PM
thanks guys for the help

and unc1e no big deal I found the others with out much problem..I just need to learn more about this app. so I'll know things like that.

I will try maya one day but we have lightwave classes at the school I'm going to

thanks again

scottg

scottg
09-02-2005, 12:24 PM
"It isn't your powerbook its lw's old architecture and crippled opengl performance"

Greg
is this something that we can hope they will fix? Is it fixable for them?

I love the program . so I hope it is

scott

scottg
09-02-2005, 01:03 PM
hey pantone when you say "Make sure your hard disk is set to never spin down"

do you mean the box that says "put the hard disks to sleep when posable"?

thanks

scott