View Full Version : Remove background from a scene?

08-29-2005, 07:29 AM
I have some prebuilt scenes with my Lightwave 8, but when I render them to .avi and use in VT 4.5, they have a black background. When I try to chroma key the black it really cuts into the graphics and makes them look bad. Is there a way to remove the background when in scene editing or rendering? Thanks!!

08-29-2005, 11:19 AM
Investigate using an "alpha channel" to pass transparency information between applications. This is either a separate file sequence (per frame), or data contained within a 32-bit file format (e.g. TGA-32 or TIF-32) which indicates exactly where the background is visible through or around your rendered objects.

If you're trying to put a background behind rendered objects, it's best to import the background into LW before doing the rendering, especially if you're using anti-aliasing (AA). The AA along edges and with transparent portions of your rendered objects must decide on an "intermediate color" for the smoothed pixels. If your background is black, AA will use black, and you may end up with a thin black aura around your objects. But, if you import your background before doing the rendering, then the intermediate color used for AA-smoothed pixels will reflect the background.

Importing the background into LW also allows you to use it in reflected surfaces of the rendered objects.


08-31-2005, 06:00 AM
You need to make the original render in a form which can save the alpha chanel. - If you are going to VT then you probably need to be rendering an image sequence (or rtv) file NOT an AVI. Because VT can load a tga sequence as if it was already an rtv, you are best using .tga output. In fact you can actual save 2 image sequences at once - tick & give a filename for both image and alpha output in render options (easiest to use same name with an A on the end for the alpha). for soft edges/transparency/volumetrics you need to tick 'use fader alpha' this will give rgb images that look very clunky, but provide the information to let the alpha image fade forefround to background perfectly - without the black rimming mentioned in previous post.

P.S. as has been said many times, rendering direct to avi is asking for trouble, one glitch & you've wasted the whole render.
ALWAYS render image sequences, then you can pick up where you broke 'down, or correct a couple of images, or whatever.
With VT you can load a TGA sequence directly, otherwise you can always load the sequence in Layout's image editor, set it as background in 'compositing', set the camera to the same frame size, and re-render to avi with no AA - very fast.