View Full Version : Velvet/Felt for Jewellers Tray

kiwi dave
08-28-2005, 11:08 PM
I have to create a velvety texture for a job I am currently working on, and I was wondering if anyone out there has come across a tutorial for creating this using saslite?

I suppose the other question would be do I have to use Saslite?

All opinions and comments welcome.



08-29-2005, 02:08 PM
Hi Dave:

You may want to use a shader instead. There are a few velvet shader plugins for LW. Try doing a search of Flay (http://www.flay.com/) under their "Plugins" page using the search word "velvet." You should get five or so hits.

Also, Antti Järvelä has written a microfur shader for cloth and other material. See this discussion at:


Best of luck on your project.


08-29-2005, 04:37 PM
There is a nice little tutorial in "Lightwave 3D 8 Texturing" by Leigh van derByl
She uses a procedural and a gradient. Excellent read. You can find it at most book stores and Amazon.

kiwi dave
08-29-2005, 10:36 PM
Thanks guys! I've downloaded the velvet shader from Spinquad, and I've also got my hands on a copy of Lightwave 8 Texturing. Really want this job to look great, so I'm covering my bases.

Thanks for the info


Captain Obvious
08-30-2005, 06:04 AM
I also just downloaded the velvet plugin. It seems to work as advertised, but it seems to crash whenever radiosity is turned on. Can anyone comment on this?

08-30-2005, 06:35 AM
I also just downloaded the velvet plugin. It seems to work as advertised, but it seems to crash whenever radiosity is turned on. Can anyone comment on this?

Works fine on OSX though I've only tried it with a very simple test scene. - Baz

08-30-2005, 07:27 AM
I have a velvet plugin I got from......hmmm, flay I think. It works as advertised. I do not think Ive tested radiosity on it though.

Captain Obvious
08-30-2005, 07:29 AM
I'm also using OS X. It works just fine with normal lighting. Whenever I turn on radiosity, it just stalls at 'rendering polygons'. It doesn't really do anything.

08-30-2005, 07:35 AM
Sorry, I should have said, I tried it with radiosity and it was fine! - Baz

kiwi dave
08-30-2005, 01:50 PM
I tried the plugin on a simple scene in OSX and it crashed my computer everytime. Am I doing something wrong?

I selected the plugin and it told me two plugins had been installed, then I set up some basic surface attributes and chose velvet from the shaders drop-down. I left everything as default and hit F9 and boom. Meltdown!

Any tips?

08-30-2005, 03:24 PM
Sorry, that's exactly what I did, I only gave it some color and a bit of bump though.

08-30-2005, 04:48 PM
Last I knew, it only worked with 1 render thread on OS X. Big bummer since most Mac towers now are multiprocessor systems. I posted about this bug on the SpinQuad thread where the OS X version was announced, and never heard anything back.

kiwi dave
08-30-2005, 06:06 PM
That's what it is alright Weepul. I changed the number of threads to 1 and it works.

Bit of a bugger, but its always nice to no what's going on.



03-22-2007, 10:06 AM
Just downloaded this plug-in last night, and can't get it to successfully render. I am running OS 10.4.8 (I think) on a G4, with Lightwave 8.5. Multi-threading is set to 1, but I still get either a freeze during the render, or an all out crash.

If anyone has any advice, or even a sample file that works, I would really appreciate it.



04-03-2007, 02:01 AM
Here's an object with the shader applied. You should be able to just load and render. Just be absolutely sure your render threads are set to 1.

Cheers - Baz

04-03-2007, 05:09 PM
Works like a charm. Thanks for the assistance, Baz.

04-04-2007, 01:24 AM
My pleasure!

04-04-2007, 07:39 AM
Worked like a charm. Thanks for your assistance, Baz.

I am having the same problem that Captain Obvious mentioned when radiosity is on, but other than that it looks pretty slick.

Take care,