PDA

View Full Version : warping of rigged character in layout



JamesScottG
08-26-2005, 10:01 AM
I'm new to this so bear with me. Yesterday I made a test walk cycle with a humanlike character that I had rigged. When I opened the file up this morning, the character's body was warped and folding in on itself. Clicking Setup>Enable Deform pops the character into the proper position but I can't figure out how to get the rig working without the warping. All previously saved files are the same.
There were two objects in the scene. One rigged in modeler with skelegons was parented to the bone of another rigged in layout. They worked great yesterday. What am I doing wrong?

Dodgy
08-26-2005, 10:07 AM
Hmm, try selecting all you bones when they're in the rest position (matching the character's pose) then press 'r' to Rest them again, that should sort it out...

DigiLusionist
09-09-2005, 12:43 AM
Here's a problem I've been having in 8.3:

I have loaded a simple character into Layout to rig him, and everytime I finish doing so, and reloading him, the geometry is contorted and a mess.

The model has skelegons that have been converted. I parent bones, then record pivot rotations (having Autokey on as I do so).

Anyone know what the problem is? Thanks.

Dodgy
09-09-2005, 06:44 AM
Could you post me the character? I've never had any problems of this fashion...

DigiLusionist
09-09-2005, 09:57 AM
Thanks, Dodgy. Here's the image:

DigiLusionist
09-09-2005, 11:11 AM
Okay, Dodgy. I got the answer from CGTalk. Apparently, I need to go back to Frame 0 and deactivate all of the bones. Then I hit 'r' key to reset the bones. Everything works after that.

I don't remember having to do these two extra steps before. Kind of a pain.

meanlebh
09-09-2005, 11:12 AM
Not sure if this will help or not..but i have had the same issues from time to time, I don't really know what causes it do to so but I have found a way around it each time so far.....anyways, try to re-record the rest position of each bone at frame 0, after you reload the scene, after you have it all rigged....good luck.

meanlebh
09-09-2005, 11:13 AM
sorry about that, looks like we posted at the same time, glad you got it solved.