PDA

View Full Version : Possible Bug with Color Filter?



Mebek
08-22-2005, 01:29 PM
Here's a project I'm working on. It's a product for a client, and I've set it up with glass outside and the liquid inside, with all the refractions and air surfaces intact. What I'm doing is boosting the color filter of the liquid to 250% to get some deep colors (100% just wasn't enough). But this has introduced a refraction error into the final rendered output. Specifically, it's noticeable in the base of the bottle.

Attached are two images, the first one with the color filter set at 250%, and the second one at 100%. Nothing else was changed between the two images. Is this a bug?

Edit: I am using 8.3 build 801, native LW (can't afford FPrime).

Mebek
08-22-2005, 03:31 PM
After running a few more experiements, it looks like I am essentially increasing the contrast of anything that refracts through the liquid by increasing the color filter beyond 100%. Thus, the bright highlights that are caused by the HDRI image are showing up with more intensity in the 250% version than in the 100% version. It's not a refraction issue, since the glass is still refracting the same. We're just not seeing the intense highlights through the 100% filter nearly as well.

I've decided to go with a middle ground of 175%, so I still have some deep purples but it's also hiding those ugly highlights fairly well.

So, in the meantime, ignore my post. :)

toby
08-22-2005, 11:58 PM
You can't really call something a bug when you're pushing it past 100%! You're effectively trying to filter out 250% of the light, more light than exists.

Do you have transparency at 100%? Whenever I use a lot of color filter I have to max out the trans, because it gets more opaque-looking with so much light filtered out. I've never tried trans. at over 100%, could be fun, give it a shot but I take no responsibility!

Mebek
08-23-2005, 09:25 AM
I thought it was a bug because the refraction -appeared- to be doing some funky things that it wasn't supposed to do (that would have been a bug, if it were the case). And I'm not trying necessarily to have it be transparent, the over-saturated look of the color filter being beyond 100% is what I'm after. This liquid is supposed to be somewhat opaque, but it's a very deep color, something that can't be reproduced in the color channel alone. Like I said, a middle ground of 175% color filter gave me acceptable results.

toby
08-23-2005, 09:58 PM
That's what I'm saying - if you get render errors when pushing the software past 100%, it's not a bug, if it's a mathematical impossibility, or the software wasn't designed for it.

And I thought you might be able to get a deeper color with higher trans., but whatever works ~