PDA

View Full Version : surfacing errors



gpdesigner
08-13-2005, 06:41 AM
Hello all,
I am having a small issue with surfaces . .
has anyone seen this, and how the heck do I get rid of it cleanly. I tried to adjust the smoothing angle, this works somewhat but it has the predictable effect on the mesh in that the edges start to reveal themselves. . . it's a small issue I know and I am almost ready to live with it, but why should I...
any ideas?
gp

skanky
08-13-2005, 07:36 AM
coplanars? does unifying the polys do anything?

gpdesigner
08-13-2005, 08:31 AM
when you say unify do you mean join? or align?
gp

Orimar
08-13-2005, 01:24 PM
Hi GP:

It does look like a coplanar problem. Here's LW's online manual definition of "Coplanar:"

"Refers to two or more entities that lie on the same plane. Two planar surfaces, for example, that lie on the same 3-dimensional plane are considered coplanar. If these coplanar surfaces share a common edge, it is recommended that they be joined into a single surface."

So, what is recommended above and what skanky meant is to select the area effected and first merge points ("m" key or Detail > Points > Merge Points) and then unify the polygons (Shift "i" or Detail > Polygons > More > Unify Polys).

.O.

gpdesigner
08-14-2005, 08:04 AM
Orimar & skanky thanks for the help . . .
I went over the areas with a fine tooth comb, but couldn't find any coplanar poly's. I do know what they are, just didn't know thw term, in fact if you organic model and hit tab, you find out pretty quickly where the coplanar polys are.
I went over that area carefully and didn't find any dual points or stacked polys so it must be something else maybe . .
In this next section I am having the same issue, I even went so far as to delete all the polys in the area and rebuild it from scratch, but still I get the same result. There has got to be another expalnation . . .
Anyway thanks a lot for the help I appreciate it :D
gp

gpdesigner
08-14-2005, 08:06 AM
I just remembered, I have wieght maps applied on this mesh, do you think that is the cause . . . ? I will experiment and see . .
gp

gpdesigner
08-14-2005, 08:28 AM
Ok so I played around with the wieght map and got no change in the surface. Then it dawned on me that maybe I needed to relieve some of the "stress" on the poly's in that area so I tripled them and . . "Bammm" issue gone....
only problem is, the mesh is going to look really ugly if i just tripled random sections to get ride of this issue. Anyone have any real ideas, rather than my temporary fix . . :cool:
gp

Surrealist.
08-14-2005, 07:58 PM
Post a wire of your unfixed mesh, we'll get you going. :)

And also, you are using subpatch right?

gpdesigner
08-14-2005, 09:10 PM
Post a wire of your unfixed mesh, we'll get you going. :)
I actuall dont have an a version of the unfixed bow, I do have a version pre-freeze. I guess that will have to do. nothing special just you ordinary sub-patched mesh, some wieght map info, clean and simple.

http://www.graphicproduction.org/image_links/iweb/forum_images/galactica/nonfreeze.jpg



This is where I trippled the corrupted poly's, like i said for the most part, the mesh will be clean, until I start to randomly triple sections of poly's to get rid of the "coplanar" poly's. if that is what they are.

http://www.graphicproduction.org/image_links/iweb/forum_images/galactica/freeze.jpg

any ideas of how to get rid of the irregular poly's without adding a bunch of random triple poly's here and there would be bonus. Other than that what can I say :hey:

gp

Surrealist.
08-14-2005, 09:57 PM
Well, there should not be any irregular polys in subpatch mode. So tripple is not a solution I would live with.

In subpatch mode there are only a few hitches there could be, this may be a partial list but farily complete:

1) Doubled (coplanar) polys.
2) polygons not contiguous (not connected)
3) Ngons (larger than 4 points)
4) 2 point polys. This one can be a buggaboo as it sometimes does not register - even in the stat window! This happens to me continually when I weld points. At times clicking on the suspected polygon edge and then deselecting the polygon from another edge reveals the two point poly - even though it is not in the stats. Other times they will be in the stats and I can select and delete there.

I think you have a case of gremlins in the mesh. This is a condition where the problem is simple but for some reason will not show up under normal inspection.

A good test to perform is the add edges tool. If you click on the add edges tool and get an error message that it cannot build the object structure or some such thing, you have hidden gremlins in your mesh.

I know you did it already but I think you need to rebuild, but be extremely mindful of how many points you are selecting. Your mesh is not that complex it is farily straight forward. Someplace something got messed up and is hidden from view for whatever reason. It couold even be a problem with the weightmap. I don't Know.

Then there are those booleans, the one thing that I can't figure out. How are those connected?

But asside from that the boolean tools are not perfect. They can leave your mesh in very strange shape at times. This might even be left over from that. I don't know, just quessing.

With a textured wire of your bad object I could have been more precise.

If you were to post the object file, I would be more than glad to fix it for you. :) You could even email it if you cannot post.

[email protected]

Edit:Example below

MiniFireDragon
08-14-2005, 11:15 PM
What does it look like when you turn off double sided in the render mode and the surface?