View Full Version : File-sharing/Rendezvous and LW?

04-30-2003, 02:20 AM
Whenever I do a LW render I find that, post render, the Mac concerned (Quicksilver Dual G4) can't be connected to the rest of the network unless I reboot it first.

Has anyone come across problems with Mac networking/Rendezvous following a LW render?

05-01-2003, 05:53 AM
What, nobody? OK. Looks like it's just me then!!!
Ho hum.
Well....guess I'll jus...pack up my problems...and...(sob)...walk...away into the sunset.. :-)

05-01-2003, 09:38 AM
I dont understand the problem.
please describe your network environment a little, and give us some idea of the circumstances that cause this problem (software versions, os versions, if your actually rendering on the network, using LWSN, anything that you do that causes this problem).

i'm also wondering why you have used the word "Rendezvous" in this conext, as far as i know, there is almost no way for Lightwave to have any impact on a Rendezvous service.

05-01-2003, 12:40 PM
Network is very straightforward: One Dual G4; one iBook; one iMac. All connected together via cables and a simple 10/100 hub. All machines running OSX 10.2.3.
Running a single copy of LW 7.5 on the G4, which has 1.5Gb of installed RAM. (I'm not rendering across the network, as last time I used LWSN I nearly died of fright).

I can do all the normal file-sharing stuff that people do - ie log on to any machine from any machine and move files etc - UNLESS I've done a rendering operation in LW on the G4. If I then afterwards try to connect to the G4 from, say, the iBook...nothing. I get error 36, error 5000 or a 'TimeOut' countdown. Similarly, the G4 cannot 'see' the other machines either. I have to reboot the G4 for the errors to disappear, which they always do.

The only other software I use regularly on the G4 is Photoshop, during or after which the problem NEVER occurs.

I was wondering whether it may be a RAM problem? Is LW not releasing RAM after rendering and somehow preventing system operations?

Yeah, Rendezvous is probably a red herring...

05-01-2003, 01:02 PM
sounds like the g4 is experiencing a crashed network service of some sort. Its definetly a software problem, and seems centralized to the g4.
instead of rebooting, try to log out and log back in. If that works, then you at least save some time, if not, then its a problem closer to the "core" of the os, and there Should be other people experiencing this issue.

as for whats causing it... thats problematic. LW should not be capable of hurting the network subsystem of Os X.
are the Other machines running os X (i'm guessing yes)?
if they are running os 9 then we're looking at a possible failure of appletalk, and not appletalk IP. Appletalk is a little less robust than Appletalk IP.
when you render are you connected to any of the other machines? perhaps active connections get squashed.
when you quit out of Lightwave, does Lightwave crash? this can be caused by bad preference files, and shouldnt, but can, affect the system.
When you render, do the renders take all night? are they cpu intensive and long duration renders?

at this point i suggest the normal voodoo approach to the problem, delete your pref files, run techtool, if you can duplicate the problem send a note to [email protected] I dont know of anthing in LW that should interact with the network, nor do i see anything in your description that jumps off the page as a cause for this problem.

05-12-2004, 09:46 AM
I experience similar problems. Other people on my Mac network cannont connect to my machine while I'm rendering LW animations. After rebooting the problem goes away until I start rendering again.

05-12-2004, 11:45 AM
Hello dbrearley. Coo, this thread has suddenly reappeared after a whole year of silence!

Unfortunately I'm still having the same problem; still unresolved. Glad it's not just me though!

05-12-2004, 01:30 PM
Are either of you utilizing the Hub? The hub is a TCP/IP application, and may tie up the network ports on the machine (although I've never tested this issue). If you are using it, try disabling the Hub when you are rendering -- edit the Lightwave cmdline file and add -0 (that's dash zero) at the very beginning. This disables the Hub. Does that solve your problem?

05-13-2004, 04:06 AM
Nope! Nice try tho', thanks.

05-13-2004, 09:51 AM
Two things
can the other machines on the network communicate with each other (and not the G4) when the G4 connection has gone down?

Launch Applications/Utilities/Network Utility
In the info window make sure you've selected "Ethernet Interface (en0)" which should have the Link Status: Active before rendering.
Go through your normal routine that ends with your network not working (leave this application open in the background). When you have verified your network connections are down, check this again. If the status has gone inactive, something has disabled your network port. If the status is still active, check the transfer status to see where in the data transfer is stalling. Let me know what the result is, please.

05-13-2004, 01:42 PM
1) Yes, the other machines on the network are still able to communicate when the G4 is down.

2) I've followed your instructions. With Network Utility up in the background with 'Link Status: Active', and after a render of 50 frames leading to an output of a QT movie, the G4 was unable to see or be seen on the network.

Link Status is still Active, so as you say I guess the port is still enabled. The Transfer Statistics lists the following:

Sent Packets: 502
Send Errors: 0
Recd Packets: 2482
Recd Errors: 671
Collisions: 0

Sorry, I don't know what any of this means! (The numbers that are not '0' above are steadily increasing as I watch)

05-13-2004, 01:50 PM
Can that G4 connect to the internet, or is it also not working at that point?

If the internet works but not the rest, turn off Appletalk but leave file sharing on. See if Rendezvous or IP sharing works.

If the internet doesn't work, I still gotta ask -- is the hub running?

The information you've given me says that your machine is able to transmit data out, but unable to receive it back.

Does it occur regardless of what type of render you make (QT movie, RGB images, Alpha images, or image savers via image processing/image filters?

05-13-2004, 02:13 PM
Yes, the G4 will still connect to the internet. (Via built in 56k modem)

Appletalk off. (Tried both on and off)
Hub. (Tried both with and without, following your earlier post)

Renders. Sometimes the system WILL remain visible if I do a single F9, or just a few frames of anim. at low-res. Anything hi-res or lengthy the system will certainly disappear off the network.

My theory, as I think I said when I first posted this topic last year, is that it 'feels' like a memory issue. I've experimented with different segment settings and thread settings, but to no avail...

05-13-2004, 02:30 PM
There is a great system utility called MenuMeters that tracks memory usage, CPU usage, network throughput, and a few other things. You might try installing it on the G4 and seeing what it shows.

As far as the dropout, does it happen with every method of rendering (I listed a few)? I'd also consider upgrading to 10.2.8 (assuming you weren't typo with 10.2 v. 10.3) There may have been a network upgrade somewhere in there. If you are running 10.3.3 on all machines, let me know, I'll keep on this now that it's back around.

05-14-2004, 03:25 AM
Thanks, I'll see if I can find MenuMeters and give it a whirl.

The drop out does seem to happen with every rendering method, MOST of the time.

On the system side, since my post last year I've moved the G4 forward as far as 10.2.6. The other machines are running 10.3.3. My instinct, as you suggest, is to get the G4 to 10.3.3 as well, but so far I've held off 'cos of all the chat about LW 7.5 and Panther. (Has that been resolved yet, do you know?)

As with all things there's a balance between getting work done and taking the system down in order to tinker with it. As it happens I'm right in the middle of a longish project and am reluctant to do massive software upgrades/reinstalls...you know what it's like!

Having said that, I think an upgrade to Panther might also help to 'clean up' the system generally, and who knows maybe the problem will be swept away.

I'll report back on this thread if there are any developments.