View Full Version : Matte Problems

08-08-2005, 07:07 AM
I have a question regarding the matte procedure for objects. I want to have one object be visible and another to matte out part of the object as it obscures parts of the first. Pretty simple, I've an umbilical cord wrapped around a fetus and want everything but the cord to be a matte object.
However, I cannot get the fetus, etc. to be black. It'll be a shade of gray or some funky kinda pattern, but not black.
I've checked off matte item, set the color to black and tried each of the three surface options, but no black matte objects. I've even turned off all diffusion, turned off all textures and shaders and still no black matte objects.
What is up? Is there a bug for creating matte objects? Is there a process not outlined in the manual? Thsi should be a simple process, instead its a headache at the end of a project.

08-08-2005, 07:21 AM
Hm, try rendering in one segment, set the render to use one thread only and see if that helps.


08-08-2005, 07:30 AM
Did those things. No joy.
I took the image into Photoshop and created what I needed there. This worked because I had only 1 frame to fix.
Thanks for the suggestions. I seen to remember having this problem another time with version 8 (I'm using 8.3). I hoped it had been fixed.

08-08-2005, 09:06 AM
i once solved this same problem by making sure the luminosity channel was set to zero, which it originally had not been.

08-08-2005, 10:48 PM
The Matte Object function can give you weird patterns, it's a bug, so don't use it at all. Rendering with 1 thread will sometimes fix it.

Save your objects as a Matte version, change the surfaces to jet black, set the surface's alpha ( in the advanced tab ) to 'unaffected by surface', and set the objects properties to 'unseen by rays'.

08-09-2005, 06:27 AM
Thanks Toby and all. I wound up using a workaround.
Has this really been broken since L8. I remember trying to use it then and it didn't work in the same way.

08-09-2005, 10:01 AM
I's been like that since it was introduced in 7.5 - it works more often than not :o