View Full Version : Skytracer (not skytracer2)

Bill Carey
07-30-2005, 08:04 AM
I've been playing with skytracer recently and prefer the interface to skytracer2. (Why did they change the sun placement from a simple heading and pitch to that odd where's waldo system? but anyway...)

It worked the first couple times, now it won't keep a setting. Or, rather, I can't get the settings to change. I read there was some kind of file path bug, I don't know if it's related to that or not. When I try to load or save settings it goes to c:\temp. Is there some thing I need to add to the config file to get it to work right?

I googled, but information on the old skytracer is pretty slim.

Using 8.3 on a PC, windows xp pro.

08-01-2005, 09:12 AM
can't find any separate config files for skytracer anywhere.
been saving skytracer settings in same folder as scene file. (.skt extension)
something is remembering the last folder for me. haven't tried looking for a line in
the standard configs. just cleaned those out (what i was looking for over here)
had a set in each and every user folder on a triple boot machine for 3 versions of lw and it kept loading the wrong ones for the wrong progs. can dig around some later (after i get all paths straight) if you still need more info.
did find out can move light around in scene like any other light after created in both 1 and 2 (or apply to existing light in skytracer) then just rerun skytracer for preview or render.
but then again i'm just fuzzy :)

Bill Carey
08-03-2005, 04:21 PM
Thought I replied before, it never showed up. Anyway...

Thanks for the response. If you get a chance to see where it stores it's settings, great. I'd like to understand a little more of how this plugin works.


08-04-2005, 09:54 AM
well, think i got my configs rebuilt. can't find any external references, everything seems to be in the scene file. deciphered most of the settings but there are are few interesting looking ones unidentified. annotated what i could figure and attached hereto.
near as i can tell, heading and pitch have no effect in render, only preview, and settings not saved. light behavior entirely dependant on parent.

Bill Carey
08-06-2005, 04:41 AM
Thanks, that looks like great and I'll save it for reference. Looks like I'm headed for a reinstall. Now even skytracer2 won't work. Something must have gone haywaire along the way, there are config files all over the place. Some were used a week ago, some a day ago, some now all with the same name. Are you supposed to have NTUSER.DAT files in a dozen different spots? It seems to picking where it wants to write to at random.

It's time to punt (American football for I give up)

Thanks again.

Post note:
I didn't quite give up. I killed the hub and both skytracer and skytracer2 work again. I'm not sure if I'll try to figure it out or just get used to working with out it.

Thanks again!

08-06-2005, 09:16 AM
same thing i was fighting. moved the best configs to /config folder and deleted the rest. so far, so good. should be one ntuser.dat in each user profile, do not delete! registry!
try deleting the hub config and let it rebuild, maybe. hub is cause of a lot of instability, but that autosave that keeps saving my butt is worth it.

Bill Carey
08-06-2005, 02:44 PM
Do you mean the /config directory under windows? Mines empty, all the config files are under my user profile. Will LW find them there?

Also, the NTUSER.DAT file in my profile is almost 10 megs in size, the others are 256K, same for you? And final question for this round, the only config file I have for the hub is in my temp folder. I clean that out on a regular basis, is there another one? Sorry for being stupid, but until now lightwave just worked, I never had to find out how.

08-06-2005, 06:45 PM
made new /config in lw directory
couple of threads on here about moving the .cfg's :
http://vbulletin.newtek.com/showthread.php?t=37238 this one starts out mac and ends up pc but point is, if default location need quotes to recognize spaces in path.
but i'm just using mine as backup, not using to launch. not sure if i've run 8.5 or 9.0 since cleanup. know i've not run any from xp 32 bit. so i might still have to go the -c config route yet, but don't think you will.
under xp 32 all configs and big ntuser.dat in my user profile.
under xp 64 all in administrator for some reason(big ntuser.dat, too). logging on as me so don't know why.
have: bandsaw.cfg, lw8.cfg, lwext8.cfg, lwhub8.cfg, lwm8.cfg, lwmasters8.cfg, lwmotionmixer.cfg, lwpc_edgebevel.cfg, and a few more plugin related files that have different extensions: couple of gs_cr2 files, rounderconfigs.txt
all this stuff is in profile directory (administrator for mine, xp-64)
in the temp\lwhub\ directory just sequential backups of lwext8.cfg and 192 megs of objects, scenes and layers.

Bill Carey
08-06-2005, 09:43 PM
Thanks, I really appreciate the help. I saved those pages off so I don't lose that info. I swear there was no LWHUB8.CFG file when I was looking earlier. After I deleted everything in the temp folder and turned the hub back on there it was. There was also only one .arc file in the temp folder, now there are 7. Skytracer now works, I think you're right about it saving settings in the scene file, saving the scene seems to be the key to getting it to work properly.

Again, thanks for the help, I'm calling this one closed for the moment. (I'm going to back up the config files, seems like a good idea.)