View Full Version : Layout crashes on Clear Scene

Adrian Lopez
02-14-2003, 11:44 PM
I'm having problems with Layout crashing on me when I clear the scene. The bug manifests itself when I do the following:[list=1]
Run Layout.
Open "Characters/Endo-Dog.lws" in Layout.
Run Modeler by clicking on the Modeler button in Layout.
In Modeler, choose "Synchronize Layout" from the pop-up menu, or modify some geometry.
In Layout, choose "Clear Scene" from the File Menu.
[/list=1]Following these steps causes Layout to crash with the message: "lightwav.exe has encountered a problem and needs to close. We are sorry for the inconvenience." Windows reports the following error signature: "Appname: lightwav.exe AppVer: ModName: lwtools3.dll ModVer: Offset: 0002efdc". If I call up Microsoft's Visual C++ debugger I get a message that reads: "Unhandled exception in LightWav.exe (LWTOOLS3.DLL): 0xC0000005: Access Violation."

The same thing happens when I open "MeniThings\Drone_EndomorphCrowd.lws" and follow the steps above. I'm running Lightwave 7.5 on Windows XP Home, with 128MB RAM. Has anybody else encountered this bug? Is Newtek working on fixing it?

I wish Newtek would do more frequent bugfix releases. It's not the first time (http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&q=lwtools3.dll&sa=N&tab=wg) lwtools3.dll has caused problems.

02-15-2003, 10:42 AM
you can actually get Win XP to run on 128 megs ram????
And LW at the same time?????

I thought Win XP took 75 megs just to turn on the boot screen when you hit your start switch on the computer:D

As for the crash...just tried your steps....mine does the same
however if I load modeler then the object do something to model and send to layout and close scene it works ok.

Also seems to work your way on other scenes I tried.

gotta be something about the scene file as the other Menis' work ok, cept the one you mention.

02-15-2003, 12:08 PM
I just tried this, i did it 5 times following yout steps and i didn't get any errors at all, Im using 512 meg of ram btw so it could be a memory issue? all i can suggest is try in on other scenes and see if it does the same, u could also try closing ther hub and deleting your configs (back them up first) then re-adding your plugins and see if that fixes it.

Like Prosprctor was getting at, 12mb is barely enough memory to run windows, i just checked mine and i have about half my memory used up with just a few webbrowser windows open and an mp3 player. With them all closed and all programs in my systray exited i still have over 128meg used.


02-15-2003, 01:09 PM
Well for Lightwave 6.5 that is somehow a normal phenomena...Layout crashes every once in a while when you clear a heavy scene. But what the heck, all it takes is double click the Layout Icon again :D
The LW 7.5 demo however never crashed so far , but of course i don't do much with it, just trying to convince myself it'd be worth the money :D

(PCs i had so far: 800MHz Athlon TBird with 384MB Ram and Dual Athlon XP 1800+ with 512MB)

02-15-2003, 03:53 PM
Lynx3D........:eek: ..........HU????????????????
OF COURSE IT'S WORTH IT !!!!!!!!!!!!!

So go online.......... NOW...RIGHT NOW !!!!!!!.......
and get that order in so ya have it by tuesday (overnite mail of corse):D

Adrian....... I am running 768 megs ram on 3 compys and 1024 megs on another.........Get that Ram up!!!!

02-15-2003, 08:45 PM
and I'm running XP Pro with 1 gig of Memory, so yep, it could infact be a memory issue...

- Will.

Adrian Lopez
02-16-2003, 12:28 AM
Prosprctor says he has 768 MB RAM on his computer and it crashes the same as mine, so I doubt that increasing memory would fix it. But even if the problem is due to a lack of memory it still indicates a bug somewhere in Lightwave: it seems lwtools3.dll is trying to access memory that doesn't belong to it.

I really should upgrade that RAM, but for now it must wait (no money).

Adrian Lopez
02-16-2003, 12:31 AM
Originally posted by Prosprctor
however if I load modeler then the object do something to model and send to layout and close scene it works ok.Like in your case, Layout doesn't crash when I do it this way.

02-16-2003, 10:03 AM

One of my other compys just became free from rendering so I tried the Endo-Dog scene there and it opened, redesigned, and closed fine.

So now there is reason to look into other avenues of problems..

Runs fine on...
P4S533 mobo
1024 megs 3300 MHz ram
GeForce4 64 meg video card
Dual monitor

Crashes on...
K7T Turbo2 mobo
1800 XP AMD
768 megs ram (PC133)
ATI 64 meg video
Dual monitors

As soon as another compy becomes free I will try there too but those are days away from finishing.
The other 2 are AMDs but with different mobos and video cards so that may narrow it down furthur.

Elmar Moelzer
02-16-2003, 10:43 AM
This particular scene seems to work fine for me:
P4: 2.4 Ghz
512 MB Ram
Gef3 Ti200
But I have got simillar crashes with very large and complex scenes too. I am still trying to figure out what it is, but my guesses are that Displacement- plugins (like Morph Mixer) could be related to this.
Maybe Particle- systems too.
It could also be related to an OpenGl- issue and the clearing redrawing etc...
Though as I said I am not sure.
Maybe if we all try to decribe the scenes where it happens for each of us we will be able to nail it down?

Adrian Lopez
02-17-2003, 07:55 PM
My own computer is a Dell Dimension 2100 running Windows XP Home, with a 1.1 GHz Intel Celeron CPU, 128 MB RAM and Intel 82810 graphics.

02-17-2003, 08:23 PM
New update

Another AMD freed up this afternoon..

All worked fine there too.

AMD1.3GHZ (not the XP type)
768 megs ram PC100
Dual Monitors
K7T mobo (not Turbo as above)

So works on 1 Intel and 1 AMD
Crashes on 1 AMD

Maby there is something in common between those 2 scene files that aren't in the others

but then they would be the same on every computer.....crashes...

the only thing so far is on the 2 GeForces it works and the ATI it crashes..
HMMMMM Might be the OGL as Elmar says as my ATI does have a hard time with LW and it wont play AVIs on the secondary screen unless I go to any 768 resolution ( 1024, 2048)

02-17-2003, 08:53 PM
Here is what I am getting

App: (pid=524)
When: 2/17/2003 @ 19:43:40.391
Exception number: c0000005 (access violation)

function: NtWaitForMultipleObjects
77f8281e b8e9000000 mov eax,0xe9
77f82823 8d542404 lea edx,[esp+0x4] ss:106fd2f7=cfadbbce
77f82827 cd2e int 2e
77f82829 c21400 ret 0x14

Is a ram problem