View Full Version : Trying to Drill a Poly

07-06-2005, 05:09 PM
I should know this, but I'm at my wits' end.

I'm trying to cut a hole in a poly. I've got my poly, and I've got the poly I am using to cut it in the background. I've tried both Drill and Solid Drill, I've tried extruding my poly while leaving the cutter flat and vice versa, I've tried both of them extruded and both of them flat. When I core, my poly disappears--it's not flipped, it's gone. When I tunnel, if the poly's flat I get nothing; if it's extruded (whether the cutter is or not), I get a tunnel in the middle, but there is no cut in the polys on either side so that you can see through it. If I stencil, nothing. If I slice, I succeed on the top edge of my cutter, but the bottom three points of the cutting poly get left out, so I don't get a complete cut. Boolean subtract acts like slice.

What is going on? What should I do? Any advice would be appreciated.



07-06-2005, 07:07 PM
Post up a screen shot and I'm sure somebody'll be able to help out. :D

07-06-2005, 07:10 PM
That's how many permutations there are. Do you really want all of them?

07-06-2005, 07:27 PM
Make sure you're drilling down the right axis. I've drilled down the wrong axis tons of times, and got results similar to yours regularly.


07-06-2005, 07:36 PM
Merge points / ploys on each of your objects first my guess is you have some points doubled up on one object or the other.

I have had the odd error like this and it is usually that my geometry has some oddity to it.


Just a guess though.

07-06-2005, 08:12 PM
I did have some extraneous points in the original solid. I deleted them. I tried merging points and got no points eliminated. I tried unifying polys and got no polys eliminated.

I've uploaded two screen snaps: the first is Boolean Subtract and the second Solid Drill Tunnel, the two that come closest to what I'm looking for.



07-06-2005, 09:14 PM
One more option to try if you have not had it set up this way already. -Make sure that with both objects extruded that they both have all faces or sides facing out.

If you extrude the wrong direction then you will have a back face or front face flipped inward which will give you funky results as well.

On the merge point’s thing rather than just automatic try a small numeric value less than what your points should be spaced.

With what you are showing you really should not be having any problems at all – so it is most likely some odd little thing in there like two points in same – or very similar location or a fliped poly.

Best to ya.

07-07-2005, 02:20 AM
I tried. I even tried going back to just points and recreating my two polys, those being the "g" and the cutout. I'm still getting the same results.

One more question, though: Is it possible to add points to a poly in order to complete it? The picture is what I got when I tried Stencil on the flat poly with the flat cutout.



07-07-2005, 03:48 AM
First guess, drill / boolean struggling with the poly.
Have to tried tripling the poly, drilling, then merging the result?
Not got LW running now, but vaguely recall something like happening to me.

07-07-2005, 03:50 AM
OK - I just tried this here and got very similar results... which is odd. Because it certainly looks like it should work. Anyway, what did work, however, is splitting the face of the "g" before the tunnel operation. See pic below - I don't know why, as it shouldn't make any difference- it's nowhere near the point limit for modeler, especially as it got upped in 8.3, but... Hopefully this'll take care of it for ya'.

07-07-2005, 08:08 AM
Splitting worked! That is *weird*. It's especially weird as I did this self-same thing a few months back in 7.5d--it was even the same letter of the same font--and had no trouble with the drill.

Oh, well, I'm not gonna quibble as long as I've got a fix! Thanks *so* much!

07-07-2005, 09:44 AM
Yeah, no idea why it's important now, but hey - glad it worked! What font is that, btw - if you don't mind my asking? (I have a thing about fonts, and not sure that I've seen that one yet... :D )

07-07-2005, 10:53 AM
It might be a bug in how lightwave calculates the normal, which can show up with some non-convex polygons. I usually find the most reliable way to fix these problems is to split the poly into more (thought not neccesarily completely) convex shapes just like you have there...

07-07-2005, 11:28 AM
It's made to look something like the old Venice font that came with the very first Macintoshes.

Anyway, I got it here (http://www.masterstech-home.com/The_Library/Font_Samples/Font_Indices/Image_Pages/N/NewVenice.html).

07-07-2005, 11:49 AM
Fugue - thanks! I didn't have that one... :D

07-07-2005, 12:02 PM
Well, I use it because it looks rather like the text used on musical scores. I originally used it for my signature in my work (what I did months ago in 7.5d) and I was making something to go with the logo and therefore needed to use the same font.

11-29-2005, 11:21 AM
I'm working in 8.3 and "drill>tunnel" did not work for me either, until I flipped the "drill bit", so that the normal was facing away from the front.
I don't think I had ever had to do that in the past.
Anyway, it worked!