PDA

View Full Version : Render speeds



brayne
06-21-2005, 02:52 AM
Is it just me, or has anyone else out there noticed that LightWave 8 seems to render faster if you move the mouse around while it's rendering?

Darth Mole
06-21-2005, 07:41 AM
Ah, so I'm not the only one. Yes. I might be imagining it but I'm sure I have other apps that do the same...

toby
06-21-2005, 11:47 PM
I've also seen better times when rendering two things at once. Not just the total time for two frames, but, depending on the scene, a frame will render faster if there's another process running. I forget the explaination, but considering how rarely my fans kick in it doesn't surprise me.

Captain Obvious
06-22-2005, 02:19 AM
Go to the energy saver preferences in the System prefs and set performance to 'max' instead of 'auto'.

brayne
06-22-2005, 02:23 AM
Already is.

toby
06-22-2005, 02:29 AM
Ditto -

----------

Scazzino
06-22-2005, 08:01 AM
Perhaps OSX gives more cycles to an App if the user is moving the mouse, expecting that the user is actively using that App and giving it priority over other processes... Just some speculation, since I typically use many different programs at once, even letting my work machine render in the background as part of my render farm. I hardly even notice that it's doing anything else since whatever program I happen to be in at the moment is usually quite responsive.

-MikeS

Johnny
06-22-2005, 08:11 AM
Well, as this seems to be true, will somebody creat a doo-hickey which simulates mouse movement for those renders that take place while the user is away or busy doing other things?

Or, does Apple know about this? Should they?

J

marble_sheep
06-22-2005, 09:06 AM
Does anybody have benchmarks showing the difference? I'd never heard this before, but if it's true... maybe this app would come in handy--

http://www.versiontracker.com/dyn/moreinfo/macosx/20791

it's an app that wiggles the cursor, designed to keep the screensaver from activating :cool:

eblu
06-22-2005, 09:29 AM
I've seen this behavior since vers. 6
it used to be much worse, renders would slow down till it took hours to complete a single frame during over-night renders. but for some reason, as long as I am on the machine doing things, Lightwave renders faster than if I let it sit idle while its rendering.

*sigh*

AftreEffects had a similar problem, which was fixed in the very first point update Adobe released for it, after that.

brayne
06-22-2005, 05:41 PM
Does anybody have benchmarks showing the difference?

When I have some time, I'll do some further tests, but I just did this with a simple single frame render of a 90,000 polygon object:

18.8 Sec - No mouse movement
12.4 Sec - Mouse movement

Bruce

marble_sheep
06-22-2005, 06:02 PM
18.8 Sec - No mouse movement
12.4 Sec - Mouse movement

Wow, that's a pretty big difference. I wonder how that would translate to a really long render? Theoretically, it should shave minutes off a single frame. I can't believe I hadn't noticed before :rolleyes: (The only slowdown bug I ever knew about was the "cache radiosity" bug, but that exists on both Mac and PC.)

Next large render I do I'm gonna try this!

Seriously... that app I linked above might work pretty well... The lowest time amount you can go is 1 min, but I went in and edited the .plist file, and made it .01... it constantly moved, simulating human movement. I'm not at work though, so I can't see if it actually affects render time......

Ade
06-22-2005, 06:22 PM
This type of crap upsets me.

gerry_g
06-22-2005, 06:26 PM
About six months ago I read about a guy who was puzzled by the transfer rate of songs to his iPod, the transfer would slow to a crawl mid way through, but if he kept wiggling his mouse around the speed picked up again. Some tech guy responded saying all chips are designed to idle, or cut cycles under low load, but I find it hard to believe waggling a mouse counts for heavy cpu usage but rendering don't.

Johnny
06-22-2005, 08:43 PM
When I have some time, I'll do some further tests, but I just did this with a simple single frame render of a 90,000 polygon object:

18.8 Sec - No mouse movement
12.4 Sec - Mouse movement

Bruce

holy cow! 50% improvement is hard to ignore. Maybe this is payback for the pre OS-X days when fiddling with the mouse would actually slow or stop things!

J

brayne
06-22-2005, 09:51 PM
You'll be pleased to know that it doesn't seem to happen with every scene. I'm now trying to find out what are the elements causing the differences.

toby
06-22-2005, 10:17 PM
I found no difference rendering 130k polys with backdrop radiosity - were there any effects in your scene? Lots of textures?

Ade
06-22-2005, 10:36 PM
rendering a single studio shot of a chair, jiggling seems to slow it down, it looks as if the threads are getting thinner while rendering, when no jiggling the threads are thicker.

Captain Obvious
06-23-2005, 05:56 AM
20.7 seconds without mouse movements, 23 seconds with. I doubt those extra 2 seconds had anything to do with the mouse movements, though. Probably just the unknown factor.

JML
06-23-2005, 06:31 AM
20.7 seconds without mouse movements, 23 seconds with. I doubt those extra 2 seconds had anything to do with the mouse movements, though. Probably just the unknown factor.

don't do test that small,
try to see the difference on renders that takes a few minutes instead of seconds..
(lot more accurate)

JML
06-23-2005, 06:45 AM
teapot scene from lw8 (without digital confusion plugin)
(dual G4 1.25 , OSX 10.3.6)

187x125:
mouse not moving : 16 sec
mouse moving : 17 sec

750*500:
mouse not moving : 130 sec
mouse moving : 134 sec

so no difference.

brayne
06-23-2005, 07:07 AM
OK, I'm finding out more, but I still haven't got any conclusions yet.

It doesn't happen with V8, but it does with 8.2 + 8.3, so I'm thinking it may be linked to the new PLD antialiasing (I'm by no means certain of this).

The effect seems to be felt only on small render sizes. The test file I have been using is very simple, and contains a subpatch object that is animated with bones. I'm rendering it to a very small frame size with PLD antialiasing. The 'mouse jiggle factor' makes a huge difference with this job, but if I render the same scene at a large size, there is no 'jiggle' difference at all.

I'll come back with some times, and hopefully some more specifics.

Certainly nothing to get worried about.

Bruce

Captain Obvious
06-23-2005, 12:09 PM
Try setting it to a 'classic' AA mode instead, and post the results.

brayne
06-23-2005, 06:02 PM
OK, I think I've worked it out. Firstly, the times I posted of 18.8 and 12.4 seconds were WRONG. I'm afraid I misled everyone (and myself) with those times. There was another factor at work there. My apologies.

This issue will only arise with extremely short render times, and I do mean short. This is what I believe to be the case, but it's still only a theory. LightWave seems to have a sort of 'refresh cycle' that runs at an interval of around one second while it's rendering. If you have a frame render that is under a second (I told you it was short) the next frame won't be started until the next refresh cycle. So this means that even though the frame might only take 0.3 of a second to render, it's actually going to take a second to complete.

Jiggling the mouse makes LightWave refresh much more frequently, which means that it will assign the next frame faster, and therefore increase the render speed. For extremely small renders like this, the percentage difference is huge, but the time difference is not that great.

If you are rendering something that takes a lot longer, the increased refreshing actually slows the render process slightly, hence the moderately slower render times that everyone has been posting.

So, there you have it. Like I said, nothing to get worried about.

Bruce

eblu
06-24-2005, 07:20 AM
bruce,
I've experienced an exponentially increasing slowdown, since vers. 6. Again, it doesn't happen every time, it doesn't even happen with the same render every time, but as the render progresses over night, the frames take longer and longer to render, until the machine is basically at a standstill, projecting a whole lot of hours per frame.

its almost exactly the type of effect you'd expect from a memory leak in the rendering engine, but I'd think that Newtek would have eliminated them a long time ago.

I've checked all the obvious things... screensaver, sleep, hard drive sleep, processor settings, they don't appear to be factors, and this is the third machine (2 g4s and a g5) to exhibit this behavior from clean installs of LW. and the only thing that seems to clear out the problem... is moving the mouse around.

anyway, thats my exp.
-eblu

toby
06-24-2005, 05:25 PM
I do remember hearing about this problem, it is strange - you'd think that if it's a memory leak it would eventually crash, and I don't think it would slow down *that* much from it anyway.

Maybe setting your mouse on top of a wristwatch would do the trick :D