PDA

View Full Version : Unseen By Camera Problem



bcicio
06-16-2005, 10:15 AM
I've set up a hydrogeologic block diagram where a bunch of wells are injecting air into a saturated zone below the water table. The well screen at the bottom of each well has a particle emitter and is giving off a load of bubbles that float up to the water table. I then need these particles to be drawn to another larger well screen that is above the water table with a wide flat (40' diameter) capture zone around that well. I have created the capture zone "disk" with a 10' thickness around the well and have assigned it's properties to act as a collision object in the "attract" mode. So far so good.

The problem is.. though I want the capture disk to influence the particles and divert them to the vapor capture well, I do not want to see this collision object in the render. I was simply going to set it to a 100 percent transparency, but I remembered that I could set it to be unseen by the camera. I did that, but it still shows up. My settings for the disk is...

Checked: Unseen by camera, unseen by rays
Unchecked: Self-Shadow, Cast Shadow, and Receive shadow

The disk, itself resides inside of a semi-transparent layer. Could that be the problem? The reason I just don't use a generic invisible null collision object is I do not see an option for it's influence to be disk-like in shape - which is what I need. (I guess I might have to settle for a flattened sphere shaped collision object.

I'm operating in LW8.3, but the same thing happens in LW7.5. I just tried setting the disk to 100% transparent and it still renders even after saving the setting.

Any suggestions would be appreciated as to what I am doing wrong.
Thanks!

Exception
06-16-2005, 11:18 AM
Well your description is a bit confusing... but as I understand you have an object that needs to be unseen by camera (and has the appropriate check box ticked) and is also in a partially hidden layer?
What do you mean with the last part this 'partially hidden layer'?
I don't get that part.

So far, I use Unseen by camera on a daily basis and it works fine, but it could be a cross-bug that only happens in specific situations. If we could narrow down all the properties of the disc object perhaps I can help.

bcicio
06-16-2005, 11:37 AM
Sorry, I'm mixing LW teminology with the terminology of my field. Not surprised you find it confusing.

Yes, basically I have a disc acting as a collision object that is to attract particles to it's center as the particles reach any part of the disc's surface.

The disc needs to be unseen by camera, or totally transparent -- while still influencing/attracting the particles.

By "layer" I was referring to a geologic layer in the block diagram. Doooh! What I mean is the disc is located inside of a semi-transparent rectangle object.

I'm not sure why the camera sees the disc despite the previous mentioned settings.

Thanks.

bcicio
06-16-2005, 11:57 AM
Okay... I found the problem. I had inadvertantly loaded 2 discs on top of each other -- and, naturally, only set one to be unseen by the camera.

User error. What can I say. Sorry.

Exception
06-16-2005, 02:42 PM
No problem, happens to me every time.