View Full Version : Translate+Zoom issues/bugs

06-15-2005, 03:24 PM
Hi all,

I have a funny problem that I cant seem to get round. I have a list of points that simply wont zoom in any further. Theres around 35 of them, and if I translate them away from the needed location to the origin, it works fine. But if I try to frame them (Shift-A) where they are, and then zoom in there, it only goes in so far (which isnt very far at all).

I cant see any reason for this.

The model (list of points) can be found here.


I cant translate them to the origin, they need to stay where they are. I need them in this "exact" spot as each point has been created by hand with these values.

Anyone any ideas or solutions?

06-16-2005, 11:38 AM
It appears to be zoom restriction depending on where the view is placed in Modeler. In your case, the minimum grid size is 100m if you have your object in view. But try this:

1) Bring up Modeler, no points, objects or anything
2) Zoom out until the grid size is 10 Mega-meters per unit by just holding down ","
3) Shift the top view until the origin/axes are in lower left corner
4) Try to zoom in. LW V8.2 won't zoom closer 5km per unit.

Seems like a wierd restriction.

As a workaround, you might consider parenting the object in Layout to a Null, then move the Null. To get the precise point positions, select one of the points, write down it's X,Y,Z position, then translate the point set so that one point is on the origin, then shift the parent Null the same (inverted) amount. I don't know your whole situation, so it may not be a feasible solution.


06-16-2005, 11:56 AM
I tried to translate it, then move it back, but the LW numbers I type in don't seem to be accurate enough! When the points were moved back, they were out by 8 meters!
I does seem like a funny bug. As you get further out, you can zoom in less. See,s linear too... 1/2 way gives around a 50m zoom. Weird, and driving me up the wall.

Seems like a really easy bug to fix too... Translate the camera, then do rotations etc... easy. If your using a card that has vertex shaders, then its even easier....

I'll try again just in case I picked the wrong point or something... but this bug should really be fixed.


Actually.... I know exactly why this bug exists. The bigger the number, the less you can zoom in and rotate it . This is because with floating point accuracy, you get terrible results if you multiply a very large number, by a very small one. I had the same issue, but I fixed it with vertex shaders. By not zooming in that far, they dont show this hardware limitation. However.... with GeForce3 and up class cards, this limitation can be fixed easily.... If they want to get in touch, I'll even tell them how.

For those that care... the issue is that a matrix holds SIN+COS values (very small numbers) for rotation, and my vetices are very large...multiply them together, and the results aren't good. Doubles fix this, but you have to do that in software, not a good idea either.

06-17-2005, 03:08 AM
It doesnt seem to be far away object either. I though I'd cracked it by scaling the whole thing down 100,000 times, so the object was about 75meters in length, but that didnt work either...

For some reason, it has to center it for it to work..... Come on Newtek, lil help?

06-18-2005, 02:36 AM