PDA

View Full Version : Problem making a mirror with reflection. NEED HELP ASAP.



SLAYER
06-05-2005, 01:50 PM
Hi,
I am hoping somebody can help me.
I have a scene that I want to show a mirror and the objects that are placed in front of the mirror to reflect.
I have created a mirror which is just a cube that I have applied a mirror surface to.
The objects in front of it that I Want to reflect are colored transparant bottles and glasses.
My mirror comes out black in render and I cannot get the bottles and glass to reflect in it.
What do I need to do. Any help is greatly appreciated.

Thanks

prospector
06-05-2005, 01:54 PM
make sure render setting is set for reflections on,
make sure the reflection is not set to background but to raytracing and spherical (in the surface editor panel).

SLAYER
06-05-2005, 04:59 PM
Thanks.

I got the reflections and stuff going.

However, now when I render, I get little red dots all over the place that appear to be from the ray tracing that do not go away.

Any ideas? What are these and how do I get rid of them?

Thanks

SLAYER
06-05-2005, 05:39 PM
Hi again,

I do not mean to be pesky, but I still cannot get rid of these **** little red dot artifacts!

Of course I normally can wait for responses, but I need to present something for work tomorrow and it will take quite some time to render, so the sooner I can receive help, the better.

Thanks

prospector
06-05-2005, 05:40 PM
are they in some sort of pattern?
got a screen grab?

SLAYER
06-05-2005, 05:57 PM
Thanks for your help Prospector.
Here is a rendered out quick pic from earlier.
They appear to be on items that have transparency.

prospector
06-05-2005, 09:11 PM
K, I would go thru it piece by piece.

Are your transparency objects double sided?
Don't merge them if they are (merge points after making the inside layer)
They should be seperate layers, not just double sided in surface panel.
Then I would check the size of the inside layer of glass (it should be resized smaller (like 99.5% on the size button) and not just copied polies and flipped.
After that I would see if they do it without being reflected.
It could end up being something in LW itself that is messing up trying to reflect transparencies.
Are you using FPrime? Try in LW render.

I would also try a different ray recursion limit number, maby higher, but that would greatly effect rendering time.

That's about all I can think of offhand.
Maby someone else can think of something I haven't.

The way the pic looks, it seems they are happening wherever there is a poly edge,that comes in contact with another poly, which leads me to believe it is because of the sides overlpping. Hard to explain it but that's what it looks like.

Exception
06-06-2005, 02:59 AM
I suspect there is something that is red somewhere in the scene. It gets reflected only minamally but bacuse you are not using anti Aliassing, it shows as specs.

Suggestions:
- turn on anti aliassing
- perhaps use shadows
- follow prospectors comments

It looks as if the object you are rendering has been converted from some inferior 3d format such as .3ds. I can see clear triangulation smoothing errors. Clean up your model. do a merge points, unify polygons, and perhaps a Reduce Polygons to get rid of the triangles.

IZZE
06-06-2005, 01:36 PM
I had that problem when I created some glasses a while back. I got two glass objects right one top of one eachother. Removed the second copy and problem was fixed.