PDA

View Full Version : Xdof will not focus on Null



sonofmickel
06-04-2005, 12:32 PM
Hi all,
I have Xdof 2 and LW8.3. I am trying to use Xdof effectively for animations. When I use Xdof by it self, it is supposed to be able to to use :focus on" and then you chose an object in the scene (Imade a null and parented it to the camera). That is great but the null stays in a fixed position throughout the animation (not so good). I then use the LW8.3 camera DOF and tie that to the camera (keyframed with a follower). But the LW8.3 DOF does not reflect a true 35mm camera for DOF! Pure junk!
So...has anyone been able to animate a null with Xdof and get decent results. The moral to my story is that Xdof works great for stills but does not really "Focus on" a null throughout an animation. I will try keyframing every frame for a 2 minute flythrough.
Thanks

Darth Mole
06-04-2005, 02:12 PM
Yep, you're right - it's broken. It seems that moving to LW 8.x has stopped the null (or whatever your focus target) data being accessed by X-Dof: if you look in the Graph Editor > Camera > X-Dof > Focus distance, it's just a horizontal straight line, based only on the starting position of the null.

A quick workaround is to add your null and keyframe its positions as usual (you needn't parent it to the camera - it will just move with the camera and the focus point will effectively stay static).

You can get the focus distance from X-Dof by manually selecting (or re-selecting) your null at different points along the timeline in the 'Focus At:' pulldown menu. Just add these measurements into the graph editor by adding a keyframe and typing the distance into the Value field. Depending on the complexity of the scene this might take a few moments, or a bit longer...

Once you've keyframed the X-Dof Focus distance the animation should run fine. (On another note, unless you're trying to render at a seriously small DoF you won't need LW's own DoF in the scene as well.)