PDA

View Full Version : adding file extensions



Wade
05-26-2005, 10:31 PM
For some time now off and on Layout has saved some of my scenes without an extension. No problem I can and have changed them one at a time.

Yet now I have a folder with maybe 100 or so with no file extension, and I would like to add the .LWS extension to all of them in a folder at once. Is this possible? How do you do it? Or must I do it one at a time.


P.S. all these scenes are pre 8.3 so I am back tracking a little here. I have not noticed this happening with 8+


Thanks Wade :o

Silkrooster
05-26-2005, 11:05 PM
This has been happening since ver 8.0, I have not figured out the cause yet. I would assume it has to do with the config files, as that is where the list of extions is located.
Take notice when your going to save a file, look in the file name box. If it is blank odds are good it will not save the extention, however if the box contains the widcard * with an extention and you see a list of files with only that extentions, then odds are good it will save the file with the extention.

Now as far as do group renaming, Make a back up first as it has been years since I have done DOS commands.
Instructions for Windows only.
This is what should happen:
Start the dos command window. Start>Run>cmd
change directory to the location of your files. *hint* CD=change directory.
type rename *. *.lwo note there is a space between . and * as *. is original filename and *.lwo is the new file name.

If this works correctly your filenames will now have a file extention.
Tip: If this does work correctly, you can create a batch file with notepad that has all the commands in it. The filename for this has to have the extention .bat.

You may even want to do a test run on some files in a test folder, to make sure this works. I just don't want you to loose any important files.
Hope this helps - let me know, I hate second guessing my self.
Silk

NIGHTSBIRD
06-02-2005, 09:35 AM
To fix the issue add this line to the LW8.cfg file

FileType Scenes *.lws

If your issue is with images make sure this file does not have this in it

FileType Images *.rla;*.als;*.bmp;*.cin;*.jpg;*.pcx;*.pct;*.png;*. psd;*.hdr;*.rgb;*.ras;*.tga;*.tif;*.vpb;*.yuv;*.fl x;*.iff

and add this to your LW8HUB.cfg file

AppConfig FileType Images *.rla;*.als;*.bmp;*.cin;*.jpg;*.pcx;*.pct;*.png;*. psd;*.hdr;*.rgb;*.ras;*.tga;*.tif;*.vpb;*.yuv;*.fl x;*.iff

have fun hope it helps it took me about 4 hours of looking at 2 different LW installations to get mine fixed

Wade
06-02-2005, 10:39 AM
The issue for me dates back to 7.0 - 8.0, but not now 8.3. Seems that from time to time for no reason I can nail down the scenes would save with out the extention. The problem then was that when I went to open the file from layout - layout could not see the scene... It would show up if I just opened the folder so could add the extension or open with LW..

I seem to be ok with 8.3 but am searching through any number of old project folders and adding the extensions so the scenes will show in layout. :)


Thanks for the help.

Wade

NIGHTSBIRD
06-02-2005, 03:23 PM
usually when an update is applied is when it starts messing up from what i can tell it adds new information to the config files and sometimes duplicates info and that is what causes the problems but anyway that i provided is for future reference if you have the issue. good luck on sorting out all your old scenes

Jeff

Silkrooster
06-02-2005, 06:16 PM
In the lw8 config file, look at the directory type. In mine, the objects folder is the only one that ends with a \. I would have to think this is an error, either they all end with the \ or none of them do. Now in the lwm8 config file the objects and images folder do end with the \. But I did notice that in the file type images, that .rla does not start with a *.
Silk

NIGHTSBIRD
06-02-2005, 08:43 PM
your very correct but the lines I posted work as well for some reason maybe each lightwave decides how it want to configure itself :p

lardbros
06-04-2005, 10:44 AM
I had this problem back in version 7 when i had changed the PC settings to "show known file name extensions"

Whenever i saved a file without typing the extension, it just saved it as a blank file. Doesn't seem to do it anymore, maybe it was a one off XP experience, get some odd ones once in a while.