PDA

View Full Version : Major Glitch or Mactintosh? -FX Particle Emitter One Speed Only! HELP!



Glendalough
05-22-2005, 10:22 AM
I am trying to do a scene with a majestic sea fog blowing gently across a townscape....Am finding it impossible to change, slow down, the rate a which the FX particles cross my scene.

On the FX Particle tab:
Set the motion, say, 50 meters and this is how far the particles go with a strong deceleration at the very end. Increase Particle resistance and THIS HAS NO EFFECT ON THE SPEED. It just pushes the end of the particle stream closer towards the box. (Newtek says in the manual : "Particles will move slower as you increase this value". They also say this about Velocity.)

Decrease the Velocity (in percentage) and the same thing, no speed change, just end of stream is brought closer in proportion to box again.

On the Etc tab to adjust Gravity has also the same effect but if you put it high enough it just reverses the particles and they travel back at the same (****) speed.

PLEASE would someone knowledgeable enough, some EXPERT, or even a normal person, tell me this is not true and What I Am Missing. Really can't believe that such one dimensional thought has gone into the development of this aspect of Lightwave.

toby
05-22-2005, 01:32 PM
I think you can judge by the length of the particle's 'tail' whether it's going faster or not - when you decrease the velocity, resistance will have to decrease in order for the particles to travel the same distance - could that be it?

Glendalough
05-22-2005, 02:50 PM
Thanks very much for the reply toby.

If I gather what you say correctly, the tales have a direct relationship to speed.....but when I decrease the velocity, say by 50 percent, the particles only go half way across the scene and I have to increase the vector to 100 meters, twice the distance. Then the tails, as you say, get longer with increase of speed. The whole thing is eminently logical. The only constant is the speed which always seems to remain the same.

It seems to me that (with all the options which go nowhere) there are only two controls, full one speed ahead and stop (and reverse).

FX Wind and FX Gravity also seem to have the very same effect i.e. no effect on the speed of the particles. It will stop, reverse, or deflect but cannot change the speed.

toby
05-22-2005, 03:14 PM
Particles are tricky aren't they -

Try putting resistance and gravity to 0 so your particles will never slow down, then change the velocity, and you should see a difference. That'll tell you if it's working properly. If not, I don't know what to tell you! That would be a software problem, but it works here...

You can also try hitting the 'calcuate' button for more accurate simulation.

Glendalough
05-23-2005, 05:18 AM
Doing as you say DOES slow the particles, but to get a gentle motion the particles barely leave the box.

But found to give a LONG LIFE to particles is the answer, 2000 frames and to start at minus 300 or so. (This just to cover just about 300 frames animation.)

The Particle Emitter must have been designed with fast dynamic movements in mind, like explosions etc.

Thanks Again, my faith has been restored.

toby
05-23-2005, 12:38 PM
Good times!

monovich
05-23-2005, 04:17 PM
You could also getting the basic motion right, then saving the motion to a pfx file, then loading the motion back in and set it's playback speed to something like 25% (for 1/4 speed). It's a good way to get slow-mo.

At least in theory... I actually haven't tried it yet, but it's been knocking around in my head for a bit...

Glendalough
05-23-2005, 06:26 PM
Ah....The PFX file, that's a good idea...Just looked it up. This would give the whole thing a much bigger scope (and control).

Thanks for the tip, monovich