PDA

View Full Version : target camera



Exception
05-10-2005, 05:43 PM
Hi guys,

I don;t animate often, and when I do, its usually really straight forward flythrough. No different this time.

I parented a camera to a null, just to control the rig easily. Then I parented a target null at the camera. Then I made the camera target the target null. Now each time I even attempt at moving the target null, the whole rig goes heywaire. There is no way I can set the target correctly.
Is this a thinking fault? What am I doing wrong? I just want a target camera for a bit more stable animation, and more control. And I don't want to move the target with the camera all the time...

Karmacop
05-10-2005, 11:29 PM
That's weird. Maybe post the scene file or some screenshots? I do this too and I've never had any troubles. The only thing I can think of is that you parented the camera or target after you'd already done some animation and then you used parent in place which could screw things up.

operation
05-11-2005, 02:11 AM
there is taget and target :)

It depends ... I think you're doing something wrong.

Create a Camera
Create a null

Select Camera
press "m" Key (motion option)
in "Target item" select "NULL" object

Select "Null" object
press "m" Key (motion option)
in "Parent item" select the camera

Bingo !!! You find a LW bug !!! ;)

Yes it's a bug ... use an old version : )

It seems to move the pivot point to opposite at the same time....

cheers!

Operation

Exception
05-11-2005, 02:11 AM
I checked that, and parent in place is off.
I now solved it by parenting the null to the other null and not to the camera. I still think its weirdish...

I attached a small scene with a similar setup.
In this scene, try to move the camera on frame 40. Nuts!

Karmacop
05-11-2005, 02:35 AM
Ah ok operation, that is kinda weird ... :)

So this worked with older versions? Maybe I just parented the targert to the parent null and not the camera.

operation
05-11-2005, 02:53 AM
Not working on 8.2.1 ...
I will still test on old version ... : )


but yes, the trick is to have:

Master null and 2 childs camera + Null (camera target)

;)

Operation

Exception
05-11-2005, 03:00 AM
not working in 8.0.1 either, neither in 7.5, although in 7.5 it is less erratic...

operation
05-11-2005, 03:20 AM
:confused:

Sorry I have been dreaming ... may be I Kept in minds other app process... oupps

I send you a file to show you a trick...
I tried to use expression .. but it's not working for me ( I am a loop message error)..
but you can use 'set driven key' -> follower

you can test in my scene : the position of the camera follow the master null position.
and the camera look at the child null.

Hope it can help. (but don't animate the camera :)

Operation

Exception
05-11-2005, 03:29 AM
That still has 2 nulls though...

operation
05-11-2005, 03:39 AM
yes there is two nulls ..the parent solution works in Max, XSI and Maya... not in LW sorry for LWer.


But 1 null drive the camera and the other is the target....

move the target .. the camera doesn't get crazy !

With my solution , the camera follow the master null. Like this you can move both at the same time.
by practicing, you will understand the small difference...

having or not having the "setdrivenkey" what is the difference? Try to animate , you will understand.


Operation