PDA

View Full Version : Front Project busted in V8.2



MonroePoteet
03-31-2005, 11:43 AM
I've been using Front Projection for many years in LW V5.5 to make objects show through the background image except for where shadows fall on them.

Front Projection image mapping seems really busted in V8.2. Rather than the pixels of the mapped image just being placed in the final rendered image, they are scaled based upon the size, position and orientation of the object.

To illustrate:

1) Create a very large, flat square, say 5km x 5km x 0 for X,Y,Z
2) Load into Layout. Camera will be placed automatically showing the object.
3) Load an image of say 640x480 (like you'd use for a background)
4) Map the image to the object using Front Projection
5) Render

It appears that the image pixels are being scaled up to the size of the object based upon its distance from the camera. So, for this very large object, each pixel of the image is made HUGE, then pixel blending is applied making a totally blurry, unrecognizeable image on the object. If you move the huge object closer and closer to the camera, the pixels continously scale down until they are 1:1 and the image becomes recognizeable.

This is PLANAR mapping with global coordinates, not FRONT PROJECTION mapping. The pixels of the mapped image should not be scaled at all, but simply moved to the final output image for each pixel corresponding to the mapped object after shadows have been applied.

How can I get the previous behavior of Front Projection?

Thanks,
mTp

Lewis
03-31-2005, 12:13 PM
Hi !

OK i'm not home now so i can't check but i didn't had such problem in 7.5 (last time I used front projection :)). So out of my head i would say to check on image editor texture antialiasing and in display options check mip map functions ?

cheers

Thomas M.
03-31-2005, 12:31 PM
Did you choose a camera for the front projection? Just front projection doesn't work, as LW doesn't know to front project from which camera, even if there is only one!

MonroePoteet
03-31-2005, 12:33 PM
Setting Maximum Mipmap Quality to OFF in the Image Editor for the background image did the trick. Another new feature to research...

THANKS!
mTp

Lewis
03-31-2005, 01:40 PM
Setting Maximum Mipmap Quality to OFF in the Image Editor for the background image did the trick. Another new feature to research...

THANKS!
mTp

I'm glad and happy that you solved problem :).

LFGabel
08-15-2005, 08:02 PM
I can confirm this bug, and I would like to thank Lewis for suggesting MIP map options... and to Monroe for testing it! Much appreciated! :D