PDA

View Full Version : nose/mouth light



prospector
03-29-2005, 02:06 PM
has anyone figured a way to remove the light showing in nose and mouth interior?
tried a search but nothing came up.
Tried a blacklight in nose..nothing
tried copying polys then flipping them..nothing

liquidpope
03-29-2005, 09:05 PM
Hows about posting a render to show what you're talking about?
Sounds to me like you maybe shouldn't point a light up a character's nose, or better yet, turn diffuse setting waaaaay down on the polys inside the nose and mouth.
This sounds like a fundamental lighting and/or shadowing problem though (not as much of a texturing problem) as in placement and rotation, maybe even type of light, and shadow type and/or shadow color.
Again, a render would help.

Jimbo

Silkrooster
03-29-2005, 09:15 PM
Seems like I remember someone commenting on this subject with another modeler. Their solution was to plug the nose. But Since LW can change how light effects the polys, I would have to agree, with liquidpope and change the diffuse values for the polys inside the nose.
Silk

prospector
03-29-2005, 11:31 PM
I've taken all lights out but 1 and it's behind and above the head.
Tried all the types of lights and nothing worked, ambient is set to 0.
pic shows light from nose (nose is capped inside and not hollow), light is shining on toung and lighting bottom of mouth.
Diffuse won't work as it makes the parts only darker and it is not showing the textures.

SplineGod
03-30-2005, 12:50 AM
This usually happens when you have lights that arent casting shadows. Turning on shadows and giving the lights a falloff can help.
Other ways:
Put negative lights with falloff inside the mouth.
Lower the diffuse value of the mouth interior
use of gradients along with reference null to lower the diffuse value
or use of gradients with a weight map.

liquidpope
03-30-2005, 12:51 AM
Just for fun, try a render with all of your "skin" polys double sided...
Is this head model complete? Can we see the whole head?

Silkrooster
03-30-2005, 01:17 AM
hmmm. I think you have me stumped. The only thing I can think of is either there is some kind of pinhole in the mesh or the light is so big it is engulfing the mesh.
I just had an idea, did you try loading the mesh into a new scene. I am wondering if there is a bug with the lighting. For example you delete a light and is is still active.
Boy am I drawing at straws here. :rolleyes:
Anyways good luck, I know you'll figure it out.
Silk

Silkrooster
03-30-2005, 01:21 AM
I guess we all posted about the same time, I think Splinegods answer sounds more logical than my rambling on. :rolleyes:
Silk

SplineGod
03-30-2005, 01:21 AM
Things to check:
Shadows should be turned on in both the Light properties panel and the render panel (ray traced shadows)
Self shadowing should be turned on in the object properties panel.
If youre using shadow maps make sure you have a high enough resolution on the shadow maps. The wider the cone angle the larger the shadow map.

prospector
03-30-2005, 01:52 AM
Well I'll be dipped in polyfluid.
I hate when that happens...a newbee mistake.
Put shadows on
BUT

forgot to turn ON in raytrace shadows in render :mad:
that fixed it..thanks SplineGod

Searched every panel for something and it was right under my nose.

SplineGod
03-30-2005, 01:59 AM
Understandable since you have to turn on shadows in 3 different panels :)
Glad you figured it out.
This would be a great use of lscript commander. Make a button that turns on shadows in every place it should be on :)