View Full Version : boolean refusing to run

02-21-2005, 08:45 AM
Hi, just trying to boolean several components together in from different layers (in modeller). After joining 3 layers the fourth one refuses to work with the error message 'Internal buffers too small for the requested operation'.
Can anyone explain a way round this?

02-21-2005, 09:43 AM
Have you tried merging points on the model? Not doing this can cause problems with boolean operations.

02-21-2005, 12:42 PM
Yeah, I have just tried that and still getting the same problem.

02-21-2005, 06:05 PM
Restart your computer.
Its some sort of weird memory thing. I get it after a few days of intense LW action... then Knife starts to do it, and even Merge Polygons... Just reboot the machine, and start afresh...

02-22-2005, 03:37 AM
I tried that as well. Still nothing. I have now tried different layer combinations and am getting a different error message : 'unable to regenerate contour. This may be caused by highly non-planar polygons, or by ambiguous overlap between polygon edges and the cutting tool. Triple non-planar polygons or add a small offset to data and try again.'
I should have explained earlier, what i am trying to achieve. I just want to be able to move the model into layout and be able to move it around. At the moment all the components are disjointed in layout and I cant seem to select all the components to move them. Yesterday I learned about nulls. Am I right in thinking that they can solve this problem? One thing I have learned about lightwave is that there is usually more than one way to solve a problem or achieve a result!

Captain Obvious
02-22-2005, 04:25 AM
I just have to reboot Modeller when that happens...

02-23-2005, 11:56 AM
I had this problem when i was boolean subtracting windows for a basic arch-viz visualisation.

There are a few things you can do to get it working... This is what i did anyway:

Move the 'cutting' objects up, down, left or right slightly... sometimes they are ON a line of geometry that it just can't cut through, moving the cutting objects makes it an easier operation i suppose.

Also, try using bandsaw on the object 'to be cut' try different bandsaw cuts, on differing planes and test the boolean to see if it works after that.

Also, when i was doing buildings i had to make sure the internal walls of the structure had the same number of divisions as the outside walls. It wasn't ABSOLUTELY essential but avoided any further problems!

Hope i've helped in some way. By the way i was only getting the last error message you got... never had the memory one.

AND.... now i have just read the rest of your last post.

It seems what you're doing is trying a Boolean Union, to group objects together?
Am i wrong or am i right? Lightwave doesn't work in 'groups' as other software (confusingly in my opinion) does. In lightwave anything you create in a single layer is a group. If you want separate objects they have to be made in a different layer OR... parented in a heirarchy within the Modeller's Layer browser or using Layout's Motion options or Scene Editor.

Sorry for the LOOOOONG reply, just confused as to what you're trying to achieve!!