PDA

View Full Version : Particle Problems



wizlon
02-18-2005, 02:20 AM
I have to show airflow through a complex object, the object is rendered in xray and has 20
seperate particle paths. for the particle paths I'am using 20 .mot files each loaded on to a
null, each null has FX_Wind applied and it's option set to path. I have an additional 20
nulls placed at the same location as the wind nulls, each of these has FX_Emitter applied.
All particles stream down their respective paths, and are rendered with HV sprites. all fine
and dandy works like a charm.......but, here's the problem, I now have to rotate the
complex xray object 720 degrees on it's heading, all the particle motions are now screwed
up.

Is there anyway to play back saved particle motions and at the same time rotate them
based on a parent's heading?

Thanks.

I'll post a scene if anyone would like to take a look.

Axis3d
02-21-2005, 06:29 PM
Open the Emitters properties and go to the File tab. Change the "Playback Mode" parameter to Key. This will allow you to keyframe the emitter. There is also a Parent Key option.

Wonderpup
02-22-2005, 01:26 PM
Hi wizlon,

apologies if this is a really dumb suggestion, but is it possible to just rotate your camera around the object- maybe composite it back into the scene if needed?

wizlon
03-01-2005, 06:03 AM
Thanks for the reply's.

Axis3d, I need to animate (ie. move and rotate) the saved particle motion's and that appears to be impossible.

Wonderpup, 800 frames of the animation already exsist so I cannot do that either. without re-animating and re-rendering everything.

Thanks for your time.

Lee.

Ztreem
03-01-2005, 08:29 AM
That's a heavy particle scene you have there. Too heavy for my laptop.
I did a test just with one emitter and it worked fine.

How I did it:

1.Created one emitter
2.Created one Null made it a path wind
3.Animated the null, particles followed the path
4.Saved the motion
5.Made another null
6.Parented the emitter to the new null
7.Changed the playback method in the file tab in the emitter setting to 'key parent'
8.Rotaded the null and the particls followed.

Seems to work fine for me, if this is what youre after.

Hope it helps.

wizlon
03-01-2005, 08:54 AM
Not sure that's what I want, could you post the scene?
Cheers.

Ztreem
03-01-2005, 10:59 AM
Here's a scene file you can play with. Rotate the null(2) object and the saved particle motion will follow.

wizlon
03-02-2005, 02:55 AM
Thanks for that Ztreem, it's exactly what I wanted thankyou, I tried parent key option several times before and it never worked on my scene, but after redoing the scene, it now works fine.

Cheers.

Lee.

Ztreem
03-02-2005, 03:22 AM
You're welcome, glad I could help.