View Full Version : What the H*#! IS THIS!!!

02-14-2005, 01:59 AM
After maticiously doing 200 movements for motion mixer on this model, I closed LW for a bit.
Came home, reloaded scene and I got this MESS!!!!!! :mad: :mad: :mad:

Normaly I am cool, calm and collected, but after sittingand getting over 500 bones to go where I want and saving motions and running an avi for each one, and testing and retesting each (it worked fine with ANY motion before shutdown), I figured I was just about done........

Is there something I need to do when loading a motion mixer scene other than 'LOAD SCENE'??
It straightens out when I turn bones off or turn off deform but goes back to this when I turn them on again.

IS THERE A WAY TO FIX THIS PIECE OF........!!!!!!!!!!!

I am really hot under the collar right about now :mad:

02-14-2005, 06:31 AM
Have you tried resting the bones? Select them all and press r?

02-14-2005, 06:41 AM
not yet.
doing the remove reload LW thing now

02-14-2005, 07:32 AM
That was it Dodgy
Thanks Thanks THANKS !!!!!
Now I'm cool and calm again :D

02-14-2005, 07:38 AM
it's great it's fixed - but the question is WHY did this happen? I get strange things like this too - either you have to reload a scene to get something to work or when you do reload a scene things are wacky.

02-14-2005, 08:58 AM
OK this is not going to be fun.

Every time I go to load this thing, I have to go into scene editor, highlight all the bones and then click on 'record bone rest position' hitting 'r' doesn't do it.

Maby the coders there at Newtek could take a look and add a few lines to loading a scene with motion mixer to;

select all bones after motion mixer loads and gets all it's information, and record rest position.

At least it would be automatic.

I STILL get bone jumping back to it's original spot (pre keyframing) after I move one,keyframe it, and select another bone...as soon as I start to move the next bone, the previous one jumps back to it's spot before it was keyframed.

This must be also part of the bonetools everyone seems to be having troubles with.
It sure makes for long days when you have to remember to move slider to lock the previous move down.

02-14-2005, 10:55 AM
"long days" - yep, it sure does. :)

02-14-2005, 11:21 AM
Let's do two things, if you would be amenable; post the info on this on the bug workshop thread here in General Support; then, just in case this is considered "current expected operation" for the tools involved, please also post in the Feature Request forum...

02-14-2005, 12:27 PM
Not really mad :D

I thought I had lost everything.

Also I didn't realize it was a bug as no-one else reported something like it, and almost everyone does more involved stuff than I do, so I thought I did something wrong.

And since LW3, I don't think I ever said anything was wrong with anything Newtek did,

Well, I did question the thought process behind taking the old text tools out where we could just type in text and get neon sign type letters back (in ver 5).
Never will understand that , and as moire and more people get into arch side of LW it would come in handy again.

Oh well

02-14-2005, 01:25 PM
It must be a bug that's intermittent, as I've been using MM recently with a boned object, and not had the same problem, and lots of other people would have reported similar problems.. :P Annoying if you're the one who's got it though :)

02-14-2005, 02:26 PM
Yea I know :(
But starting up 8.01 it works great
8.2........another thing....
I don't even get the bone jumps in any previous ver.
Tho it's not intermittent
it's every bone that jumps unless I lock it by moving frame slider 1 frame and then back.
And every load that has to do with bones in MM loads like that.
I did load the ones fron the LW CD and they loaded fine but then they were using other objects besides bones to record (nulls and such for IK)
I am using just the bones (sometimes there are 56 in 1 motion file to record), with 508 total bones in object to keep track of, so I might be reaching some kind of unknown limit.

02-15-2005, 05:37 AM
Did you check if there is the "rig" keys (where the basic rig pose is store) on each motions you saved?
If there isn't the first pos/rot/scale key in your .hmot, your animated items will jump at 0,0,0 when you play motion.

02-15-2005, 07:53 AM
'rig' keys?

02-15-2005, 05:09 PM

Newtek or any bone gurus out there

Am I trying to do something with bones that they weren't made to do?????
Please look...

02-15-2005, 06:22 PM
I assume you HAVE to do this with bones? Cause I really would suggest morphs :) But you knew that...

First I would say you're definitely using too many bones. I would be more tempted to line the lips, say two bones from the corners of the mouth uptowards the centre of the upper lip, and two bones at the centre pointing down. You could add a bone at the end of the middle bones to act as a target for the corner bones. A similar rig should suffice for the bottom lip. You should be able to get all the movement you want from these bones. Parent the lip corner bones to a bone in each corner so you can maneuvre them more easily.

02-15-2005, 07:21 PM
I assume you HAVE to do this with bones? Cause I really would suggest morphs But you knew that...

I would LOVE..JUST LOVE to do that
but alas LW Motion Mixer wont save them in the file :(

First I would say you're definitely using too many bones.
I started with 3 in each lip, but couldn't get the movement needed, and this model is only the low res one :eek:

The high res has 3 times as many (1467 total) but the control I have is just astounding, I can get pores to twitch in the face, :D and yes I need to do that for this model.
And no IK either because the control for very subtle movements just isn't there yet.

But until LW saves EVERYTHING in the Motion Mixer files, bones are the only way.

So am I trying to do something bones aren't suppose to do? (Like move more than one at a time?)

Tom Wood
02-15-2005, 08:08 PM
I assume you HAVE to do this with bones? Cause I really would suggest morphs But you knew that...

I would LOVE..JUST LOVE to do that
but alas LW Motion Mixer wont save them in the file :(

I'm not at my LW machine right now, but I'm pretty sure I've saved some morphs in MotionMixer. I only have a few simple ones, but when they are included in a MorphMixer slider bank, they can be saved into a MM motion. I think... :p


02-15-2005, 10:13 PM
Will try again but something about them wouldn't work in Motion Mixer, but that was in ver 8, maby 8.2 is fixed?
Something about an X channel. Gotta go back thru the book.
Man, I hope your right.

02-16-2005, 01:44 AM
Still not saving morphs in MOtion file

That I can find a way

Made a box with bones
Made some morphs
animated bones
set morph keys
keyed them
saved as motion file (selected items so a motion file on 1 part doesn't interfere with another section)
Played out and looked fine
Made another set of keys with differenty timed morphs (same morphs, just different timing)
moved and keyed bones
Made motion file (selected items)
played fine

now add the first motion file back into the timeline

Morphs are gone

Looked under X-Channels and nothing showing to select (manual says X-Channels no yet working or can't be included or won't
Hold on I'll find it again...

Here;Note: Baking does not currently support X Channels.
which include endomorphs acording to help file.

So I can't use morphs :mad:
Unless someone knows of a way to record them with SELECTED ITEMS clicked on

Tom Wood
02-16-2005, 07:54 AM
I'm on LW 7.5c and just made a morph motion in MotionMixer and it works. Maybe there's something about the combination of bones and morphs? Also, the MM manual has some things in it that are out of date, especially regarding Screamernet and baking. Here's a screenshot of it working. The lips morph from no kiss to a kiss shape and back to no kiss. The lips are in a separate layer so I can select them and use Selected Items when making the MM motion.



02-16-2005, 08:00 AM
Did you save the motion and do another with different timing and put that on the timeline with thew first lip?
That's when the morphs go away.

Tom Wood
02-16-2005, 08:06 AM
Yup, still works.

02-16-2005, 09:05 AM
See if this works on yours please.
Just a box, some bones, 2 morphs
there was no way to get it to work on mine.

02-16-2005, 09:06 AM
has to be mix of bones and morphs in SAME object.
Tho I see no way to do facial and muscle morphs on object from another layer.
In scene, first morph plays, second morph (on other end of object) is gone and third is just bone movement.


Tom Wood
02-16-2005, 09:14 AM
WTF is a .rar file? :confused:


02-16-2005, 10:02 AM
like a .zip file but better
compacts better and faster

02-16-2005, 10:50 AM
Loads and works on mine fine, using 8.2 on a pc... Could it be a mac bug?

BTW, morphs come under the object, not under x channels anymore I think...

02-16-2005, 10:52 AM
you got both morphs playin?
Both big bumps?
I got a pc too
Sure the morphs 1 AND 2 are working?
Bones run in all 3

Morph mixer sliders are running on both 1 AND 2?
You may be only seeing the bones moving

02-16-2005, 12:04 PM
I've tried on every PC (6) that I have here and both morphs not working.
Just #2 works.
There should be one of those massive bumps coming in on the locked down end around frames 80-100.

Just checked and found something strange...

It will only accept the LAST morph made.
I made 2 new morphs to go with those 2 and every morph is gone except the last made.
All the motion Mixer motions are still there and the bones in them work but the morphs are gon from each. No matter where I put them in the timeline...they are gone.

02-16-2005, 12:37 PM
Hold on, I see what you mean now.

Your morphs are supposed to be in the clips yes?

They aren't in your actor map, and they're just playing through their own envelopes.

Morph 1 has no non-zero keys so it doesn't do anything. If I move a couple of the zero keys, it now morphs as normal.

You should have added the object to the actor, as morphs are now kept in it's part of the actor, NOT as external channels. I think this may have changed from the first iteration of motion mixer.

If you add the Box to the actor map, then edit the motions and add morphs to them, it should all work...

02-16-2005, 02:09 PM
Go thru this slowly and with pics!!! :D

If this actually works...I'll give you my first born :D

02-16-2005, 05:16 PM
Okay, I'll go through this fairly slowly as I don't know what you've got worked out yet.

Your Actor is a list of all the objects which you want to contribute to your motion clips. You can add new Items to your actor by selecting items and using the ActorMenu>AddItems.

Now you might not want all the channels from those items to be in clips, for example you might only want rotation channels from bones. You can select which channels are used in the Actor Map, and you can change this by going to Actor Menu>Edit Actor Map.

This brings up a panel with all the items of your actor on one side. One the other side, appear all the channels associated with the item selected on the left side. You can [L]ock the channels or tick the channels which you want to be used. When you lock a channel, this means if you create a Motion from the keys on the time line, this motion won't use any keys from that channel. In theory it shouldn't even have those keys in there, but for some reason they are...

Anyway, Morph channels are grouped under the mesh they belong to. It might have been the case that they weren't before 8, but now they are so the reference to Xchannels is only there for channels which can't be associated with an item (for example Ambient intensity)

In your scene, you hadn't actually made the Box a part of the Actor, so its channels were never picked up by MotionMixer. Thus its morphs were being keyed, and were only part of the scene, not part of the actor. You had keyed Morph 1 all at 0%, so that's why it wasn't morphing into that particular shape. I moved some of the keys, and it started to work. I then added the Box to the actor, selected one of the motions and clicked Edit Motion. I then added some morph keys to the motion and clicked edit Motion and Accepted the changes. Then it worked.

02-17-2005, 06:12 AM
So I've;

Made MM file with only bones
works good
Went into Edit actor map

added the box (one would (well I did) think that this was done when I created the actor)


NOW add morph

I woulda thought that a button called 'CREATE MOTION' would mean that this is where the full motion is created.

I made them and they worked ,added them to timeline.....worked (both)...saved both, cleared everything from memory (it asked), reloaded motions,put both on timeline....worked

Well partially :(
Only the first time, I then added the first motion on timeline AGAIN after the second ( so I have motion A followed by B then followed by A again)
like Motion mixer was made for NON-LINEAR animation, the second A on the timeline only includes (or plays) the bone movement and NO MORPH, tho morph is there because it is playing in the first instance of it on the timeline.
So I made timeline longer again and added second morph AGAIN to timeline and it ALSO drops the morph on any subsiquent uses after the first.
The whole point of MM is to reuse copies of a motion over and over.
I got rid of the two non working A and B clip on timeline and with the 2 that are working I baked them (because now morphs aren't an 'X'channel,)
baked fine...1 long clip plays both shorter,
So everything is BAKED and it plays fine


you add a second one :mad:
I have two baked motions (a copy of first just added to timeline)
first baked motion plays, second only plays bones, and again...no morphs....even tho it was BAKED.

Then I rid the second copy of the file and just had the WORKING baked motion on timeline, I then made a POST BEHAVIOR to repeat,,original baked motion played fine..Post behavior of REPEAT lost the morphs :mad: , bones played ...no morphs, and it was a REPEAT of motion...it should REPEAT

Motion Mixer just isn't ready for the big time yet.
Tho it's probably me doing something wrong

The guy that wrote Motion Mixer
can someone explain where I am going wrong???? Or is it not working to begin with so I can quit beating my head here......

Dodgy, thanks for at least showing where stuff is added as I didn't see this in the help files.

02-17-2005, 07:42 AM
So I've;

Made MM file with only bones
works good
Went into Edit actor map

added the box (one would (well I did) think that this was done when I created the actor)

Did you add the box before you went into the edit actor map panel? To check the box was in there with it's morphs? Because I think the Edit Actor map panel is non modal, so opening it THEN clicking Add item would do nothing.


NOW add morph

I woulda thought that a button called 'CREATE MOTION' would mean that this is where the full motion is created.

Only if the box was part of the actor when you originally created the motion. You'd already made the motion before you added the morph to the map, so it wouldn't have been. This makes perfect sense to me. This is how it behaves in every other package I've seen. Why should it add the morph to the motion if the morph is not part of the actor map?

One thing that I forgot to mention is that because you didn't have the object as part of the actor map when you made the Motion originally, you will have to use 'Add items' in the MOTION MENU (after you have done this in the Actor menu) to add the object to the motion. Then you will be successful in adding the morph using the Edit motion.

I apologise for that oversight. Really MM should do this by default if you add something new to the actor map (because you obviously want that item to be part of your motions from now on), but presumably they had a good reason at the time.

Here's a working version of your scene. If it doesn't morph the second time, let me know.

02-17-2005, 08:32 AM
I just had a similar problem.
I posed a character, closed LW, next day open LW and my character is a complete disaster.

I have to completely start over.



02-17-2005, 09:18 AM
Strange, it loaded fine except the object is like 5 KM away from bones :D

it works

I can see the morphs working in Morph mixer,
it works when adding other copies,
it works when baked,
it works with a post effect

So I am doing the steps but in the wrong order? :confused:
This is ALL I found about morphs in conjunction with Motion Mixer in help files;

'You can use Scan X Channels to add Endomorph channels, if Morph Mixer is added to an item after that item has been added to an actor. Motion Mixer allows you to mix all of the animation channels belonging to an item. The non-transformation channels (i.e., any channel other Position, Rotation, and Scale) are called X Channels. Other examples of X Channels are: a light's RGB color and Intensity channels, a camera's Zoom Factor, an object's Dissolve channel, and so on.'

I gotta work on this as it will save me weeks in time and $ in asprin.
And I don't need a model with HUNDREDS of bones :D

02-17-2005, 09:21 AM
I have to completely start over.

Luckily I held off a bit cuz that's what I was getting ready to do till the great DODGY came to rescue and mentioned the 'r' key :)

02-17-2005, 09:57 AM
I think that is the problem. You didn't have a clear idea of what each stage is doing and so got muddled when you're doing the stages.
Basically the Actor Map is the list of what gets included in the motion when you make it. If an object/channel isn't in the actor map, it won't get into the motions you make.

You can Actor>Add items to the actor map after you've made some motions, and if you want to include those new items in the already made motions, you have to Motion>Add items to the motions as well.

Once an item is in the Actor and the Motion, you Edit motion, and then set keys for that item, and Edit motion again to apply those changes to the Motion.

Then your motions should reflect the newly added items.

Tom Wood
02-17-2005, 10:14 AM
You can Actor>Add items to the actor map after you've made some motions, and if you want to include those new items in the already made motions, you have to Motion>Add items to the motions as well.

Thanks for this tip, that's important info!

Once an item is in the Actor and the Motion, you Edit motion, and then set keys for that item, and Edit motion again to apply those changes to the Motion.

Then your motions should reflect the newly added items.

And then remember to Save Motion to make it permanently part of the motion file.


02-17-2005, 10:44 AM
Thanks for this tip, that's important info!

And then remember to Save Motion to make it permanently part of the motion file.


You don't have to Save Motion, just saving the Scene will save it...

02-22-2005, 01:58 AM
I read this thread before embarking on a complex animaton bit. To make a simple test, I boned a pyramid with three bones pointing at the zenith. This means Bone 1 was rotated 90 deg to point straight up, and the next two were its children.
Then I animated a little slide-to-a-stop along the x axis, with a little wiggle in the bones.
I created the actor with the pyramid object selected and then added the bones to it using Add Items. I checked the Edit Actor window to make sure the bones had been added, then made a motion, added it and played it back OK. Saved the motion but it saved the file in the Applications dir under Lightwave 3D 7.5 app folder (whut the ****?). Saved the scene.
Reloading the scene, the pyramid came in rotated 90deg to point to +Z, the direction bones come in by default. Hi ho. I reactivated the bones, as suggested on this thread, and the pyramid flipped to its proper position for the duration of the motion. The bones however stayed pointed at +Z instead of at the zenith as originally keyframed. Therefore, they did not function as originally saved.
The best part is last: I clicked on Remove Actor and LW crashed immediately. I tried this a couple more times and Remove Actor crashed whether or not actor was activated. It also screwed up Layout so that the Modeler button disappeared. I wound up reinstalling. All this on LW7.5c with Mac OS10.2.8-usually very stable. :rolleyes:

02-22-2005, 05:01 AM
You realise that Recording the bone's rest Position won't actually change their direction? All it does it make the mesh use their current position as the base from which to deform? That's all it does. That's why it worked in prospector's case, as his bones were in the right position, it was the mesh that was screwed up... If your bones are in the wrong direction, this won't fix this.

You also DON'T NEED to saved the motion separately unless you're going to use it separately (For example with another character). The motion is saved with the scene.

I just tried doing the exact same thing one a wintel machine and it works fine...

(if the Modeler button diappears, try running both apps from the hub, and the button should reappear, and then you shouldn't have to run them from the hub again. I they're not listed in the hub, try running them separately first so the hub picks their Locations up)

02-23-2005, 12:44 PM
Make sure all your bones have unique names, even if you mirrored your bones give them totally unique names like leg-1_left, leg-1_right. I've experienced this in motion mixer before and my problem was just that I was lazy and all the bones were named Bone, I think it confuses Motion Mixer when you reload the scene.

02-24-2005, 12:24 AM
thanks, uncon for your pertinent suggestions
Maybe I'll play with it some more when I can afford time to fiddle with it. Perhaps the old method of setting up the bones with a character saved out of Modeler head pointed towards +Z (instead of rotating the first bone) will work better.

Dodgy: there are other things which work on the PC but don't on the Mac. Perhaps I should have posted in the Mac forum, but there seemed to be some common problems with Motion Mixer. BTW, beware of that "Free Actor" button.

02-24-2005, 03:56 AM
I thought the mac issue could be a problem, that's why I stated I was on a wintel. I haven't had a problem freeing the actor, but maybe the machine type is the problem. Anyone confirm this problem who's running a mac?

02-24-2005, 12:47 PM
i tried saving my pyramid object from Modeler rotated +90 so that the tip points toward +Z. The, when the bones are added in Layout, they don't need a rotation to start with. Then I rotated the pyramid object up -90 to point at the zenith to start animating. Everything works fine. The scene saves and reloads normally.I tried "Free Actor" (of course after deactivating it and removing it fromMotion Mixer's timeline. This did not crash this time, probably because the reinstalll fixed something. The .hmot files saved properly in my Motion directory in the current content directory.
I don't know why I needed to save the object with heads up at +Z. I got the idea looking at some older tutorials on boning a character. LW manual says you can bone a character standing up. Maybe something else was corrupted before the reinstall; I'll play with it more.
I should know better than to get dithered over reading about problems people are having in these forums; there are so many reasons for these things including computer maintenance and even my misunderstandings of the programmer's intentions and approach, which can really get in my way. Of course I wish I could go right on without having to experiment and fiddle for hours, but it's actually comparable to the hours I spent learning to draw.
The reason I reinstall frequently is that I find most of LW very reliable but the more complex plug-ins seem to get corrupted after a lot of experimentation, especially experimentation resulting in crashes. Sometimes I can just restore the Plugins directory from a backup. I find that in learning how far I can go with the software I screw it up a lot. Mac OSX is thankfully very unflappable, but in previous Mac OS versions I ended up reinstalling the sys itself after several crashes, when it would get "hinky". I keep my content directories and custom interface files in a separate directory so that reinstalling LW is very simple.
i apologize if I have intruded on this discussion. I certainly must have added to the consternation.

02-24-2005, 02:59 PM
Hey no, as long as your problem is sorted :) I have occasionally known to flap too, just ask Elmar! LOL

As for laying your pyramid down, that's because when you add the first bone, and it's vertical, it will inherently have 'gimbal lock' where the Bank and Heading become equivalent. If you lay your object down, then you're laying out the bone horizontally, and avoiding GL in them. However you then get gimbal lock when you rotate the object itself upright. I tend to lay out a 'main' bone (for an overall parent for my other bones) which I de activate, and this proves the 'gimbal buffer' I need to let my other bones be okay. I animate the whole body with the object's pivot, then ignore the main bone completely, and just animate with the rest of the bones.