PDA

View Full Version : LW 8 - why are there still so many mac bugs?



donc
02-11-2005, 06:45 PM
I have been using Lightwave on the mac almost every day at work since it was released for OSX. I currently use version 7.5b (10.2.8, ATI bugfix, dual 1.25, ATI 9000 pro). It is rock stable and has been since I started using it. This is an application like photoshop or Illustrator that just works.

What the heck happened with version 8.0

0 K bug
display bugs
unstability
more...

I can't upgrade because with an unstable app I will miss my deadlines and lose my job.

It's been a long time since 8 was released. My hope is that there are systems at Newtek that do work correctly or else they would not have released it - right?

Maybe someone at Newtek could give us the specs on one of these machines so I can buy one and upgrade to all the cool character features in 8.

If there are no machines even at Newtek running 8 that are as stable as 7 or 7.5 then please Newtek own up to your QC problems. Give us an itemized timeline for mac bug fixes and renew are faith in your ability to make professional (stable) software. Your software is my job.

We deserve it - as many of us in spite of our love for LW are painfully considering other high end 3D apps - with the unwanted learning curve/cost - in order to be able to produce reliably on the new fast G5's.

The thought of all the time I spent learning your Lightwave - down the drain makes me sick. I went through this a few years ago with Animation Master.

How about this. Pull out the new bells and whistles that are causing problems and offer us a special version "Newtek certified stable" for spacific hardware configurations.

Losing faith,

Don

toby
02-12-2005, 04:43 PM
I too remember LW 7 being super stable like Photoshop, but remember that Photoshop was written for the Mac, and LW was written for PC. I think that that stability was either luck or an intended effort to make it more stable than the PC version. In my experience it's still more stable on OSX, mostly because of the system.

btw - you should be using 7.5c, not b, b was recalled - there's a couple new things in it too

donc
02-13-2005, 07:42 AM
I'm using LW 7.5 build 582. I'm not sure if this is rev b or c.

If anyone knows which rev 582 is, that would be great.

Also, why not 7.5d? Did it introduce bugs?

Thanks,

Don

Lynx3d
02-13-2005, 11:57 AM
am not 100% sure but:
582 should be 7.5b

and the other 7.5s:
7.5: 572
7.5c: 584
7.5d: 598

toby
02-13-2005, 12:36 PM
sorry I forgot about d, I already had 8 when it came out. But I think it only fixed issues with OS 10.3, so you might not need it.

7.5c introduced Spline-amation, Surface Mixer and the Surface Thickness gradient, all very cool.

mats4d_
02-16-2005, 08:15 PM
well , for whoever is reading this.. NT hopefully ...

just want to add my 2 cents - LW's performance on the mac is really really bad.. constant crashes , when swtiching from modeler to layout / graph OSX crashes, have to hard reboot - etc.. makes working really slow and painful.. making sure I save the scene everytime I make changes..

etc.. workflow is super slow and unstable compared to the PC version

any news if they're working on coding the mac version from scratch??

Matt -

Captain Obvious
02-17-2005, 04:42 AM
NewTek are supposedly working on porting Lightwave from the ancient Metroworks' CodeWarrior to Apple's Xcode. It's not a complete re-write, far from it, but it should yield better performance, fewer bugs and general asskicking. Let's hope they're making progress with it. ;)

Scazzino
02-17-2005, 01:00 PM
constant crashes , when swtiching from modeler to layout / graph OSX crashes, have to hard reboot - etc..

Try disabling the hub, it seems to contribute to some of the in-stability on the Mac...
http://www.dreamlight.com/insights/10/cmdline_files.html#hubSwitch

-MikeS

mats4d_
02-17-2005, 02:11 PM
Thanks Mike !

Will give this a shot, sounds like its related to the hub process running

Matt -

toby
02-17-2005, 03:04 PM
Apparently using the new Scene editor causes instability too. I never switched from the old one, so I can't really comment...

wilgory
02-20-2005, 08:29 PM
Wow, I've had to do numerous hard reboots and Layout Crashes on my constantly. LW Layout is the first application to bring my g5 to its knees on numerous occasions. When it doesn't crash the background of the viewports flash colors like greenscreen green, blue, lavender (my favorite) and ocassionally a pastel yellow.
Earlier I accidentally hit the window configuration button. First it hid the top of the window under the OS X taskbar so I was unable to click close, minimize or maximize. Now when I load Layout I get
Error : WINDOWCONFIGURE.LSC (line 244, invalid object method linecount().
Press OK.
Next I'll go to Utilities>Master Plug-ins> (remove the window config utilitiy which I could do without) next I click on Spreadsheet scene manager. Budabing It crashes and gives me the error message LW has unexpectandly quit. Notice that I didn't even have a anything loaded. The spreadsheet scene manager, should have still worked to allow me to view both my camera and the light, but it didn't. This is very buggy and poorly tested. I have been using LW since inspire 3D version 1 > LW 6> LW 7> LW 8. It seems that as LW progresses the only changes are plug-ins and added bugs. Sorry that this sounds negative but I am concerned about my investment with NT.

Next bug on the list is also in Master Plugins. I go to the Setup Mode under master plug-ins and I get this Plug-In Error. Cannot Load external plug-in file <Macintosh HD:Applications:Lightwave [8]: plugins:animate:bonetools.p>. The funny thing is that the plugin is located in that spot on my HD.

Next bug is the VBFile Requestor and the LW_ColorPikr. Just use these two options in both Modeler and Layout and you will understand. In modeler the Color Picker should be called the alert beeper because it just beeps error noises when I choose colors. The VBFile Requestor does not agree with my home directory and only displays the Library folder, that sucks cause my models are not stored in there. In modeler when you use the Object filter it filters out .lwo files which are the majority of OBJECTS I use on both the PC and Mac. This has work arounds and is just annoying, don't use it but still annoying.

When I open the GuffySample.lws from the Newtek Content Folder I find that if I click on the scene editor button it will launch the window with the menu bar hidden under the OS top FILE EDIT etc menu bar. This space should be off limits to all floating windows.
I think that all of the fixes that are been done are more bandaid patching and not addressing the architectural problems of LW. I should be posting the numerous feature requests that I would like to see in LW on this forum but I am reporting bugs involving plugins and system crashes caused by LW. I hope that these all of these major errors and fixed and 8.3 released to the end users in the following weeks. This instability has also caused me to reconsider purchasing some 3rd party tools and plugins for LW.

Greg
G5 2.5Ghz 2 gig Ram NVIDIA GeForec 6800 Ultra OS X 10.3.8.