View Full Version : Screamernet rendering with no textures..

02-07-2005, 09:47 PM
Hey all,

i've been trying out the renderpal demo and seeing as its pretty easy to setup it was rendering away quite happy in no time.....

only problem is there are no textures.

i've been reading thru forums for days trying to find an answer and tried everything i've read on the issue but to no avail....

Renderpal calls screamernet in the -3 mode and even in the past when using screamernet -3 i've had exactly the same issue so im inclined to believeits not a renderpal thing.

now as far as my setup goes

mapped drive t: which has screamer plugins and config (i re added them in lightwave to use this mapped location)

and mapped y: which is my content.


1: screamernet reports no errors
2: Content manager in lightwave says all content is using the mapped drive (and just to be on the safe side i used content manager to export the new content dir setup) and all the objects are loading without hassle
3: config files are loading and plugins are loading....

now im only trying to render with one machine (the same machine in which the content is on)

i have tried typing in the screamernet command manually and still get no textures....

here is a sample of what screamer is telling me

T:\lwsn.exe -3 -c"T:/Config" -d"y:/" "Y:/scenes/MyC2-2.lws" 1 1

LightWave x86 ScreamerNet Module (Build 768)
CPU number: 369

Current directory is now "y:/".
Loading "Y:/scenes/MyC2-2.lws".
Clearing scene
Loading settings
Loading plug-in
Loading plug-in
Loading "Objects/MyC2-2_v002.lwo"
Loading "Objects/MyC2-2_v002.lwo"
Loading plug-in
Validating scene
Preparing "Objects/MyC2-2_v002.lwo"
Preparing "Objects/MyC2-2_v002.lwo"
Scene loaded.
Allocating frame buffers.
Allocating segment buffers.
Updating geometry.
Moving MyC2-2_v002:Layer1.
Moving MyC2-2_v002:Layer2.
Optimizing MyC2-2_v002:Layer1.
Optimizing MyC2-2_v002:Layer2.
Transforming coordinates.
Removing hidden polygons.
Computing polygon distances.
Sorting polygons.
Rendering frame 1, segment 1/1, pass 1a/7.

this no textures thing is bugging the hell out of me as its stopping me from batch rendering.....

i hope someone can help

thanks in advance

02-08-2005, 03:04 PM
Could you post the Screamernet cmdline files you are sending to your machine? Also if you save the scene and recall it, are all your textures as you left them? I don't use RenderPal - Still typing commands, but may be able to make some sense of it. Also, what do you see when your sequence is rendered - Black (any geometry or shading showing up?)


02-08-2005, 03:06 PM
Also, is your content directory mapped right from the root as you were showing "t:/Config"?

02-08-2005, 03:14 PM
This line is where I think there are some problems.

T:\lwsn.exe -3 -c"T:/Config" -d"y:/" "Y:/scenes/MyC2-2.lws" 1 1

Not an expert on how this works on pc, however the [1 1] at the end seems like the wrong syntax. This should be a string of three numbers [Start Frame] [End Frame] [Increment]

for example:
1 300 1 (for a 10 second animation starting frame 1 ending frame 300)

So if you are just trying to initiate a render on the controlling machine [-3] mode and have specified the frames in the example you would not get a batch render but a single frame, or perhaps the error that you are having.

Like I mentioned, if RenderPal changes the way these files are configured, then my advice may be wrong.

- Paintmonkey

02-08-2005, 04:51 PM
Thanks for all your replies paintmonkey

within layout the textures are all loaded and are as i left them and render with f9
when i use screamernet the geometry loads up and is shaded but it has not loaded the images...

my content directory is mapped to y:


as screamer is loading the objects the mapping seems to be correct......
as i said i used content manager to make sure that all the images were being accessed through the mapped directory i then exported a new content setup from content manager to make sure it was all in order...

in the sample screamernet text outputi attached im my lastmessage i was only trying to render 1 frame so the increment of 1 istaken as default (with or without this third number at the end it still renders without textures).

i've attached 2 images.
the one with the textures is one directly out of lightwave
and the dark one with only shadingis out of screamer.