PDA

View Full Version : Help - Transparent polygon rendering Trick



Anthony_Locke
02-06-2005, 03:25 PM
Hi all,

Iím currently running Lightwave 7.5c, and am rendering a scene with the transparent polygon in front of the camera. As expected, it has sped up my scene rendering by about 5 times!

The problem Iím having is that if I have any items in the scene which also use transparency (i am fading seperate objects in and out as the scene progresses), they are suffering from some type of internal self shadowing within the object itself, and the shadows donít fade out with the object, they stay 100% until the object is fully faded out, then they just Ďpopí outÖBasically it looks terrible!

I have turned off all the shadow options on the object itself (Receive shadow, Cast Shadow, Self shadow etc), but still no luck. They still appear.

Has anyone else experienced this?

Actually I just had a thought now. Iím using Raytraced shadow..Could that do it?

Iím kind of thinking this could be a limitation of the rendering method, but thought I would see what you all had to say.

Thanks in advance for any feedback.

Anthony

Silkrooster
02-06-2005, 04:23 PM
I ran into the same problem awhile ago. What I ended up doing is using the trasparency channel for a smooth fade and using object dissolve to hide the object and the shadow. You can use the graph editor to adjust the both values by clicking on the e button.
Silk

Anthony_Locke
02-06-2005, 04:30 PM
Hey thanks for the reply!

I'm currently only using Object dissolve on the item (Should have mentioned that!). So you say if i copy that parameter over into the 'surfaces' transparency I should be ok?

Anthony

Silkrooster
02-06-2005, 06:17 PM
Object dissolve will remove the shadow that is cast onto other objects where as transparency will still cast that shadow. If you did not need to cast a shadow then you could just disable shadow casting.
The reason I use both is that I find changing transparency channel to be smoother than the object dissolve. I guess it is personal taste.
As far as the object casting shadows onto it self you should find a place to disable self shadows on the object properties rendering tab.
Silk

Anthony_Locke
02-06-2005, 06:48 PM
Thanks Mate,

As stated above I have tried turing off 'Self Shadow' but nothing changed.

Maybe adding the fade-out into the transparency will do the trick.

Anthony