PDA

View Full Version : FRONT PROJECTION BUG FIX PLEASE - repost from another thread so it won't be missed



jin choung
02-03-2005, 06:50 PM
the FIXED button in the front projection mapping feature allows the CAMERA to move while maintaining the texture but will not allow you to MOVE THE OBJECT!


while i wouldn't necessarily call it a BUG (though i did for brevity's sake) but it is indeed missing a highly desirable feature.

BAKING a surface will work but considering that you have to UV MAP every piece of geometry that will take the image as well as split up surfaces and prevent overlap in uvspace and such, unless uvs were needed in the first place, this could be a HUGE PAIN of an unnecessary step.

-----------------------------------------------------------------------------------------------------------

IF a simple FIXED button on front projection will not do it, i have an idea for a potential SOLUTION:

CONVERT THE FRONT PROJECTION MAPPING into lw's standard, legacy PROJECTION MAPPING TYPES (most probably, a simple PLANAR will work because that is all that front projection is!)

jin

p.s. oh and i'm doing something at work that this really has an impact on so it's a 'real world' kinda request as well.

Karmacop
02-03-2005, 07:04 PM
Ahh jin, I've missed your upper case letters :p

So if you need the object to move why not just use front projection?

jin choung
02-03-2005, 07:18 PM
hey kc,

yah... me and my caps have been really busy since the new year... hope all is going well with you.

actually, the issue is this:

FIXED button was implement to allow camera to pan around and such without the texture reprojecting constantly onto the geometry and making a mess.

but with FIXED TURNED OFF, if you move the object, the texture will STILL swim right through texture.

it's not like turning fixed off (or on, or anything) will fix this. NOTHING in lw currently addresses this issue except for baking which is not always necessary.

jin

Karmacop
02-03-2005, 08:26 PM
All is good with me Jin :)

I don't think this is a bug at all, it's just the way front projection works. For example, say the image you wan to front project is an animation of an object moving past. You'd want the front projection to be sticky with the camera, not the object.

On the other hand, I do understand where you're coming from, and matching front projection with planar projection is hard. I think what is needed is just another button on the interface for fixing the texture on an object.

So maybe a post in the feature request forum is what is needed.

trick
02-04-2005, 01:10 AM
I think what you need is Worleys Sticky Front Projection, which is in the Taft Collection I think.

Yog
02-04-2005, 06:37 AM
The way I have done this in the past is to set up the front projection, then bake the model to a texture, then just replace the FP with the new UV map.

Cman
02-04-2005, 08:05 AM
You might also add a 2nd Camera to be a "texture cam" and parent the 2nd Camera to the object and use it as the Front Projection Reference camera.

That way the texture stays truly fixed whether you move the object or 1st Camera or whatever.

edit -
I could only get it to work by parenting both the object and camera to a null so the camera and object stay in relation. Also I had to turn off Fixed.