View Full Version : Layers Problem

01-29-2005, 11:16 AM
Hi All,

I'm trying a tutorial on the new European Newnek site and I'm having a problem with layers. I thought that if I had a model with one layer in layout, then I went back to modeller and added another couple of layers, when I syncronised with layout, the layers would appear in layout. I tried several things to make the layers appear but no luck. I've tried replacing the object to force the new layers but they still don't appear. Am I doing anything wrong or are layers a bit tempermental? Thanks.

01-29-2005, 12:13 PM
This may be a brute force method, however, I found that if I cut and paste the two new layers to different layers i.e. they will have different layer numbers, then replace (not syncronise) the object into layout, they then appear, They don't import into the current objects locationm however, instead at (0,0,0). I'm not sure whether is a problem with the HUB or not. Has anyone else experienced the same problem?

01-29-2005, 12:23 PM

The only way I know around this is to reload the scene- this forces lightwave to re-evaluate the number of layers in the object, and see the new ones. It might be worth checking the 8.2 fix list ( if your not on 8.2 that is) as this may have been fixed in the update.

01-29-2005, 01:24 PM

I reloaded the scene but that didn't work. I think your right that it may of been fixed in 8.2 which I've just downloaded.

This is just one of those things to be aware of


01-29-2005, 01:39 PM
Hi chaps,

you'll find that a simple mouse click on the existing layers in the scene editor seems to kick the hub into action, but this is just to update the layers list in the scene editor the hub (on my mac anyway) MY mac always pops the new layer straight into layout and from memory it's the same on my PC. A quick save of the object when you add a new layer might also help.



02-24-2005, 11:13 PM
I just encountered this same problem in 8.2.

The new layers won't synchronize to Layout at all. The only way I can find to get my new layers into Layout is to resend the entire object. Needless to say, having the object appear at the origin again is incredibly irritating.

Can anyone confirm this as a bug?

02-25-2005, 07:01 AM
Layers seems to work fine for me. Thouh I've not tested it extensively.

When you did 8.2, did you update it from 8.0 or 8.01? A clean install may possibly fix it. Most seeming problems I've had were solved by a clean install of LW.

02-25-2005, 07:33 AM
this problem has existed since the hub was first introduced. No fix in 8.2. It is really irritating.

02-25-2005, 07:50 AM
This is not a new problem at all and this is one of the reasons why I REALLY find the hub pretty much useless.

After mucho consternation I am simply in the habit of loading the object layers in manually. OR if you have 80 layers in an object file and have made changes to a quite a few of them just kill all of the poly objects in the scene within Layour and do a complete reload of the entire object and all of its accompanying layers.

This won't work as well if you don't build your entire scene within Modeller which I do. And it helps to have all surfaces saved just in case they need to be reapplied.

If you have made location changes of objects and the like within Layout just import that back into Modeller with a plugin and start your new work from that new object. The layers will be retained for a fresh reimportation into Layout if necessary.

I do this ALOT- saves me worries about properly updated object adjustments and if you organize your saved files properly this can also be a great way to incrementally save your progress.

02-25-2005, 11:02 AM
How is it possible that NewTek doesn't know about this problem if it's so well-known by the users? This seems like a fairly obtrusive bug to me, so I find it absolutely ridiculous that it hasn't been fixed yet.

I started using LightWave in December and can easily say that I have encountered way more problems than I did in my previous main 3D app. Luckily, I really like many things about the program and I have faith in the NT team so I will not be abandoning it anytime soon (I hope).

Anywho, I don't want to hijack this thread, so I'm done now. :)

02-25-2005, 11:52 AM
This seems like a fairly obtrusive bug to me, so I find it absolutely ridiculous that it hasn't been fixed yet.

you and me both :)

02-25-2005, 03:03 PM
Sorry to chime in on the negative side, but yes, this happens too often. I make a variety of changes in modeler, both to existing layers and adding new layers. It is kind of capricious regarding what comes over, and no, re-loading doesn't always take care of it. Annoying??? YES, should it work as expected... DUH!!! I had hoped that the 8.2 fix would have taken this one off the list. Oh well, hope, hope.........

02-25-2005, 05:51 PM
Has anyone reported this one?

02-25-2005, 06:45 PM
It works for me. Are you saving your object before switching to layout? :confused:

02-26-2005, 01:30 AM
Yes. I tried everything I could think of.

02-28-2005, 04:21 PM
I was just about to make a bug report, but in the process I found that I can't recreate the problem anymore even though I have done nothing that could have potentially fixed it (as far as I know).

I'm positive it's there though so I'm going to keep trying to recreate it. Are there any specific conditions that you guys know of that caused this problem for you? For example: using a loaded scene, a scene that hasn't been saved, or using a specific number of layers?

It could also be a hardware problem, no?