PDA

View Full Version : Possible Modeler Issue in 8.2 - Cut Tool



erroLux
01-22-2005, 01:59 PM
Hi, worked about 8 hours in Modelere today after having upgraded to LW 8.2, and I thought I give a test render a shot.

In layout, the mesh was screwed up so I thought there were some one or two point polys.
In modeler 8.2, the statistics panel said: no one or two point polys; merge points did nothing and eliminate polys did nothing either.
Changed surfaces, went back to layout, no difference.

So I decided to open up version 8.01, immediately saw some duplicates, and did a merge: some points got merged and the whole mesh got 'screwy', kinda 'foam-looking'.
Eliminate polys and merge points did nothing more (duplicates not at the same place), so I'm eliminating the duplicate polys ONE BY ONE because I do not want to loose all that work (poly count 4000 something)!

This is going to take me hours of cleaning up, cause often I kill good polys, and have to undo that, and it already started in my first saved file, and all incremental saves only added to the problem, and NOTHING OF IT WAS VISIBLE IN MODELER 8.02!

Man, why am I so cautious, over 63 incremental saves and still they're useless!
I am pissed! :mad:

I'm going to uninstall 8.2 and wonder why they even released it?

I do not want to start one of those threads with pros and cons, there's enough of them, but if someone has had the same problem and found a workaround (other than reverting to 8.01), I would like to hear about it.

Greets...

Karmacop
01-23-2005, 05:25 AM
Can you explain this a bit more with screenshots maybe? I don't know how your model could be so bad, and why you can't merge points and unify polygons. If you were lucky you could have just used select conencted.

erroLux
01-23-2005, 06:23 AM
Hi Karmacop, thanks for the reply.

You know, it's not my intention to be negative, but it was a bad surprise after a lot of pleasing work.

Trouble is, I've been trying all morning to reproduce what has happened, but I'm not getting the same bad results anymore, which is of course a good thing.

Furthermore, I had fixed the last incremental save, so there's nothing to show anymore, and I do'nt find anything in previous incremental saved files.

I've attached an example: it's a sphere that I've duplicated; then in a separate layer I've displaced some (not all) of the polys, placed it back in the original layer which contains the original un-deformed sphere, and used Terry Ford's Mirror Tool plugin.

This resulted in part of the duplicated sphere to merge with the original sphere.
In attachment you see the result after using Merge Points and Unify Polys.

So, you would say: "Haaaha, that guy simply mistakenly duplicated geometry and screwed his mesh up!".

Well, I PROBABLY DID mess the mesh up, be it by using 3d party plugins that are'nt compatible with 8.2, or by just copying and pasting by mistake.

BUT: that what's troubling me is the fact that what you see in attachment, was NOT VISIBLE IN 8.2 (!!!) even though I use Merge Points and Unify Polys on a regular basis, and only after searching for a while and opening the object in 8.01, it immediately was visible!

So, now I'm using 8.2, and after each incremental save I check the mesh in 8.01, and until now no problems anymore.

I have'nt used alcohol yesterday, so I'm sure I'm not mad. :rolleyes:

Karmacop
01-23-2005, 06:28 AM
Hmm ... this is certainly weird. So you're saying that even this sphere will show up like this in 8.0.1 but not 8.2? Any chance you could upload this file?

EDIT: And by uploading the file, I mean could you upload the .lwo file? Just making myself clear :)

erroLux
01-23-2005, 08:34 AM
Well not exactly, because I made this example in 8.2.

All has been working well today, but as I said, the weird thing is that while I was working in 8.2 yesterday, all seemed fine: Merge Points and Unify Polys in 8.2 replied that nothing was merged or unified, the statistics panel said there were no one or two point polys, yet when I went to layout, the surface looked screwy in some places.

And only when I went to 8.01 I saw what you can see in the attachment, which today with this example I also see in 8.2.
And when I did Merge Points the first time in 8.01; there were some points that were merged, but not all, which is also weird if it's a case of duplicates, I would expect that all points would merge.

No wait, I remember that somehow 'original geometry' ( i.e. = geometry before the use of the Cut Tool ) was stiil there together with the new 'cut geometry'.

That's why I thought that maybe the Cut Tool was buggy, but I have not been able to reproduce it.

So maybe it was my system anyway.
I hope so at least.

I have been thinking that maybe I should have done a restart of the computer.
Maybe something got screwed up inside???

Will upload the file for examination.
I only have this one file left, all incremental saves now in different layers and layer 19 is the mesh that I cleaned poly by poly. (deleted a bunch of layers after that because the file would be too large.)

Well, can't upload it here, and can't upload it to my website, should soon buy a license of WS_FTPHome for my try period has ended.
Maybe I can email it?

Thanks for the help! :)

Karmacop
01-23-2005, 09:12 AM
Well as long as everything is working fine now then I guess it doesn't matter, but it'd still be interesting to see one of these meshes to have a look at what you did.

I know why you were so angry though. After modeling for so long if you lose a file then it's devistating.

A few years ago I had a hard drive crash and lost ALL of my lightwave files. You can imagine how depressed I was. I just wanted to give up. Luckily I'd made a backup cd a few weeks earlier that I found. Since then I lose files when Lightwave crashes etc and it upsets me every time, so if this is a bug within Lightwave I'd want it fixed.

From what you say it sounds like a weird error with your system, and I hope that's all it is :)

erroLux
01-23-2005, 09:46 AM
Well yep, I've been working all day in 8.2 now, constantly checking the work in 8.01 and doing test renders in 8.2, and what happened yesterday has'nt happened today, not even when I tried to force it somehow.

So I'm more and more convinced that somehow my computer system went bazerk.
Maybe I've been too hasty to post this the way I did, but having just installed the upgrade made me jump to conclusions I guess.

Anyway, thanks a lot for your help, it's hugely appreciated! :cool:

chikega
01-23-2005, 09:47 AM
Well as the old adage goes:

One Step Back, Two Steps Forward.

Let's hope it's not the other way around. :eek:

Chuck
01-23-2005, 10:34 AM
The thread is a support issue and has been moved to the support forum; the title was not informative as to the nature of the problem, but rather seemed intended to be inflammatory, so the thread has been retitled as well.

The issue also seems to be resolved, but will be brought to the attention of the development staff for their review.

erroLux
01-23-2005, 11:49 AM
Chuck wrote: the title was not informative as to the nature of the problem, but rather seemed intended to be inflammatory,

Yep, indeed, not my intention, but in the heat of the moment's frustration.

My appologies if I offended anyone.

Greets...

Lewis
01-24-2005, 06:48 PM
hmm i work in 8.2 for few day snow (severl hours) and i did use CUT tool severl time snad no problems so far that i saw.

But from look at your model it looks liek you have polygons INSIDE of sphere and then you get piching sicne they are pulling geometry inside when you subPatch it. If merge points / unify polys doesn't help then it's 99% polygons inside :).