View Full Version : Problems/Usability Issues

02-07-2003, 05:34 PM
Have to do this in parts:

This is carried over from the previous forum. Riki and others posted 91 points, I asked a couple of Mac folks on our Beta team to review the points and comment. I've got our first reaction back, still waiting on another to come in, and of course we'll be following up with the programmers on confirmed problems and feature requests; and with the docs team on doc issues.

Below, the comments of this Mac beta tester are marked "MB1".


The VB File Requester lets you add files to favorites. But there's no option in this menu to delete favorites. My current setup LW 7b Mac OS 9.1 G4 200000k allocated to each program, with the hub disabled, RAM 384

MB1 - I can't even find this favorite functionality with the VB Requester any more. Was is superseded by the recent scenes list?


You can create customised Libraries in the Preset Shelf but there is no option in the drop down Contextual menu to delete or rename a library.
MB1- True.


The cursor seems to shakes spasmodically when changing directories using the VB File Requester, this occurs regardless if a scene is loaded or not.
MB1 - Not happening here.


Contextual help is non existent.
MB1 - Feature request


The 'DOCUMENTATION ADDENDUM' for the 7b update, regarding Motion Mixer doesn't marry up with the Reference Guide. For instance it refers to Page 19 when the actual doc only goes up to page 16.
MB1 - Manual Errata


QTTools.p doesn't work with the 7b update on OS9.1. I had to replace this plugin with an older version in order to be able to save animations as QT Movies.
MB1 - Fixed in Release 7.5


The bookmarks in the Chapter 6 of the lw7manual.pdf haven't been done as links, which makes it difficult to navigate.
MB1 - No comment :-)


The Manual doesn't have a chart listing keyboard short cuts.
MB1 - No comment :-)


Chapter 6 of the lw7manual.pdf has been repeated at the end of the lw7manual.pdf. The links in this section work but it has been obscurely labeled "woverview_noMM.pdf".
MB1 - No comment :-)

0010 (Plotz)

In OS 10.0.4 with 7.0b.

In the camera properties window select "Lens Focal Length" and enter something. Say "15" or "15.00" What you get is "15000.0mm". It's converting the number to meters, and then back to millimeters.

Camera FOV is always in mm, so why convert to meters and then back? To enter FOV you have to manually type in "mm" to have the number enter properly.
MB1 - This is fixed in 7.5 release, I believe. You enter '6' and it inputs 6.0mm.


In OS 10.0.4 with 7.0b

Set the Max Render Level in the camera window to "bounding box". Open the scene editor and the camera window gets switched back to shaded render view.
MB1 - Fixed in 7.5 release


In the lw7manual.pdf (section 6.30) it reads "Choose Display >Utilities: Master Plug-ins to display the Master Plugins panel."

That should be "Scene > Utilities: Master Plug-ins"
MB1 - OK...


Sometimes if rendering a large image, the final result that pops up in the Image Viewer window can look like a deranged mess. The Image does however appear fine when saved and opened in Photoshop. Something is obviously still wrong there.
MB1 - Under OS9 you certainly could get some weird corruption in the ImageViewer and I would guess this still may happen periodically in 7.5 release for OS9 since the same OS9 memory handling issues prevail.


If I open Layout and then immediately quit, I get a dialog window asking if I really want to quit. We should only be asked this if we are quiting with unsaved changes. Not when quiting a blank scene. Plus there should be some way of telling if have saved or not before quiting. Maybe the save button could be ghosted if there are no new changes to save.
MB1 - Feature Request


If quiting out of Layout with unsaved changes to either objects or scenes, we should get a warning dialog that tells us this, instead of the dialog asking if we really want to quit.
MB1 - Feature Request


We need a Histories window. It would be great if we could undo the last 10 or 20 actions. The level of undo is something that users could determine in their preference setting, depending on their own system resources.
MB1 - Layout Feature Request


The Render Status window should provide an estimate and progress report of the render time.
MB1 - Layout Feature Request


When using the Image Editor the whole application come to grinding halt once you start to play around with the sliders such as Brightness, Gamma etc. It is virtually impossible to drag the slider, all you can do was click a new position and wait for it to kick in.

My current setup LW 7b Mac OS 9.1 G4 200000k allocated to each program, with the hub disabled, RAM 384
MB1 - This has always been the case across OS9 and OSX and is still an issue (but one which apparently also affects PCs). If you try and edit an image displayed in an OGL viewport using any of the Image Editor controls then updates are very, very slow..


The Text Tool in LW7 should be usable from the very first time you boot the program. Other apps can see what usable fonts I have in my systems folder and have them there ready to use without having to create a font list.
MB1 - Feature Request


If using the text Tool, once you've started typing, pressing ESC then 'n' to bring up the Numeric panel is awkward, and trying to backspace through the text in the Viewport is not possible.
MB1 - Fixed in 7.5 release


Clicking on a blank space of the Toolbar doesn't reset the Text Tool. Even if you change tools (to say the Pen Tool) and then come back to the Text Tool it still persists in automatically generating the last piece of text entered.

If you make a typo, this becomes a real problem when combined with the fact that you don't seem to be able to backspace though text in the Viewport.
MB1 - Sounds like a feature request. I think it's quite useful that the text tool retains the last input string.


If you use the default settings with the gears.ls that ships with LW7 it creates an object with two inward facing polygons.
MB1 - Fixed in 7.5


If your using the 'Change Surface' panel (q) and you've got a surface selected that's already been named, if you scroll down through the list to change to another predefined surface, the colour swatch doesn't change to reflect the new surface colour. This can sometimes cause confusion if working with objects that have lots of surfaces.
MB1 - I can't duplicate this in 7.5


When you do use the "q" key why isn't the "name field" automatically highlighted so users could just start typing a new name instead of having to mouse?
MB1 - Feature Request


When using 'Object Sequence' in Layout, after rendering a test animation the last object in the sequence automatically defaults as the initial object at frame 0. If you then render the animation again the sequence will start off with the wrong object, which means that we have to keep changing it back with each subsequent render.
MB1 - Object sequence is missing from OSX 7.5 release. Would be nice to have it back :-)


If you reset the Lathe tool by clicking in a blank space on the toolbar it resets all values to zero. But if you reset this tool with the Numeric panel it automatically sets the end angle to 360 degrees which is a real pain when working with complex models.

The reset values should be the same with both methods, as is the case with other tools such as Bevel etc. There needs to be some level of uniformity between the Tools and how they work.
MB1 - That's a UI decision....


While working in the Top viewport, using the Pen tool and the 'Control' key to constrain the position of a new point to 45 degree increments, relative to the last point, I found that this doesn't always work. It can depend on where you click and you can sometimes end up with a single three point line.
PS see the example below on the right.
MB1 - I don't know how this is supposed to work....

02-07-2003, 05:41 PM

If you then choose the Hub from the Application's menu in the top right hand corner of the screen and then File > Quit (to quit the Hub), it brings up a dialogue called 'Lightwave Hub' with the following message:

"Lightwave applications are still active. Do you really want to quit?"

If you select 'Yes' (to quit the Hub) it quits Lightwave instead and the Hub stays open.
MB1 - True for OSX 7.5, too.


When you open the Spreadsheet Scene Manager and go through the Options menu turning on/off different Options, I found that I wasn't able to uncheck the 'Show All Supplemental Rows' option. It stays checked regardless and brings up an error message "There are currently no Supplemental Rows to be limited to". We should be able to uncheck this option. It is possible to do so if you open the alternative Options panel, with the check boxes so it seems strange that you can't do it in the drop down menu.
MB1 - True, you *can* deselect this option from the options 'tabbed' dialogue box.


If you've got the Spreadsheet Scene Manager open and go File menu >Quit, nothing happens the application stays open.
MB1 - Fixed in 7.5


Probably more suitable as a feature request but it sometimes bugs me that I can't zoom in on a selection in the Image Viewer, often 100% zoom is too big and 50% is too small.
MB1 - Feature Request


Layout seems to crash a lot when I'm using the Spreadsheet Scene Manager. The application becomes unstable.
MB1 - True, probably because of all the errant master handler stuff it puts in the scene file. But definitely contributes to program instability and sudden application quits after you've opened spreadsheet.


When using the Spreadsheet Scene Manager in 'Selected Items' display mode, you have two additional sorting modes: Selected and Reverse Selected.

But what happens when your in 'Selected Items' display mode with 'Reverse Selected' sorting mode and you decide to change to another display mode that doesn't support 'Reverse Selected' sorting mode???

Answer: It causes an error an Lightwave freezes up.
MB1 - Totally true. Nice bug. Wish I'd spotted that one.


Regarding the Workspace 'Options' drop down menu on Spreadsheet Scene Manager. The 'Options' entry doesn't look like a selectable item. Because it sits at the top of the list, it could be easily missed and mistaken as just the Title of the drop down menu.

This is a shame because this version of this menu with the checkboxes is much easier to use. It allows you move quickly through the list turning things on and off, rather than scrolling through the drop down menu turning one thing off/on at a time.
MB1 - Feature Request


In the Spreadsheet Scene Manager, additional sorting modes such as 'Selected' and 'Reverse Selected' should be ghosted over when not available rather than disappearing altogether. At least that way we get some hint that the option is available.
MB1 - Feature Request


When you resize Spreadsheet Scene Manager to fill the screen, the resize handle in the bottom right hand corner suddenly disappeared. The only way to get it back is to trash your pref files.

Someone else also reported the same problem with the Numeric panel and this bug has been confirmed by other users. PS see screenshots in \topurl{http://www.newtek.com/discus/messages/2/12739.html?1006734508,http://www.newtek.com/discus/messages/2/12739.html?1006734508}
MB1 - I've seen it with OS9 and some of the older OGL implementations but not in 7.5 and not in OSX.


There's a nasty bug with the Window resize handle on the Spreadsheet Scene Manager window which causes a jittering effect when you drag out the size of the window. Then if your not careful you can loose the ability to make the window smaller again.
MB1 - with 7.5 you no longer lose the resize widget but the jittering and flashing of the bottom row of the window looks bad, still. The same applies when you change multiple items in spreadsheet - the rows below the cells themselves flash repeatedly.


In reference to loading Objects into Layout the start of chapter 7 in the LW7 Ref Guide PDF states:

"you can press the + (plus) key on your numeric keypad, which adds the appropriate item based on the active edit mode selected at the bottom of the screen (i.e., Object, Bones, Lights or Cameras)."

I tested this and found that regardless of what mode I was in, if I pressed the + key in Light Edit mode etc, it would still bring up the File Requester to load an Object.
MB1 - UI issue. Should it add a new light for you? Dunno.


The Color Control is sometimes disabled in the Change Surface panel. It would probably be useful to have this option available when your defining surfaces.
MB1 - it's only disabled for default. Once you enter a name the control becomes usable.


When you cut and paste layers from a multi-part object into new layers the old layer names stay attached, but grayed out, in the layers you're cutting from.

To clear the display you have to save the object. Close the object, and re-open it.
MB1 - fixed in 7.5.


Rename a layer. Cut the layer and paste it in a new blank layer. The object takes on it's original name.
MB1 - Fixed in 7.5


When working with the Hub enabled, the content directory setup properly, and an object saved in the Objects folder as box.lwo Everything seems to be working fine, but when I set the 'Automatic Save' option to one minute, I noticed that the little asterisk near the object title (in the drop down Object menu above the Viewports) in Modeler was always present, even after a few minutes which would seem to indicate that the object isn't being saved????
MB1 - Hub autosave has never worked for me in any version of Mac Lightwave.


Pressing the DELETE key doesn't delete the current keyframe as described in section 8.5 of the LW7 PDF Ref Guide. And despite what is written about this in the 'Last Minute Readme' if you check the Key Configuration panel, the 'delete' action has been mapped to the DELETE key. If I map it to another key, it works fine, if I then map it back to DELETE key it still doesn't work.
MB1 - This is resolved in 7.5.


The 'Delete Motion Key' Plugin mentioned in section 8.6 of the LW7 PDF Ref Guide is actually called 'Mot-ify Delete Motion Key'.

If your using the Plug-in and you hit the 'About' button, the About window comes up beneath the Plug-in window and it has a tiny scrollable field seems to contain some useful information regarding 'Keys' but is too small for view properly. (see below)
MB1 - True, if you press the about button in Motify the dialogue sits behind the window and you can't focus it...


If I use InitConfigs I end up with two copies of Sky Tracer ('Sky Tracer' and 'Sky Tracer2'). The first copy doesn't work and brings up a "Cannot load external plugin" error message.
MB1 - Fixed in 7.5


The Preview Options menu item which is mentioned in section 8.9 of the Manual is not available on the Mac Platform. After having spent some time myself looking for this option and chasing it up, I can say that it would probably be a great time saver it Newtek could make a note of this (for other Mac users) in the manual.
MB1 - Yes, some of the preview options for PCs do look good. They're not available for Macs. (Similarly, things like multiple threads and safe mode are not available in the Mac version of Motion Designer - threading would be a huge bonus as currently MD only uses a single thread under OSX)

02-07-2003, 05:43 PM
0047 (Phong)

Backstep to LightWave 6 Chapter Nine: Rendering Options (pg. 9.10)
"Recording Images To Tape".

"With the Serial Port Recording option active, you can instruct LightWave to send record commands to a single-frame controller enabling it to control a VTR deck to record frames."

The above was one of the main reasons why I bought into LightWave; assuming this feature would be redirected to the FireWire on the Mac, allowing me to dump to a digital deck, and despite addressing this as a feature request, and others 'thinking it was a good idea', it was never commented on by the NewTek staff.

In the "Mac LightWave version", I purchased, the manual states "Recording Images To Tape" as a feature of LightWave... and (fwiw) I bought a serial converter to control my older analog decks only to discover that feature was blanked out!

I do not know if this is mentioned in the 7.x Mac versions of the LightWave Manual.
MB1 - Would be good to highlight in the manual just where the Mac version differs from the PC version.

0048 (Plotz)

In graph editor "add layout selected" and "get layout selected" don't work. According to the docs when you select something in layout with these options enabled the graph editor should update with the channels for the selected object. This does not happen.
MB1 - This works properly in 7.5.

0049 (Plotz)

Viper is completely unreliable. It just doesn't accurately represent gamma values from the final render. In some situations it's too bright. It seems like it's too bright when you're working with material settings, and too dark when you're working with bitmapped textures.
MB1 - The nature of Viper. It can't display certain types of calc.

050 (Plotz)

Missing Feature?

The feature list for "Modeling Tools" states: "Animatable Metaballs, Metafaces, and Metaedges".

This gives the impression that you can animate with metaballs style collisions. (i.e. two water molecules that touch and form into one by combining the intersecting triangles). This doesn't seem to be the case. You can model with the collisions...but you can't animate them that way. Once in layout they work just like rigid geometry.
MB1 - No, you could use bones or other deformers to bring the points together, surely?

0051 (Plotz)

Missing Feature?

Under the Layout Workflow & UI Enhancements in the features list is: "Turn on/off XYZ, HPB (Layout)"

This leads me to believe that I can change the labels in the status display from HPB to XYZ. I can't find any way to do this. If it's in the manual I haven't found it.
MB1 - I don't know about this one at all.

0052 (Plotz)

According to the manual: "The plus (+) button on the toolbar adds a new track to the Timeline at the end of the current list of tracks. The minus (-) button removes the currently selected track along with any motions on it. You can select a track by clicking on it."

This doesn't work. I select the track, click the "-" button and it is not removed.
MB1 - this was all reworked for MotionMixer that shipped with 7.5

0053 (Plotz)

In the graph editor the "Autofit Selected" (SHIFT + a) will only work one time. When you first load a channel from the bin and hit autofit selected it works.

When you go to reload that channel from the bin again at a later point (without having first closed graph editor), the autofit selected command doesn't work on it.
MB1 - this seems to be working fine in 7.5.

0054 (Plotz)

Do an F9 render and save as a .tiff file. (24bit or 32bit) The file does not save.
MB1 - this was an old tiff bug that was fixed in 7.5 along with other image loader/saver issues.


The OS9 version of Modeler sometimes freezes up when I'm using certain PS1 fonts. I know this probably sounds like a problem with freeware fonts but no other program I use freezes up when I use them. I have tons of these fonts but it's a bit like playing Russian Roulette when I try to use them.
MB1 - Hard to nail this one. Some PS fonts are problematic for Modeler but a lot aren't. It's hard to know what the issue is. I think a bigger issue is that OSX Modeler 7.5 just can't read postscript Type 1 fonts at all! I reported this bug many times but it never got priority :-)


In chapter 8.14 which relates to the 'Panel Layout Adjustments' in the Graph Editor: It's not possible to drag the border "between the Channel Bin and Curve Edit Window" as described in the Ref Guide. I can see the cursor changing as it does when I drag between the Scene list and Channel Bin but it still doesn't work.

I found out that it was possible, but only after you resized the Graph Editor window (made it larger).
MB1 - that's still true. When you first open Graph Editor (ever) and it opens at it's initial default size you can't drag the window width of the channel bin until you've resized graph editor.

0057 (Plotz)

In OSX you can run into problems if you run your screen at multiple resolutions. LW will always open up the windows at their last size.

If you set you screen resolution at a higher level like 1280x1024, then change it to 1024x768 LW just cuts off the edge of the extra window space that was set to 1280x1024. There's no way to resize this window. You'll have to switch back to the higher resolution and make your best guess at resizing the screen.

This is a big problem for powerbook users who work on site and hook up to larger screens. We get home and we're stuck.

I'd suggest adding a "fit window" feature.
MB1 - would be a nice feature.


In section 8.19 of the manual it reads:

"To delete keys from curves:
1 Select the channel curve(s) and then the key(s).
2 Press the DELETE key."

I tried this but it didn't work.
MB1 - works here.


In the Graph Editor 'Curve Edit Window pop-up menu' the 'Paste Selected Keys' menu option doesn't actually paste the selected keys but rather any keys that you've previously copied using 'Keys > CopySelected keys'. The menu option would make more sense if it was called 'Paste Keys'.

Section 8.26 of the Manual supports this idea as it states "use the Paste Keys command on the Curve Edit Window pop-up menu" which is obviously referring to the 'Paste Selected Keys' menu option.
MB1 - I think this is just a terminology issue in the manual and UI.


This does not happen, even with the Hub and Content Directory setup and properly and Auto Save set to 1 minute. I'm not getting any periodic requests to save changes. Everything else seems to be working. RE section 3.2 of the Ref Guide.

"When Layout or Modeler are running, the Hub will periodically request that the applications write their recent changes to temporary files. The frequency of this Automatic Save is set by the Hub option. The temporary files are located in a LWHUB directory inside your normal"
MB1 - Hub autosave doesn't work on the Mac, afaik.


The Content Directory wasn't setup properly for some of the example scenes that ship with LW. For example the BasicDVE_Cloth_FlyOut.lws. If you set 'Content' as the Content Directory and try to load this scene it will ask you for the images.
MB1 - No comment.


If I get stuck on a really slow Render and I decide to bail out, I've noticed that sometimes when you press the 'ABORT' button nothing happens for quite awhile, yet the ESC key seems to work every time instantly.
MB1 - can't duplicate that one at all.


I searched my hard drive for LWEXT3.CFG it doesn't exist. I think for Mac users they meant 'LightWave Extensions 3 Prefs' in section 4.4 of the ref Guide. If it's worth mentioning for PC's why not for MACs?
MB1 - yes, would make more sense for Mac users if this was pointed out in
the manual.


In the Preset Shelf if you try to load the Gold Reflection preset that ships with LW, you get an error message saying "can't find GoldReflection.tga".
MB1 - I'm not even going to try..:-)


Some of the example scenes that ship with LW are missing objects. for example the ArmDeform.lws brings up a dialog which reads:

Can't find "Objects/weightedarm.lwo". Select an alternate file?

I did a search of my hard drive and ended up finding it in HD:

It seems that a few of the other example Scenes which use objects from the _Features folder aren't loading properly.
MB1 - Yep, this happens with the content on the CD sometimes. Doesn't seem like that big a deal, though although to a newbie it might look like an error..

02-07-2003, 05:45 PM

Load the Blubber.lws and it brings up a dialog asking for missing AVI Plug-ins.
MB1 - Yep, this happens with the content on the CD sometimes. Doesn't seem like that big a deal, though although to a newbie it might look like an error..

0067 (Plotz)

When you add lights to a scene the new light is not enabled to affect materials with a BRDF shader.

Unfortunately the new light won't affect diffuse channel until it's checked on in the BRDF shader dialog. This eliminated the ability to separate diffuse and specular lights from each other when using BRDF.
MB1 - this behaviour is now changed in the current beta. That is, a new light will be turned on in the BRDF panel (instead of unchecked as in 7.5 release)

0068 (Plotz)

Try as I might I can't find an option in the spreadsheet editor for object light exclusion. I can control the lights, or the objects, but there doesn't seem to be an option n the render flags for objects to include/exclude lights.

Also the columns of the spreadsheet editor seem to autosize to numeric values rather than header text. This really scrunches a lot of the text headers down to un-readable. I can manually resize the columns, but when I switch to another mode they squish back down again.
MB1 - True for include/exclude and I'm not sure what he means by scrunching the text. Maybe fixed in 7.5 anyway?

0069 (Plotz)

Forgot to add this to the last one.

The COMMAND + Q key combo to quit the app won't work when the spreadsheet is open. You can see the menu (the actual mac menu bar) highlight when you click it, but no action is taken.
MB1 - this is fixed in 7.5.


I opened the Hub on it's own, set the Automatic shutdown to 1 minute and was surfing the web for a while in Netscape, but the Hub stays open, nothing happens.
MB1 - Auto features in the Hub don't work.


I remember reading somewhere that Lscripts are platform independant?? But after a number of problems, crashes etc, I'm not convinced that this is accurate. Plus at times I'm left wondering:

Will it work on a Mac?
Will it work on 7b?
Is it a Modeler or Layout Lscript? (Maybe a simple question???)
Is it a R/T Script?

There must be an easier way to work this stuff out if it's not obvious or the script fails to load etc.
MB1 - there *have* been issues with LScripts working on PCs but not Macs but Bob's taking care of a lot of this stuff.

0072 (Plotz)

In many of the dialog boxes for renaming things the "OK" button doesn't work...you have to actually hit the "Return" or "Enter" key.

For instance open up the skelegon tree and select just a single letter or string you want to change. (example: changing the name "R_UpperLeg" to "L_UpperLeg" by selecting the R and changing to an L.)

Now hit the "OK" button. You're object has not been renamed.
MB1 - this is the way LW has always worked. You have to hit Enter/Return/Tab to get inputs to 'stick' in input fields. Very un-Maclike but LW has always been this way.


The Master Channel plugin doesn't load, it brings up an error message.
MB1 - fixed in 7.5


In section 7.15 of the LW7 Manual it states:

"To move the pivot point in Modeler: Select Items > Tools: Pivot > Move Pivot Point Tool to activate the Pivot Point tool and move the crosshairs to a new position in any viewport. It is just like moving a point."

This is actually the instructions to move the pivot point in Layout.
These instructions are also repeated on the following page. ie Section

"To move the pivot point in Layout:
1 Select the object.
2 Select Items > Tools: Pivot > Move Pivot Point Tool
3 Move the pivot point as you would any item in the Layout. (If you select the Move tool and look at the object's position settings, you will see that they have been changed to compensate for the movement in the pivot point - the object will not visibly move.)"
MB1 - I guess this needs to be rewritten

0075 (Michael Fessenden)

It would be kind of nice if Modeler and Layout appended the file extensions for files when you save them...
MB1 - Feature request.


Missing Feature??

I'm using the default Menu Configuration with LW7b and I've scanned the Plugin and Lscript directory, yet I don't seem to have the Additive menu group mentioned in section 7.11 of the Manual. (see below)

You can numerically add to Position, Rotation, and Scale values by using the functions in the Items > Tools: Additive menu group. They work like editing the input fields in the lower-left corner of Layout, but add to the existing values instead of replacing them."
MB1 - the menu configs are changed now in 7.5. Additive changes are done via keyboard shortcuts or you can add them to the menus if you like...


I noticed a number of times if your adding surfaces to the Preset Shelf by double clicking in the Surface Editor 'Preview Window' it doesn't always seem to work. The new preview icon doesn't always appear instantly in the Preset Shelf window. But then if you come back to the Preset Shelf window later on, I found multiple copies of the same preset.
MB1 - this still happens for some reason. You can have presets open and double click on the preview window and nothing appears in the preset shelf. You can then double click again on the preview an all of a sudden two presets will appear in the shelf. There seems to be something odd about the way the presets are generated or, at least, it can be slow to


If I quit out of Layout with Surface Presets in the Workspace Library of the Preset Shelf I'm finding that some (not all) of these preset have disappeared when I relaunch Layout.
MB1 - No, I never 'lose' presets unless they somehow get corrupted.


More of a features request but it would be nice if the LW Color Picker came with a web palette.
MB1 - I guess there'd be some issues squeezing floating point down to 256 colours. Insane :-)


After going into the Render Options panel and correctly setting up 'Save RGB' under the 'Output Files' tab (I tick the check box, specify the location to save the file and give it a unique name), I press F9, but the image is not being saved.
MB1 - F10 is the hotkey for rendering the scene and saving images or an animation. F9 is the hotkey for rendering the current frame.

02-07-2003, 05:47 PM

I notice that when I'm working with 3rd party plugins, that the
background is not redrawing, when I move the plugin panel around over
the top of the Viewport. (see example)
MB1 - F10


I've recently had two big sessions, working with the Preset Shelf, organizing surface presets, going back through some of my old scenes, looking for stuff that might be worth salvaging.

Anyway in the course of this process I have noticed a number of oddities:

1. Moving one preset to a new Library, the preset refused to move and then I noticed that it was present in both libraries.

2. If I quit out of Layout with presets in the Workspace library, I sometimes (not always) found that 'some' (not all) of these presets would be missing when I relaunched Layout.

3. While moving presets around, for example, I would be moving a texture preset to the nature section but I would then end up in the metal section with the 'Nature' title at the top of the panel. This bit sounds bizarre, I can't find the words to explain it much clear than that. Something is obviously wrong there.
MB1 - Nah. Presets are fine, just slow to update. I can't duplicate any missing presets here.


Layout just crashed on me after selecting 'Save All Objects' as a result it has wiped one of my objects. The object that I've circled in this image was completely erased. When I open this object in Modeler it contains no geometry. Luckily I do have a backup on CD, but it was a nasty surprise.
MB1 - Yeah, sometimes we all get screwed geometry. I've currently got a scene that his some corrupted morphmixer information which prevents an object in that scene from loading but this happens across all platforms and all software products...no?


My results from using the Inertia Displacement Plugin in the Object Properties panel seem very clunky and awkward. I'm not sure that it's usable.
MB1 - Inertia seems fine in 7.5


Not sure if I'm alone in this, but Point Clone Plus crashes Modeler (7b OSX 10.1.3)every time. The dialog box comes up, but when I press 'OK'.....bam.
MB1 - Point clone plus seems fine in 7.5.


The Serpent Displacement Plugin in the Object Properties panel seem very mediocre. It requires a large amount of computation power for very poor results.
MB1 - Serpent is almost unusably slow under 7.5 OSX.


Sounds a bit funny :-) 'Subdivision' is spelt wrong in the Autopatcher

I'm now using Mac Modeler LW 7.5 OS9
MB1 - True


Quicktime is not usable for image maps or backdrops when the comp frame rate is anything other than 30fps. For example, when both the Quicktime backdrop and the comp are set to 25fps, Lightwave will try to conform it to 30fps by doubling every fifth frame.
MB1 - Broken in 7.5, fixed in the latest betas.

Clone Hierarchy....does not work.
MB1 - Broken in 7.5, fixed in the latest betas.


LS commander, either corrupts prefs, or crashes either way it doesn't work?
MB1 - Definitely broken in 7.5 release. This is fixed in the latest beta.


skelegon name panel refuses to accept entry by hitting the "OK" button. must hit return or enter for change to take.
MB1 - Yes, LW requires an Enter or a tab to get input fields to stick before you hit OK.

02-07-2003, 05:49 PM
Ok, now we have a bit of continuity!


02-08-2003, 05:57 PM
Thanks Chuck, the new forums look great :)

02-08-2003, 08:33 PM
I came across something in LW 7.5 that wasn't mentioned on the list. When using the LW Color Picker, I can only enter 2 digits in the R and B fields, but I can enter 3 digits in the G field. Weird!

Anybody else seeing this? I'm on a 1 GHz TiBook with the Mobility Radeon 9000 card and OS X 10.2.3.

02-10-2003, 09:23 AM
Recently I have run into a couple of problems with the maximize window button.

the first one: when clicked it it made my layout window like 5000 px wide. I wouldn't restore... I had to exchange the pref. files.

second one: happened last night... hit the button by mistake and made the whole window an OGL window but it was all white and around 4000 px wide

the tabs worked but the widow wouldn't restore. Had to replace the pref file.

anybody seen this?

02-10-2003, 12:17 PM

I got this too. Admittedly, I'm new to LW on the Mac (i've used LW on PC for years), but my solution was to change out the .prefs (as you said). Next, before I opened Modeler or Layout, I hid the Dock (alt+apple+D) and then maximized their windows. Now I just hide the Dock when I'm using LW, and I don't, under any circumstances, hit the little green button. :D

I would like to see this working properly.


02-10-2003, 03:09 PM
he, he yeah that's the best advice... I was just wondering if anybody at Newtek could recreate the problem so it can be consider as a legitimate bug.

I am using the graphite color scheme so sometimes I hit the wrong button:D

02-10-2003, 08:24 PM

The Quadric Tool produces some sloppy errors in the mesh. They become more noticable when you convert to a SubPatch. LW7.5 (OS9)

BTW SuperQuadric seems to work much better


02-11-2003, 11:14 AM

skelegon name panel refuses to accept entry by hitting the "OK" button. must hit return or enter for change to take.
MB1 - Yes, LW requires an Enter or a tab to get input fields to stick before you hit OK.

i still have an arguement with this....Numerical entrys , yes require enter or return, but this is a text field?
If i hit "Q"(name surface) i can type a new name and click ok and it takes
without enter or return....
or i can rename a layer and click ok and it takes it...
but not with the skelegon panel?
oh well. silly anyway i suppose

02-11-2003, 03:01 PM

Issue: Middle Mouse functionality does not exist for multi-button mac users. I believe the "basic" MMB function is Ctrl-Mouse for LW-PC, but there is no key-mouse combination for extended MMB functions on the Mac.

Suggestion: Cmd-Ctrl-Lt Mouse?