PDA

View Full Version : Normal/Disp Maps from ZBrush - Successful Results With Shadows Anyone?



Deux
12-23-2004, 03:13 AM
Hi 'Wavetamers

Ok, just to set the scene... I have read several of the discussions in the Community already about using normal/displacement maps generated from ZBrush in LW and have got some successful results already... however, the problem I am now running into is that neither solution is proving 100% successful when it comes to rendering either raytraced or shadow-mapped shadows.

Normal maps seem to produce the best visual result, although I get a darkening of the object that means it never gets illuminated properly. Normal displacement using 16bit grayscale images is ok, but in both situations there is artifacting in the shadows generated.

Has anybody achieved good, shadowed renders using either normal/displacements maps?

I've tried LW's own Normal Displacement plugin, Marvin Landis' and also Lynx's. Kudos to the authors for their work, but I'm sure they have had to do what they can with LW's renderer and it just doesn't seem to cut it. Not looked at Microwave yet at all though.

Sadly, it looks like I will be moving over to another 3D package... for this project certainly... as I don't think LightWave can achieve what I'm after.

Cheers,


-: Deux :-
Lead 3D Artist - Satellite

IZZE
12-23-2004, 04:40 PM
I have not had any problems with my displacement maps and Lynx's plugin. Are you sure you have enough poly's? Are you subpatched?

Are your RGB values set correctly on your normal map?

Show us the artifacts that your are getting.