View Full Version : Network Rendering - FLX Files

04-11-2003, 03:10 PM
I am getting my feet wet with Network rendering. After following the instructions in the manual I finally got a number of PC's to render a scene together using ScreamerII. The only problem is that I am only getting the frame output in FLX image files. I cannot read these files in any applications that I try and use, e.g. Adobe Premiere 6 or Adobe Photoshop 7. Please could someone tell me how I can network render image files in a recognizable format such as tga, jpg etc..... or where I can get an application that will read flx files and convert them to tga, jpg etc...


04-24-2003, 06:32 PM
I'm having a similar challenge on two Windows machines. The machine that has Lightwave installed will correctly save frames to .png files, the other machine produces .flx files for its frames.

I another thread about Linux and networking rendering someone was nice enough to list the supported frame file formats for Linux. I guess we need to experiment with different formats until we find the one(s) supported across a Windows network render.

I found that PNG did not work. I will try Targa file format next.

04-25-2003, 08:07 AM
it sounds to me like your machines that do not have LW installed on them cannot find the lw config files. Make sure that you have properly pointed LWSN to the directory. In Win2K they are usually found in the documents and settings folder (in local machine subfolder). Have you tried lightnet? I found it to be much simpler than screamernet, and there is a great tutorial on his site. Here is the link. http://www.joejustice.org/lightwave/lightnet/.

Good luck,

Troy McClellan

04-28-2003, 10:04 PM
At first I was able to find a few error messages when the scene referenced objects via patnames known only to the LW host machine. Once I resolved the object references so they were visible via the mapped directory, all the error messages went away, but still I get .flx file results.

I wonder how I can tell for sure that LWSN.exe can see the config file. I can see it via the command shell. The config file contains pathnames to each and every plugin, I've tried UNC (\\machine\path) and mapped drive (L:\path) pathnames in the config file, neither causes any error message to appear -- hardly proof that all is well.

The manual is very lean on such information.

04-29-2003, 11:36 AM
Again, don;t worry about these problems. Go to http://www.respower.com and just let it go. Get your stuff cheap in 1/100th the time.

04-30-2003, 09:01 AM
One thing that i found i had to do was to place the output directory (where you are saving the files to) in the same directory as my Lightwave installation (L:\LightWave_3D_7.0\Renders). So basically i just created a Renders folder in my Lightwave installation directory. I know its not much help but I think its worth a shot.

04-30-2003, 07:57 PM
Discode: In fact, I took that easy way out from the beginning. I figured what could be easier than to have everything in one directory on one mapped drive. Sadly, it didn't solve the problem then or now.

I'm still guessing that the issue is in resolving/accessing plugins, but I'm unsure as how to really validate that they are seen from the other screamernet nodes.

Trentonia: Suggestions to use www.respower.com are fine if I stand to collect money for work done, but I'm just a hobbyist so to speak, so spending more money will be my last resort.

05-02-2003, 12:47 AM
It's been a while since I've set up a Windows screamernet, but...

You may want to check your lwext3.cfg file. This is the file that lists the plug-ins. If you get something like this:

{ Entry
Class "AnimLoaderHandler"
Name "AVI(.avi)"
Module "C:\\LightWave\\Plugins\\Input-Output\\AVI.p"

Your render machine will look to it's own C: drive for the plug-ins. You could (a) copy the the plug-ins to the render machine (with the same directory structure), (b) (save a backup of the file) use notepad to change the path names in the config file or (c) (save a backup of the file) clear the plug-ins and re-add them within lightwave but this time going through your network path.

Then again, I may be wrong about this. :)

ScreamerNet would be a heck of a lot easier to use if it gave us proper error messages, but it doesn't.

BTW, any of the single frame file formats that are available will work across a windows network. FLX is the only file format that shows up on the MAC when no plug-ins are added.

good luck

05-02-2003, 08:08 AM
There are a couple more options that you can try as well.

Try copying your "lwext3.cfg" file from the installed computers default location to the same users location on the rendering computer that had the problem.


You could open layout. Then go to the image editor and load your .fx files as a sequence. Then go to the scene tab and click on compositing. Then load your sequence as a background image. Then set the scene length to match your sequence lenght and render the scene. If i am not mistaken the .flx format is something that is proprietary to lightwave. That is why you couldnt find any other applications that will open those files. I could be wrong about the format being proprietary though. Also you may want to set your camera res and pixel aspect in your new scene to match the one that rendered as .flx files. Im not sure if this makes a differnce or not since it has been quite a while since i have tried using .flx files in Lightwave.

Anyway hope this helps some.


05-02-2003, 08:13 AM

I beleive Mr. Burman is correct however. Readding the plugins through your mapped network drive on the computer with Lightwave installed should fix your problem as well.

05-02-2003, 03:53 PM
Thanks to Discode and Dwburman, I have addressed the LWEXT3.cfg file issue, I think -- That's why I'm looking for a solid test. If I select the rendering output frame format for a scene to be 24bit PNG I get .png files on the LW machine, on the other PC I get .flx files. Setting TARGA as the output frame results in .tga files from each machine.

Could that still be a LWEXT3.cfg problem?

Here's a sample of the LWEXT3.cfg file:
{ Entry
Class "AnimLoaderHandler"
Name "AVI(.avi)"
Module "L:\\Plugins\\Input-Output\\AVI.p"

The L: drive is mapped the same on all PC's to make everything work. All the other files, command directory, content directory, program directory are contained in L:\ It seems logical that if the programs are found, the command semaphore files are created and updated, rendering happens, content is accessed, etc., that the plugins should also be found.

I didn't see any restrictions on file access permissions, but I set them wide-open on the L:\ directory and sub directories.

Maybe this is as good as it gets? I just have to live with TARGA file formats? I'd rather use PNG as it's smaller.

As Discode suggested, I could take all the PNG/FLX/TGA files into image editor to produce my video/animation output. I think they all need to be the same format for that to work.

Discode, I believe you are correct that .flx is a LightWave proprietary file format.

05-02-2003, 11:47 PM
It still isn't finding the config file. The windows version of LW has 4 native file formats: .flx, .iff, 32bit .iff and .tga. I moved my lwext3.cfg to my desktop and they were the only file formats available to render to.

Try doing a search (find file) for lwext3.cfg on your hard drives. I think I once had a problem with multiple config files on a machine and couldn't figure out why things weren't working. ;)

Make sure you're pointing to the right place. Maybe look at the config file for your hub to see what config files it is pointing to.

05-03-2003, 02:32 PM
I'm open to the idea that the LWEXT3.cfg file is not getting accessed, so here's more of what is on my system. Perhaps there is a clue here that I've overlooked. This is a Windows 2000 Professional OS, so some of default file locations are a little messier than WinXP or Win98.

Here is my LWHUB.cfg file:
FileRequesterServer $Default
ColorPickerServer $Default
DialogCenter 513 393
WindowShape 10 362 308 540 171
TimeOptionsIndex 1
SaveClientIndex 0
ProcessName LWLayout L:\Programs\Lightwav.exe "C:\Documents and Settings\dude.thisPC"

C:\Documents and Settings\dude.thisPC
ProcessName LWModeler L:\Programs\Modeler.exe "C:\Documents and Settings\dude.thisPC"

C:\Documents and Settings\dude.thisPC
AppConfig FileRequesterServer VBFileRequester
AppConfig ColorPickerServer LW_ColrPikr
AppConfig FrameSliderLabel 0
AppConfig ContentDirectory L:\Programs\Content

I don't see any reference to a LW3.cfg or LWEXT3.cfg file in the LWHUB.cfg file
I'm guessing that the pathnames in quotes (") are specifying the location for Lightwav.exe and Modeler.exe to find/load their respective .cfg files? Should I copy the .cfg files to my L: directory location and update these pathnames to reflect the L: location?

There is a copy of the LWEXT3.cfg file in "C:\Documents and Settings\dude.thisPC" directory , I made sure it is an exact copy of the LWEXT3.cfg file in L:\.

The startup batch files I use to initiate LWSN services contain:
REM ## Launch a Screamernet node
REM ## Edit the directory paths to suit your system
echo init >"L:\Programs\COMMAND\job1"
L:\Programs\LWSN.exe -2 -dL:\Programs\CONTENT\ -cL:\Programs\ L:\Programs\COMMAND\job1 L:\Programs\COMMAND\ack1

So, it seems that the config file can be found at L:\Programs\LWEXT3.cfg and I can validate that path in a command_prompt shell.

The content is being found because I get render results.

The plugins may or not be found (the issue you raised about copies of the LWEXT3.cfg file and possible conflicts with pathnames in the LWHUB.cfg file), but the pathnames in the LWEXT3.cfg file do resolve from a command_prompt when tested on both machines.

Is something hidden in the registries that's causing this problem?

05-11-2003, 11:39 PM
AFAIK there aren't any registry settings that'd cause problems.

It's been a while since I've set up a screamernet on Win2k so I'm kind of rusty. I tended to use LightNet for rendering, but things still needed to be set up right. You could try some of the other network render controllers.

Is your LWext3.cfg in L:\ or L:\programs. You're telling LW that it's in the profgrams folder.

There is another way to test if your plug-ins are being read or not. Try rendering a scene that uses a plug-in (like vector blur or some shader). If your render computer can't find the plug-ins then the frames it renders either won't have that effect on the frames it renders, or it won't render the frames at all.

I'm getting too tired at this moment to think too clearly :) g'night

05-12-2003, 03:33 PM
My LWext3.cfg file is located in L:\Programs\LWEXT3.cfg

The contents of the file use pathnames that do resolve from all my PC's, such as:

{ Entry
Class "ImageLoader"
Name "LW_PNGLoader"
Module "L:\\Plugins\\Input-Output\\PNG.p"

That is the very plugin I'm trying to use. I want to save the rendered frames in .png format.

Even though the files seem to exist, the pathnames seem to match and resolve, something is broken and I'm at a loss to discover what it is.

I guess I could try the brute force technique of copying the entire programs directory locally, so that the programs and plugins are local. Seems like a waste of disk space and time, if the file names already seem to match and resolve. [But I admit that something somewhere isn't right because it only works correctly on the LW machine]

Here's a copy of LWSN running on the non-LW machine:

L:\Programs>REM ## Launch a Screamernet node

L:\Programs>REM ## Edit the directory paths to suit your system

L:\Programs>echo init 1>"L:\Programs\COMMAND\job2"

L:\Programs>L:\Programs\LWSN.exe -2 -dL:\Programs\CONTENT\ -cL:\Programs\ L:\Pro
grams\COMMAND\job2 L:\Programs\COMMAND\ack2
LightWave x86 ScreamerNet Module (Build 582)
CPU number: 2

Current directory is now "L:\Programs\CONTENT\".

LightWave command: init.

LightWave command: load.
Loading "L:\Programs\Content\Scenes\BeamingText2.LWS".
Scene loaded.

LightWave command: wait.

LightWave command: render.
Allocating frame buffers.
Allocating segment buffers.
Updating geometry.
Moving TEXTflat.
Moving Beam.
Transforming coordinates.
Removing hidden polygons.
Computing polygon distances.
Sorting polygons.
Rendering frame 2, segment 1/2, pass 1/1.
Rendering transparent polygons.
Integrating pixels.
Rendering frame 2, segment 2/2, pass 1/1.
Rendering transparent polygons.
Integrating pixels.
Writing RGB image to L:\Programs\Content\Beamed002.flx.
Frame completed.
Last Frame Rendered: 2.
Rendering Time: 2.6 seconds.
Freeing segment buffers.
Freeing frame buffers.

As far as I can see, it seems to be happy, until it saves the output file. I chose the .jpg output format because it is non-native and will highlight the problem. So, the plugins silently fail.

05-12-2003, 03:51 PM
Originally posted by videoblaze
L:\Programs>L:\Programs\LWSN.exe -2 -dL:\Programs\CONTENT\ -cL:\Programs\ L:\Pro
grams\COMMAND\job2 L:\Programs\COMMAND\ack2
LightWave x86 ScreamerNet Module (Build 582)
CPU number: 2

The offending character is the trailing \ in the -cL:\Programs\ line above. If I remove it from the .bat files I use to start up LWSN, then it works. Wow, what a tricky pain.

Thanks to all you fellow users that offered ideas, tips, suggestions, examples and tutorials, it helped me eliminate possible dead-ends and save a lot of time.

Happy rendering!

05-13-2003, 10:27 AM
Good deal. I am glad you finally found a solution....