View Full Version : USB dongle still parallel?

04-09-2003, 11:46 PM
I was doing some system cleanup work and it dawned on me that I was no longer using my serial or parallel ports. So I disabled them in BIOS to free up some resources. Guess what? LW wouldn't initialize ... couldn't find dongle.

Now I've got a USB dongle, but from reading in this forum I gather it used to be a parallel port dongle.

So apparently, the USB dongle still needs the parallel port enabled in order to be found by LW? Seems like a waste of system resources. Do I need the new Sentinal drivers to get around this?

Or am I missing something obvious?

04-10-2003, 11:52 AM
Perhaps this (preceding message) is to obtuse a question for the forums, and I should just email it right to [email protected] I just hate to load new drivers unless I strongly believe I need them.

Hell, if I could get one of those original parallel port dongles I might just use it and free up a USB port ... had to buy a hub just to accomodate the dongle as I only have 2 ports on my mobo.

04-11-2003, 06:29 AM
USB is inherently a parallel-port-based technology, so yes, you do still need the parallel port enabled.


04-11-2003, 08:05 PM
No, that can't be ... as I type this my USB mouse, webcam and printer are all still working with the parallel port disabled. Only the dongle seems to be affected, as LW still gives me that "Can't Initialize" message. When I re-enable the port LW boots just fine.

I'm guessing that it's some "legacy code" in my USB dongle that makes it sensitive to the parallelport being off, even though it shouldn't really need that port.

I hate wasting resources on my main machine.

I'll probably have to contact LW tech and see what they have to say about this. I'll post what they tell me.

05-06-2003, 11:24 PM
So here's the final answer, best as I can tell ...

NewTek tech told me to try the new Sentinal drivers from Rainbow (about a 5M DL) and that it might solve the problem.

It didn't. Messed things up royally. Had to reinstall LW along with original driver to get back to square one. From what I read elsewhere this new driver is indeed needed for XP, but all it did on my 2K machine was cause hangs.

Answer: your USB dongle still requires the parallel port to be enabled, likely due to legacy code in the Sentinal drivers.

Moral: You still can't free up IRQ7 by disabling the parallel port, even if nothing is using it, as long as you need the USB dongle.

05-07-2003, 05:56 AM
That really rots! Did you let Newtek know the situation?

05-07-2003, 08:37 AM
Something about that doesn't sound right... I installed LW on my (new) laptop so that I could use it on the road, and it worked fine for a while. Now my laptop has no parallel port on it at all, so that makes me wonder about this issue to begin with, BUT last night I tried to crank up LW, and it insisted on running in demo mode on both my desktop and my laptop, although I did notice that without the dongle drivers installed, it wouldn't even launch at all.

So I launched Aura on the laptop, and it's asking me to register... which makes no sense, since it's a registered copy, keyed to the same dongle as LightWave.

05-07-2003, 08:53 AM
Frickin weird! I had thought about switching out my parallel for a USB, but think I'll hold off on that...

05-07-2003, 09:28 AM
Originally posted by mattclary
Frickin weird! I had thought about switching out my parallel for a USB, but think I'll hold off on that...

I upgraded because I knew that it would not be long before I wound up with a machine that had no parallel port... but now I'm just irritated by the fact that NewTek is still willing to tolerate inconveniencing the customer like this for nothing.

(I know why the use a dongle... I just also know that it doesn't accomplish the goal.)

05-07-2003, 10:38 AM
Yeah, I kinda wish they'd ditch it.

05-09-2003, 02:44 PM
Yeah, I reported it to the NT tech who had advised me, and told him to forward the comments on to Rainbow. Maybe the next driver version will have it fixed.

05-09-2003, 02:51 PM
I'm going to bug NewTek's tech support tonight to see if I can get this issue resolved in a timely manner.

05-10-2003, 09:49 AM
Good luck. That latest Sentinal driver was posted like two months ago. I wouldn't expect the next revision real soon.