View Full Version : SN seems to hang on loading scene file

11-22-2004, 04:45 AM
Good Morning,

I decided to take advantage of my home network having spent a little over 50hours rendering out a 30second camera walk-through of my house model on 1 computer, I'm pleased with the outcome as I feel very much the novice.

I read the manual on SN in the LW manual, got scared... Found matt's excellent PDF and then video tutorial and spent the best part of half a day tinkering to get it working on 2 computers running Win98SE.

In short, I have successfully setup ScreamerNet with 2 nodes. I loaded in a simple scene of 120 frames as a test and it worked a treat.

Now onto the problem. I then "Add Scene to List" having reset everything (knowing it works correctly) and load in my house project scene (from the same content directory) with only 10 out of 720 of the frames pre-set to render out. I get the following message, which is correct in the LWSN DOS box:

LightWave command: load.
Loading "//network/address/contentfolder/scenes/house.lws".

(Note can't find backslash key on this keyboard so had to use forwardslash as demo) Anyway it sits there indefinitly (left it upto 20minutes and nothing) also same problem when trying this on 1 node (master computer).

Can you think of any reason that might cause this to happen?

* plug-ins (I can't think of any non-standard ones I've used)
* texture files (image files for wallpaper etc)
* sub-patched content
* Multiple cameras (only 1 used for animation)
* Hub being active

All i can think to do next is to copy that content directory to a safe place and to start pulling it apart until it works: blank all textures to default etc

Sorry for such a long post and vaguness



11-22-2004, 05:22 PM
Well I pulled apart my scene and blew out all the textures so all surfaces used the default texture so no texture images were linked in, I deleted all non-essential items from the scene. No change, LW was still hanging at this point.

I was praying it wasn't the model so to test it I created a new scene with just the model in, set 10 frames and rotated my camera around the model and tried Screamernet rendering, which worked.

I had eliminated everything I could think of and put it down to the scene file itself being problematic. I searched the forums on several avenues and "spreadsheet" kept cropping up. I read somewhere I think on NewTek's site that this problem was solved in version 7.5c and upwards (evidentally not the case). Carried on reading and decided to dissect the scene file in notepad.

7 repetitions of plugin 1 spreadsheet end plugin. So having backed up my files I deleted all instances of these and voila everything ran perfectly.

soooo... OMG !!! that was frustrating. Well this thread might serve as another source for others using the search feature to resolve any issues.

I'll most likely be back tomorrow with another problem :)

take care


11-26-2004, 09:32 PM
You've just hit a big issue... There's some other issues like FullSceneParamEval that can also cause SN to barf... I wrote a tool to help - Lean Clean Scene Machine.

Process your files through LCSM (Lean Clean Scene Machine). It'll clean up all that stuff. It does it in bulk, so if you have a lot of scene files that don't work, you can clean the lot at once... It will also clean and fix other issues, optimise parts of the scene, check emitters and dynamics have saved motion files and more...

At the moment, NewTek Europe is the exclusive place to get it - Its free, I wrote a PDF manual for it, and should work on both Mac and PC (its a compiled LScript):