PDA

View Full Version : Slow render times on Mac G4



Bill K
11-16-2004, 08:08 AM
I am trying to complete the 3D Garage Lightwave 8 chandelier tutorial and light & surface the object in Layout. I am working on a Mac G4 1.42 GHz with 2 gigs RAM, Radeon 64 MB video card. The render time is 10 - 15 minutes for a preview in the Render Status window. Is this normal?

Any advice/insights on how to speed things up would be greatly appreciated. The options I have thought of so far are: getting a G5 (most $$$ option); a better video card; using FPrime to preview.

Thanks for any replies.

Bill K

eblu
11-16-2004, 01:59 PM
bill,
both the fprime, and video card options will not affect final render times in LW's rendering engine.
fprime supplants LWs renderer, and the video card is not used at all by the renderer.

you are right that a g5 will have some impact on the render speed, but I'd like to suggest a much cheaper alternative...
turn down the options set in your render panel and your camera panel...

for instance what level of antialiasing are you using? most renders only need "enhanced low", if you are raytracing anything (shadows, transparency, reflectivity...) turn down the bounces to 2-3
turn off "extra raytracing optimization."

and if you are only previewing, and don't yet need to see the finished product, turn everything off.
scale down the camera output (in the camera panel, theres a handy scale option for the render dimensions 50% ought to speed up your render by a factor of 4 in most cases) turn off antialiasing altogether.

I have never done the tute you are referring to, so i have no idea what times you should expect, but you can always get faster renders by turning off some bells and whistles.

Bill K
11-16-2004, 05:48 PM
Thanks eblu:

I tried decreasing the camera resolution to 50%, increasing the Segment Memory Limit to 2000 (I have 2 gigs of RAM in my G4 1.42 GHz), decreasing the render and display subpatch settings down to "1", turning off "Ray Trace Optimization" - along with everything else in the Render Settings being off, anti-aliasing was off before and still is off; and Layout STILL crashed following a long render time with VIPER open when I made changes in the Surface Editor and pressed "F9".

I also tried trashing all the prefs and re-scanning plugins - twice.

Perhaps reinstalling LW8 may help; I plan to try that next.

Thanks for your input, eblu. Would I be able to at least "see" what I am working on if I were to use FPrime instead of using VIPER?

Bill K

eblu
11-17-2004, 01:42 PM
turn the segment memory limit DOWN.
i would be amazed if Lightwave could even address that much memory.
set that to 64

or the minimum that LW requires to make 1 segment.

Bill K
11-17-2004, 08:06 PM
Thanks again, eblu. The Segment Memory Limit was originally set at "32".

Bill K

moubctez
11-18-2004, 06:42 AM
Is it dual-G4? If so, try increasing number of threads. 2 should be okay, but sometimes I find 4 rendering faster.

Also, if you have any null-objects in your scene, make them inactive in the Scene Editor.

Try using spotlights with shadow-map, instead of other light sources with ray-traced shadows.

You can crank down other things as well (like anti-aliasing level, or subpatching).

Good luck :)

Bill K
11-18-2004, 08:29 AM
I e-mailed Worley re: my difficulties and asked if they thought FPrime might provide a solution to enable me to "see" what I was doing. After dropping all render settings off, I decided to "go for broke" and turned on everything: radiosity, caustics, antialiasing, etc., etc., - just to see what would happen. When Worley Labs asked me to send them the file, I inadvertently sent them the file with all those settings on. I have a dual G4 1.42 GHz with 2 gigs RAM and it was SLOWLY (very slowly) trying to render a single frame - I gave up & aborted the render.

I sent a second e-mail to Worley that the files I sent had different render settings than what I'd described previously:

"We noticed that. :~)

We have a 2.4gig PC here and it took FPrime about 30 seconds to generate a preview with the full settings including radiosity.....in normal scenes, though, the FPrime interactive preview window usually starts up immediately.

One big problem we noticed is that you're using Subpatches on an object that already has a high level of polygonal detail....which is a huge overkill ( the scene has over 1.2 million polys at subpatch level 3 ). We'd suggest turning off the subpatches in Modeler and just tripling the non-planars....as it would be a lot easier than remodeling the mesh to advantage of using subpatches.

Perhaps this is because you're using 2 layers for realistic glass but we noticed that if you do a merge points and unify polygons, almost 100,000 polys are eliminated. Sometimes it's easy to inadvertently double up your mesh during cut/paste operations.

So it looks to us the reason for long render times is in the mesh, once you get that straightened out you'll be a lot happier."

I am going to try Worley's suggestions, lighting suggestions, and also try using FPrime. My thanks to everyone for their input.